aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-05-11 18:34:57 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-05-11 18:34:57 +0000
commit88bfe4bd43787219ab4de75bd68c490c98776dfc (patch)
tree634e1ef4990207301493f26b46d80abe56b9f2b3 /math
parent9e8bfe9c71187ea60ac9f3a55c0c7bde80d76033 (diff)
downloadports-88bfe4bd43787219ab4de75bd68c490c98776dfc.tar.gz
ports-88bfe4bd43787219ab4de75bd68c490c98776dfc.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/asymptote/Makefile3
-rw-r--r--math/ipopt/Makefile6
-rw-r--r--math/jakarta-commons-math/Makefile10
-rw-r--r--math/jakarta-commons-math3/Makefile10
-rw-r--r--math/p5-Math-BaseCnv/Makefile2
-rw-r--r--math/topaz/Makefile4
-rw-r--r--math/triangle/Makefile3
-rw-r--r--math/wingz3/Makefile7
8 files changed, 19 insertions, 26 deletions
diff --git a/math/asymptote/Makefile b/math/asymptote/Makefile
index ae9b577b7846..6b00c9c855bf 100644
--- a/math/asymptote/Makefile
+++ b/math/asymptote/Makefile
@@ -5,8 +5,7 @@ PORTNAME= asymptote
PORTVERSION= 2.32
PORTREVISION= 4
CATEGORIES= math
-MASTER_SITES= SF
-MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
MAINTAINER= nivit@FreeBSD.org
diff --git a/math/ipopt/Makefile b/math/ipopt/Makefile
index cd7eb1640ef6..8c3a666dc7ce 100644
--- a/math/ipopt/Makefile
+++ b/math/ipopt/Makefile
@@ -4,12 +4,12 @@
PORTNAME= Ipopt
PORTVERSION= 3.11.10
CATEGORIES= math
-MASTER_SITES= http://www.coin-or.org/download/source/Ipopt/:srcs \
+MASTER_SITES= http://www.coin-or.org/download/source/Ipopt/ \
http://glaros.dtc.umn.edu/gkhome/fetch/sw/metis/OLD/:metis \
http://mumps.enseeiht.fr/:mumps
-DISTFILES= ${PORTNAME}-${PORTVERSION}.tgz:srcs \
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
metis-4.0.3.tar.gz:metis MUMPS_4.10.0.tar.gz:mumps
-EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= pfg@FreeBSD.org
COMMENT= Software package for large-scale nonlinear optimization
diff --git a/math/jakarta-commons-math/Makefile b/math/jakarta-commons-math/Makefile
index 0b4d75496d6a..c867b8b730eb 100644
--- a/math/jakarta-commons-math/Makefile
+++ b/math/jakarta-commons-math/Makefile
@@ -5,21 +5,19 @@ PORTNAME= commons-math
PORTVERSION= 2.2
PORTREVISION= 1
CATEGORIES= math java
-MASTER_SITES= ${MASTER_SITE_APACHE_COMMONS_SOURCE}/:source1 \
+MASTER_SITES= APACHE_COMMONS_SOURCE \
http://repo1.maven.org/maven2/junit/junit/4.8.2/:source2
-MASTER_SITE_SUBDIR= ${PORTNAME:S,commons-math,math,}/:source1
PKGNAMEPREFIX= jakarta-
-DISTFILES= ${PORTNAME}-${PORTVERSION}-src.tar.gz:source1 \
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
junit-4.8.2.jar:source2
-EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}-src.tar.gz
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= bofh@FreeBSD.org
COMMENT= Java library of self-contained mathematics and statistics components
LICENSE= APACHE20
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-src
-
USE_JAVA= yes
JAVA_VERSION= 1.6+
USE_ANT= yes
diff --git a/math/jakarta-commons-math3/Makefile b/math/jakarta-commons-math3/Makefile
index 119d84a5b066..4fbd46f06cb4 100644
--- a/math/jakarta-commons-math3/Makefile
+++ b/math/jakarta-commons-math3/Makefile
@@ -4,21 +4,19 @@
PORTNAME= commons-math3
PORTVERSION= 3.3
CATEGORIES= math java
-MASTER_SITES= ${MASTER_SITE_APACHE_COMMONS_SOURCE}/:source1 \
+MASTER_SITES= APACHE_COMMONS_SOURCE \
http://repo1.maven.org/maven2/junit/junit/4.8.2/:source2
-MASTER_SITE_SUBDIR= ${PORTNAME:S,commons-math3,math,}/:source1
PKGNAMEPREFIX= jakarta-
-DISTFILES= ${PORTNAME}-${PORTVERSION}-src.tar.gz:source1 \
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
junit-4.8.2.jar:source2
-EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}-src.tar.gz
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= bofh@FreeBSD.org
COMMENT= Java library of self-contained mathematics and statistics components
LICENSE= APACHE20
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-src
-
USE_JAVA= yes
JAVA_VERSION= 1.6+
USE_ANT= yes
diff --git a/math/p5-Math-BaseCnv/Makefile b/math/p5-Math-BaseCnv/Makefile
index 1938460551dd..12ba72ab69db 100644
--- a/math/p5-Math-BaseCnv/Makefile
+++ b/math/p5-Math-BaseCnv/Makefile
@@ -3,10 +3,10 @@
PORTNAME= Math-BaseCnv
PORTVERSION= 1.8
+DISTVERSIONSUFFIX= .B59BrZX
CATEGORIES= math perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-DISTNAME= ${PORTNAME}-${PORTVERSION}.B59BrZX
MAINTAINER= perl@FreeBSD.org
COMMENT= Fast functions to convert between number Bases
diff --git a/math/topaz/Makefile b/math/topaz/Makefile
index 65dbe552b642..9a76f37e1887 100644
--- a/math/topaz/Makefile
+++ b/math/topaz/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= topaz
-PORTVERSION= 3.41
+DISTVERSION= 3_41
CATEGORIES= math
MASTER_SITES= http://hp.vector.co.jp/authors/VA007663/topaz/bin/
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/./_/}-src
+DISTNAME= ${PORTNAME}-${DISTVERSION}-src
MAINTAINER= ports@FreeBSD.org
COMMENT= Command driven graph plotting system for scientists and engineers
diff --git a/math/triangle/Makefile b/math/triangle/Makefile
index 34f2d1e68091..39df959202c5 100644
--- a/math/triangle/Makefile
+++ b/math/triangle/Makefile
@@ -5,8 +5,7 @@ PORTNAME= triangle
PORTVERSION= 1.6
PORTREVISION= 2
CATEGORIES= math
-MASTER_SITES= NL
-MASTER_SITE_SUBDIR= voronoi
+MASTER_SITES= NL/voronoi
DISTNAME= ${PORTNAME}
DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
diff --git a/math/wingz3/Makefile b/math/wingz3/Makefile
index 7e86ccd765e8..c1a9c0ab2b22 100644
--- a/math/wingz3/Makefile
+++ b/math/wingz3/Makefile
@@ -5,11 +5,10 @@ PORTNAME= wingzpro
PORTVERSION= 311
PORTREVISION= 3
CATEGORIES= math linux
-MASTER_SITES= ${MASTER_SITE_SUNSITE}:wingz \
+MASTER_SITES= SUNSITE/apps/financial/spreadsheet:wingz \
${MASTER_SITE_FEDORA_LINUX:M*rpmfind.net/*:S|/fedora/core||}:l
-MASTER_SITE_SUBDIR=apps/financial/spreadsheet:wingz \
- redhat-archive/6.2/en/os/i386/RedHat/RPMS/:l
-DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:wingz \
+MASTER_SITE_SUBDIR= redhat-archive/6.2/en/os/i386/RedHat/RPMS/:l
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:wingz \
ld.so-1.9.5-13.i386.rpm:l \
libc-5.3.12-31.i386.rpm:l
EXTRACT_ONLY=