aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-08-28 16:31:18 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-08-28 16:31:18 +0000
commitd03c908f0d623667bfb7d38366b73a868879dca4 (patch)
tree45b4c3b48bdbdaf2b46d4c7ae21aa25358cdaae9 /math
parentc420e56452f3363f309a2b5288b6cf3832d0e3fa (diff)
downloadports-d03c908f0d623667bfb7d38366b73a868879dca4.tar.gz
ports-d03c908f0d623667bfb7d38366b73a868879dca4.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/libgmp-freebsd/Makefile28
-rw-r--r--math/libgmp-freebsd/distinfo1
-rw-r--r--math/libgmp-freebsd/files/patch-Makefile14
-rw-r--r--math/libgmp-freebsd/pkg-comment1
-rw-r--r--math/libgmp-freebsd/pkg-descr17
-rw-r--r--math/libgmp-freebsd/pkg-plist5
-rw-r--r--math/libgmp/Makefile28
-rw-r--r--math/libgmp/distinfo1
-rw-r--r--math/libgmp/files/patch-Makefile14
-rw-r--r--math/libgmp/pkg-comment1
-rw-r--r--math/libgmp/pkg-descr17
-rw-r--r--math/libgmp/pkg-plist5
13 files changed, 133 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 822c50fbe425..567a78188902 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -39,6 +39,7 @@
SUBDIR += guppi
SUBDIR += hexcalc
SUBDIR += lapack
+ SUBDIR += libgmp
SUBDIR += libgmp3
SUBDIR += libneural
SUBDIR += libranlib
diff --git a/math/libgmp-freebsd/Makefile b/math/libgmp-freebsd/Makefile
new file mode 100644
index 000000000000..caad5b6797fa
--- /dev/null
+++ b/math/libgmp-freebsd/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: libgmp
+# Date created: 28 August 2001
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libgmp
+PORTVERSION= 2001.08.07
+CATEGORIES= math
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= sobomax
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_BZIP2= yes
+INSTALLS_SHLIB= yes
+MAKE_FLAGS= INCDIR=${PREFIX}/include \
+ LIBDIR=${PREFIX}/lib \
+ INFODIR=${PREFIX}/info
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= "is in the base system"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/libgmp-freebsd/distinfo b/math/libgmp-freebsd/distinfo
new file mode 100644
index 000000000000..dad7238c1f15
--- /dev/null
+++ b/math/libgmp-freebsd/distinfo
@@ -0,0 +1 @@
+MD5 (libgmp-2001.08.07.tar.bz2) = 2309c9bb312c68a7aa2a957197104b0b
diff --git a/math/libgmp-freebsd/files/patch-Makefile b/math/libgmp-freebsd/files/patch-Makefile
new file mode 100644
index 000000000000..e2f5c0bdc2e8
--- /dev/null
+++ b/math/libgmp-freebsd/files/patch-Makefile
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- Makefile 2001/08/28 16:21:28 1.1
++++ Makefile 2001/08/28 16:21:41
+@@ -145,7 +145,7 @@
+
+ beforeinstall:
+ ${INSTALL} -C -o ${BINOWN} -g ${BINGRP} -m 444 \
+- ${GMPDIR}/gmp.h ${DESTDIR}/usr/include
++ ${GMPDIR}/gmp.h ${DESTDIR}${INCDIR}
+
+ .include "Makefile.inc"
+ .include <bsd.lib.mk>
diff --git a/math/libgmp-freebsd/pkg-comment b/math/libgmp-freebsd/pkg-comment
new file mode 100644
index 000000000000..04b7f02aa247
--- /dev/null
+++ b/math/libgmp-freebsd/pkg-comment
@@ -0,0 +1 @@
+A library for arbitrary precision arithmetic
diff --git a/math/libgmp-freebsd/pkg-descr b/math/libgmp-freebsd/pkg-descr
new file mode 100644
index 000000000000..69ba5950bd79
--- /dev/null
+++ b/math/libgmp-freebsd/pkg-descr
@@ -0,0 +1,17 @@
+GNU MP is a library for arbitrary precision arithmetic, operating on signed
+integers, rational numbers, and floating point numbers. It has a rich set
+of functions, and the functions have a regular interface.
+
+GNU MP is designed to be as fast as possible, both for small operands and for
+huge operands. The speed is achieved by using fullwords as the basic
+arithmetic type, by using fast algorithms, by carefully optimized assembly
+code for the most common inner loops for a lots of CPUs, and by a general
+emphasis on speed (instead of simplicity or elegance).
+
+The speed of GNU MP is believed to be faster than any other similar library.
+The advantage for GNU MP increases with the operand sizes for certain
+operations, since GNU MP in many cases has asymptotically faster algorithms.
+
+Note: This package contains version the the library just before it was
+removed from the FreeBSD base system (5-CURRENT, mid-August 2001) and it is
+provided solely for compatibility with packages that require it.
diff --git a/math/libgmp-freebsd/pkg-plist b/math/libgmp-freebsd/pkg-plist
new file mode 100644
index 000000000000..52332fa3dbad
--- /dev/null
+++ b/math/libgmp-freebsd/pkg-plist
@@ -0,0 +1,5 @@
+include/gmp.h
+info/gmp.info.gz
+lib/libgmp.a
+lib/libgmp.so
+lib/libgmp.so.3
diff --git a/math/libgmp/Makefile b/math/libgmp/Makefile
new file mode 100644
index 000000000000..caad5b6797fa
--- /dev/null
+++ b/math/libgmp/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: libgmp
+# Date created: 28 August 2001
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libgmp
+PORTVERSION= 2001.08.07
+CATEGORIES= math
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= sobomax
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_BZIP2= yes
+INSTALLS_SHLIB= yes
+MAKE_FLAGS= INCDIR=${PREFIX}/include \
+ LIBDIR=${PREFIX}/lib \
+ INFODIR=${PREFIX}/info
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= "is in the base system"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/libgmp/distinfo b/math/libgmp/distinfo
new file mode 100644
index 000000000000..dad7238c1f15
--- /dev/null
+++ b/math/libgmp/distinfo
@@ -0,0 +1 @@
+MD5 (libgmp-2001.08.07.tar.bz2) = 2309c9bb312c68a7aa2a957197104b0b
diff --git a/math/libgmp/files/patch-Makefile b/math/libgmp/files/patch-Makefile
new file mode 100644
index 000000000000..e2f5c0bdc2e8
--- /dev/null
+++ b/math/libgmp/files/patch-Makefile
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- Makefile 2001/08/28 16:21:28 1.1
++++ Makefile 2001/08/28 16:21:41
+@@ -145,7 +145,7 @@
+
+ beforeinstall:
+ ${INSTALL} -C -o ${BINOWN} -g ${BINGRP} -m 444 \
+- ${GMPDIR}/gmp.h ${DESTDIR}/usr/include
++ ${GMPDIR}/gmp.h ${DESTDIR}${INCDIR}
+
+ .include "Makefile.inc"
+ .include <bsd.lib.mk>
diff --git a/math/libgmp/pkg-comment b/math/libgmp/pkg-comment
new file mode 100644
index 000000000000..04b7f02aa247
--- /dev/null
+++ b/math/libgmp/pkg-comment
@@ -0,0 +1 @@
+A library for arbitrary precision arithmetic
diff --git a/math/libgmp/pkg-descr b/math/libgmp/pkg-descr
new file mode 100644
index 000000000000..69ba5950bd79
--- /dev/null
+++ b/math/libgmp/pkg-descr
@@ -0,0 +1,17 @@
+GNU MP is a library for arbitrary precision arithmetic, operating on signed
+integers, rational numbers, and floating point numbers. It has a rich set
+of functions, and the functions have a regular interface.
+
+GNU MP is designed to be as fast as possible, both for small operands and for
+huge operands. The speed is achieved by using fullwords as the basic
+arithmetic type, by using fast algorithms, by carefully optimized assembly
+code for the most common inner loops for a lots of CPUs, and by a general
+emphasis on speed (instead of simplicity or elegance).
+
+The speed of GNU MP is believed to be faster than any other similar library.
+The advantage for GNU MP increases with the operand sizes for certain
+operations, since GNU MP in many cases has asymptotically faster algorithms.
+
+Note: This package contains version the the library just before it was
+removed from the FreeBSD base system (5-CURRENT, mid-August 2001) and it is
+provided solely for compatibility with packages that require it.
diff --git a/math/libgmp/pkg-plist b/math/libgmp/pkg-plist
new file mode 100644
index 000000000000..52332fa3dbad
--- /dev/null
+++ b/math/libgmp/pkg-plist
@@ -0,0 +1,5 @@
+include/gmp.h
+info/gmp.info.gz
+lib/libgmp.a
+lib/libgmp.so
+lib/libgmp.so.3