aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2005-01-12 12:21:01 +0000
committerThomas Gellekum <tg@FreeBSD.org>2005-01-12 12:21:01 +0000
commitd2bcf69c0d826714bbf83c4b3bc04807ff80aeb1 (patch)
tree0e67a949bc549c48769f6088beec9523aa1c6c2b /math
parent17df997a7bcd45513b856c5d9149517874a0d248 (diff)
downloadports-d2bcf69c0d826714bbf83c4b3bc04807ff80aeb1.tar.gz
ports-d2bcf69c0d826714bbf83c4b3bc04807ff80aeb1.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/py-numeric/Makefile2
-rw-r--r--math/py-numeric/distinfo4
-rw-r--r--math/py-numeric/files/patch-setup.py32
3 files changed, 35 insertions, 3 deletions
diff --git a/math/py-numeric/Makefile b/math/py-numeric/Makefile
index cc263d43f50f..5f3b9ac5c4a2 100644
--- a/math/py-numeric/Makefile
+++ b/math/py-numeric/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= numeric
-PORTVERSION= 23.1
+PORTVERSION= 23.7
CATEGORIES= math python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= numpy
diff --git a/math/py-numeric/distinfo b/math/py-numeric/distinfo
index ea9777ddf0a3..c48dd9240e68 100644
--- a/math/py-numeric/distinfo
+++ b/math/py-numeric/distinfo
@@ -1,2 +1,2 @@
-MD5 (Numeric-23.1.tar.gz) = 5cd24ed20627f5cbc822a2bed8ff27e9
-SIZE (Numeric-23.1.tar.gz) = 724051
+MD5 (Numeric-23.7.tar.gz) = 8054781c58ae9cf6fe498316860b5ea8
+SIZE (Numeric-23.7.tar.gz) = 725824
diff --git a/math/py-numeric/files/patch-setup.py b/math/py-numeric/files/patch-setup.py
new file mode 100644
index 000000000000..eef6d8c66cf5
--- /dev/null
+++ b/math/py-numeric/files/patch-setup.py
@@ -0,0 +1,32 @@
+--- setup.py.orig Wed Sep 29 01:50:45 2004
++++ setup.py Wed Oct 20 09:31:06 2004
+@@ -33,21 +33,21 @@
+
+ # delete all but the first one in this list if using your own LAPACK/BLAS
+ sourcelist = [os.path.join('Src', 'lapack_litemodule.c'),
+-# os.path.join('Src', 'blas_lite.c'),
+-# os.path.join('Src', 'f2c_lite.c'),
+-# os.path.join('Src', 'zlapack_lite.c'),
+-# os.path.join('Src', 'dlapack_lite.c')
++ os.path.join('Src', 'blas_lite.c'),
++ os.path.join('Src', 'f2c_lite.c'),
++ os.path.join('Src', 'zlapack_lite.c'),
++ os.path.join('Src', 'dlapack_lite.c')
+ ]
+ # set these to use your own BLAS;
+
+-library_dirs_list = ['/usr/lib/atlas']
+-libraries_list = ['lapack', 'cblas', 'f77blas', 'atlas', 'g2c']
++library_dirs_list = []
++libraries_list = []
+ # if you also set `use_dotblas` (see below), you'll need:
+ # ['lapack', 'cblas', 'f77blas', 'atlas', 'g2c']
+
+ # set to true (1), if you also want BLAS optimized matrixmultiply/dot/innerproduct
+-use_dotblas = 1
+-include_dirs = ['/usr/include/atlas'] # You may need to set this to find cblas.h
++use_dotblas = 0
++include_dirs = [] # You may need to set this to find cblas.h
+ # e.g. on UNIX using ATLAS this should be ['/usr/include/atlas']
+
+ # The packages are split in this way to allow future optional inclusion