aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-09-16 16:32:07 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-09-16 16:32:07 +0000
commite4343d70fd4006cdded06afba566cf5ac81c1042 (patch)
tree2b1105fda751368f91c2495b29c8d7ed7603adbd /math
parent778e2d35510d4f8fa6bbae934b313771189e4268 (diff)
downloadports-e4343d70fd4006cdded06afba566cf5ac81c1042.tar.gz
ports-e4343d70fd4006cdded06afba566cf5ac81c1042.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/R/Makefile3
-rw-r--r--math/cvc3/Makefile8
-rw-r--r--math/maxima/Makefile3
-rw-r--r--math/octave/Makefile5
-rw-r--r--math/p5-Parse-Range/Makefile7
-rw-r--r--math/proofgeneral/Makefile3
-rw-r--r--math/pspp/Makefile4
-rw-r--r--math/stp/Makefile5
8 files changed, 16 insertions, 22 deletions
diff --git a/math/R/Makefile b/math/R/Makefile
index 61edf9f4adfe..76bfebd37144 100644
--- a/math/R/Makefile
+++ b/math/R/Makefile
@@ -66,7 +66,8 @@ OPTIONS_DEFAULT+= ICU PCRE_PORT THREADS
RUN_DEPENDS+= ${LOCALBASE}/bin/gsed:${PORTSDIR}/textproc/gsed
USE_LDCONFIG= ${PREFIX}/lib/R/lib
#now only used to build the R.1 manpage:
-USE_PERL5_BUILD= yes
+USES+= perl5
+USE_PERL5= build
MAN1= R.1 Rscript.1
diff --git a/math/cvc3/Makefile b/math/cvc3/Makefile
index 2b4dd659a13f..b5d1d2346f5a 100644
--- a/math/cvc3/Makefile
+++ b/math/cvc3/Makefile
@@ -18,12 +18,8 @@ CONFIGURE_ARGS= --enable-dynamic \
--with-extra-libs=${LOCALBASE}/lib
CXXFLAGS+= -fPIC
GNU_CONFIGURE= yes
-USES= bison
-USE_GMAKE= yes
+USES= bison gmake perl5
USE_LDCONFIG= yes
-USE_PERL5= yes
-
-.include <bsd.port.pre.mk>
post-patch:
${REINPLACE_CMD} -e 's,/bin/bash,/bin/sh,' ${WRKSRC}/Makefile.std
@@ -33,4 +29,4 @@ post-patch:
post-install:
${INSTALL_PROGRAM} `readlink ${WRKSRC}/bin/cvc3` ${PREFIX}/bin
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/maxima/Makefile b/math/maxima/Makefile
index 02d51af6000e..d7503419021d 100644
--- a/math/maxima/Makefile
+++ b/math/maxima/Makefile
@@ -19,8 +19,9 @@ RUN_DEPENDS= ${LOCALBASE}/bin/${LISPPORT} \
${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
USE_TK = 84+
+USES= gmake perl5
USE_GMAKE= yes
-USE_PERL5_BUILD= yes
+USE_PERL5= build
USE_PYTHON_BUILD= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --prefix=${PREFIX} \
diff --git a/math/octave/Makefile b/math/octave/Makefile
index 721790e15300..a646d894c34d 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -32,10 +32,9 @@ LIB_DEPENDS= GraphicsMagick:${PORTSDIR}/graphics/GraphicsMagick \
umfpack.1:${PORTSDIR}/math/suitesparse \
glpk:${PORTSDIR}/math/glpk
-USES= charsetfix pkgconfig
+USES= charsetfix gmake perl5 pkgconfig
USE_BZIP2= yes
-USE_PERL5_BUILD=yes
-USE_GMAKE= yes
+USE_PERL5= build
USE_TEX= dvipsk:build
GNU_CONFIGURE= yes
#USE_AUTOTOOLS= autoconf
diff --git a/math/p5-Parse-Range/Makefile b/math/p5-Parse-Range/Makefile
index 5bc5a9b8e288..d48fbb2ca9f2 100644
--- a/math/p5-Parse-Range/Makefile
+++ b/math/p5-Parse-Range/Makefile
@@ -20,10 +20,9 @@ BUILD_DEPENDS= p5-Module-Build>=0.4:${PORTSDIR}/devel/p5-Module-Build \
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Parse::Range.3
-.include <bsd.port.pre.mk>
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/proofgeneral/Makefile b/math/proofgeneral/Makefile
index 4d7baadf6524..74d30bd07649 100644
--- a/math/proofgeneral/Makefile
+++ b/math/proofgeneral/Makefile
@@ -20,9 +20,8 @@ BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
RUN_DEPENDS= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
USE_EMACS= yes
-USE_GMAKE= yes
INSTALLS_ICONS= yes
-USE_PERL5= yes
+USES= gmake perl5
.include <bsd.port.pre.mk>
diff --git a/math/pspp/Makefile b/math/pspp/Makefile
index 30992668a8ac..98f8b8cbb4d4 100644
--- a/math/pspp/Makefile
+++ b/math/pspp/Makefile
@@ -16,8 +16,8 @@ LIB_DEPENDS= plot.4:${PORTSDIR}/graphics/plotutils \
OPTIONS_DEFINE= GUI PGSQL
USE_GNOME= libxml2
-USE_PERL5_BUILD=yes
-USES= iconv
+USE_PERL5= build
+USES= iconv gmake perl5
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
diff --git a/math/stp/Makefile b/math/stp/Makefile
index 35377a839c57..1ad7841da00e 100644
--- a/math/stp/Makefile
+++ b/math/stp/Makefile
@@ -12,10 +12,9 @@ COMMENT= A Decision Procedure for Bitvectors and Arrays
LICENSE= MIT
-USES= bison
+USES= bison gmake perl5
USE_BZIP2= yes
-USE_GMAKE= yes
-USE_PERL5_BUILD= yes
+USE_PERL5= build
CONFIGURE_SCRIPT= scripts/configure
CONFIGURE_ARGS= --with-prefix=${PREFIX} \