aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-08 15:20:23 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-08 15:20:23 +0000
commit13b1a749ad2a7e449ed257e97a80f1d69bcca866 (patch)
treedaf53fe195f24defabd136ba934f40b65492c780 /math
parent99aab3f241810774bb06d9a1e424f9b59fea4a49 (diff)
downloadports-13b1a749ad2a7e449ed257e97a80f1d69bcca866.tar.gz
ports-13b1a749ad2a7e449ed257e97a80f1d69bcca866.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/xplot/Makefile12
-rw-r--r--math/xplot/files/patch-Makefile19
2 files changed, 25 insertions, 6 deletions
diff --git a/math/xplot/Makefile b/math/xplot/Makefile
index 6353ca091db2..ee00cf484d6e 100644
--- a/math/xplot/Makefile
+++ b/math/xplot/Makefile
@@ -15,21 +15,21 @@ USE_XORG= x11
USE_PERL5= run
GNU_CONFIGURE= yes
-MAN1= tcpdump2xplot.1 xplot.1
PORTDOCS= README README.tcp_plots
-PLIST_FILES= bin/tcpdump2xplot bin/tcpdump2xplot.pl bin/xplot
+PLIST_FILES= bin/tcpdump2xplot bin/tcpdump2xplot.pl bin/xplot \
+ man/man1/tcpdump2xplot.1.gz \
+ man/man1/xplot.1.gz
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e \
'/INSTALL/s|2xplot$$|2xplot.pl|' ${WRKSRC}/Makefile.in
post-install:
- ${LN} -sf tcpdump2xplot.pl ${PREFIX}/bin/tcpdump2xplot
+ ${LN} -sf tcpdump2xplot.pl ${STAGEDIR}${PREFIX}/bin/tcpdump2xplot
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for doc in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
.endfor
.endif
diff --git a/math/xplot/files/patch-Makefile b/math/xplot/files/patch-Makefile
new file mode 100644
index 000000000000..ac26d5dc6f92
--- /dev/null
+++ b/math/xplot/files/patch-Makefile
@@ -0,0 +1,19 @@
+--- Makefile.in.orig 2014-06-08 23:17:52.261073676 +0800
++++ Makefile.in 2014-06-08 23:18:17.975100570 +0800
+@@ -70,11 +70,11 @@ version_string.c: version
+ echo 'char *version_string = "'`cat version`'";' >version_string.c
+
+ install: all
+- mkdir -p $(bindir)
+- $(INSTALL_PROGRAM) xplot $(bindir)/xplot
+- $(INSTALL) tcpdump2xplot.pl $(bindir)/tcpdump2xplot
+- mkdir -p $(mandir)
+- $(INSTALL_MAN) $(MANFILES) $(mandir)
++ mkdir -p $(DESTDIR)$(bindir)
++ $(INSTALL_PROGRAM) xplot $(DESTDIR)$(bindir)/xplot
++ $(INSTALL) tcpdump2xplot.pl $(DESTDIR)$(bindir)/tcpdump2xplot
++ mkdir -p $(DESTDIR)$(mandir)
++ $(INSTALL_MAN) $(MANFILES) $(DESTDIR)$(mandir)
+ clean:
+ rm -f ${PROG} ${PROG}.old *.o version_string.c
+