aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorSean Bruno <sbruno@FreeBSD.org>2015-02-10 22:24:01 +0000
committerSean Bruno <sbruno@FreeBSD.org>2015-02-10 22:24:01 +0000
commit24d46ae7725c9af9dc36bd20c9b815ab945e5b72 (patch)
tree95a38828ad1e1b59f1bdcdfba3e862d99d53c8f9 /math
parent6908db6ef668ff79e14b6f699b634948a6d3dfb1 (diff)
downloadports-24d46ae7725c9af9dc36bd20c9b815ab945e5b72.tar.gz
ports-24d46ae7725c9af9dc36bd20c9b815ab945e5b72.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/R/Makefile2
-rw-r--r--math/R/files/patch-src_extra_tre_tre-internal.h22
2 files changed, 24 insertions, 0 deletions
diff --git a/math/R/Makefile b/math/R/Makefile
index 361e36aac373..9602970863d5 100644
--- a/math/R/Makefile
+++ b/math/R/Makefile
@@ -91,6 +91,8 @@ X11_DESC= X11() graphics device
OPTIONS_DEFAULT+= GHOSTSCRIPT INFO_MANUALS JPEG LIBR PANGOCAIRO PNG \
TCLTK TIFF X11
+OPTIONS_DEFAULT_armv6+= MISSING
+
.endif # !LIBR_SLAVEPORT
PLIST_SUB= R_SOVERSION="${R_SOVERSION}" \
RBLAS_SOVERSION="${RBLAS_SOVERSION}" \
diff --git a/math/R/files/patch-src_extra_tre_tre-internal.h b/math/R/files/patch-src_extra_tre_tre-internal.h
new file mode 100644
index 000000000000..b9d39324d772
--- /dev/null
+++ b/math/R/files/patch-src_extra_tre_tre-internal.h
@@ -0,0 +1,22 @@
+--- src/extra/tre/tre-internal.h.orig 2015-01-20 15:25:01 UTC
++++ src/extra/tre/tre-internal.h
+@@ -17,6 +17,7 @@
+ #include <wctype.h>
+ #endif /* !HAVE_WCTYPE_H */
+
++#include <limits.h>
+ #include <ctype.h>
+ #include "tre.h"
+
+@@ -48,7 +49,11 @@
+
+ /* Wide characters. */
+ typedef wint_t tre_cint_t;
++#if WCHAR_MAX <= INT_MAX
+ #define TRE_CHAR_MAX WCHAR_MAX
++#else /* WCHAR_MAX > INT_MAX */
++#define TRE_CHAR_MAX INT_MAX
++#endif
+
+ #ifdef TRE_MULTIBYTE
+ #define TRE_MB_CUR_MAX MB_CUR_MAX