aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-10-02 17:53:13 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-10-02 17:53:58 +0000
commit29fd94d80a3bd02b42b7ba36112ca55581cd0a22 (patch)
treee4e1798f1679396ea6d5903fce33986973fa8b19 /math
parentf1c12acf11bed73aec5451d91410024109b27943 (diff)
downloadports-29fd94d80a3bd02b42b7ba36112ca55581cd0a22.tar.gz
ports-29fd94d80a3bd02b42b7ba36112ca55581cd0a22.zip
math/gretl: Update 2021b -> 2021d
Reported by: portscout
Diffstat (limited to 'math')
-rw-r--r--math/gretl/Makefile13
-rw-r--r--math/gretl/distinfo6
-rw-r--r--math/gretl/files/patch-gui_Makefile.in12
-rw-r--r--math/gretl/files/patch-lib_src_gretl__mt.c13
-rw-r--r--math/gretl/files/patch-plugin_Makefile.in4
-rw-r--r--math/gretl/pkg-plist157
6 files changed, 111 insertions, 94 deletions
diff --git a/math/gretl/Makefile b/math/gretl/Makefile
index 902ab228d519..4dab9c2a1f14 100644
--- a/math/gretl/Makefile
+++ b/math/gretl/Makefile
@@ -1,7 +1,7 @@
# Created by: ijliao
PORTNAME= gretl
-PORTVERSION= 2021b
+PORTVERSION= 2021d
CATEGORIES= math finance
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTVERSIONFULL}/
@@ -14,6 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libcurl.so:ftp/curl \
libfftw3.so:math/fftw3 \
libgmp.so:math/gmp \
+ libharfbuzz.so:print/harfbuzz \
libjson-glib-1.0.so:devel/json-glib \
libmpfr.so:math/mpfr
@@ -28,6 +29,8 @@ SSP_CFLAGS?= -fstack-protector # XXX -strong crashes mklang on 12.0+ i386
CONFIGURE_ENV= ac_cv_lib_dl_dlopen="" \
LAPACK_LIBS="${LAPACK} ${BLAS}"
+PLIST_SUB= GTK_VER=${GTK_VER}
+
OPTIONS_DEFINE= ADDONS ATLAS GUI MPI NLS ODBC OPENMP R UNZIP
OPTIONS_DEFAULT= ADDONS GUI OPENMP UNZIP
OPTIONS_SUB= yes
@@ -47,8 +50,10 @@ GUI_DESC= Graphical user interface and plugins
GUI_CONFIGURE_ON= --enable-gui=yes
GUI_CONFIGURE_OFF= --enable-gui=no --enable-xdg=no
GUI_VARS= INSTALLS_ICONS=yes
-GUI_USE= GNOME=cairo,gtksourceview3
-GUI_USE_OFF= GNOME=glib30,libxml2
+GUI_USE= GNOME=cairo,gtksourceview3,gdkpixbuf2
+GUI_USE_OFF= GNOME=glib20,libxml2
+GUI_VARS= GTK_VER=3
+GUI_VARS_OFF= GTK_VER=2
GUI_USES= desktop-file-utils shared-mime-info
GUI_BUILD_DEPENDS= gnuplot:math/gnuplot
GUI_LIB_DEPENDS= libfreetype.so:print/freetype2 \
@@ -95,7 +100,7 @@ regression-test test check: build
${MAKE_ARGS} check
post-install:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/gretl-gtk3/*.so
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/gretl-*/*.so
@${RMDIR} ${STAGEDIR}${DATADIR}/doc
.include <bsd.port.mk>
diff --git a/math/gretl/distinfo b/math/gretl/distinfo
index 0f3d71618f80..cfa9723ae54f 100644
--- a/math/gretl/distinfo
+++ b/math/gretl/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1620321554
-SHA256 (gretl-2021b.tar.xz) = dca48003450fc7772a3177ff1b99eb9427cb8d6703886b73bc97bfb3247213a7
-SIZE (gretl-2021b.tar.xz) = 13273320
+TIMESTAMP = 1633145930
+SHA256 (gretl-2021d.tar.xz) = ce28f7dfb3ff31e982c2f31a8766d4137a1dbf429ffca5ba7d49763a03338ee2
+SIZE (gretl-2021d.tar.xz) = 13256260
diff --git a/math/gretl/files/patch-gui_Makefile.in b/math/gretl/files/patch-gui_Makefile.in
index de4b8f11168d..b3acf0ba175d 100644
--- a/math/gretl/files/patch-gui_Makefile.in
+++ b/math/gretl/files/patch-gui_Makefile.in
@@ -1,6 +1,6 @@
---- gui/Makefile.in.orig 2021-05-07 16:11:37 UTC
+--- gui/Makefile.in.orig 2021-10-02 16:19:02 UTC
+++ gui/Makefile.in
-@@ -157,7 +157,7 @@ else ifeq ($(win32_build),yes)
+@@ -167,7 +167,7 @@ else ifeq ($(win32_build),yes)
INSTALL_GTKRC = install-gtkrc
else
PROG = gretl_x11$(EXEEXT)
@@ -9,17 +9,17 @@
endif
vpath %.c $(topsrc)/gui
-@@ -279,7 +279,7 @@ NEWS: $(MKNEWS) $(topsrc)/ChangeLog
+@@ -301,7 +301,7 @@ gretl-icons.gresource: gretl-icons.xml
.PHONY:
-install: install-exec install-ui $(INSTALL_SCRIPT) install-data install-lang install-styles \
+install: install-exec install-ui $(INSTALL_SCRIPT_TARGET) install-data install-lang install-styles \
- install-news $(INSTALL_GTKRC) $(INSTALL_CMDFILE)
+ install-icons install-news $(INSTALL_GTKRC) $(INSTALL_CMDFILE)
install-strip: $(PROG) install-data
-@@ -294,7 +294,7 @@ install-ui: installdirs
- $(INSTALL_DATA) $(topsrc)/gui/gretlmodel.xml $(DESTDIR)$(uidir)
+@@ -319,7 +319,7 @@ install-icons: gretl-icons.gresource installdirs
+ $(INSTALL_DATA) gretl-icons.gresource $(DESTDIR)$(gretldir)
install-script: installdirs
- $(INSTALL_PROGRAM) ../gretl_sh $(DESTDIR)$(bindir)/gretl
diff --git a/math/gretl/files/patch-lib_src_gretl__mt.c b/math/gretl/files/patch-lib_src_gretl__mt.c
new file mode 100644
index 000000000000..6f7f0de3192f
--- /dev/null
+++ b/math/gretl/files/patch-lib_src_gretl__mt.c
@@ -0,0 +1,13 @@
+- https://sourceforge.net/p/gretl/bugs/251/
+
+--- lib/src/gretl_mt.c.orig 2021-10-02 09:01:37 UTC
++++ lib/src/gretl_mt.c
+@@ -27,6 +27,8 @@
+ # include <omp.h>
+ #endif
+
++#include <unistd.h> // for sysconf
++
+ /* for processors count */
+ #if defined(WIN32)
+ # include <windows.h>
diff --git a/math/gretl/files/patch-plugin_Makefile.in b/math/gretl/files/patch-plugin_Makefile.in
index bc284b93a713..0895ec18c20c 100644
--- a/math/gretl/files/patch-plugin_Makefile.in
+++ b/math/gretl/files/patch-plugin_Makefile.in
@@ -1,6 +1,6 @@
---- plugin/Makefile.in.orig 2021-05-07 16:11:37 UTC
+--- plugin/Makefile.in.orig 2021-10-02 03:59:05 UTC
+++ plugin/Makefile.in
-@@ -423,14 +423,14 @@ $(GRETLLIB):
+@@ -436,14 +436,14 @@ $(GRETLLIB):
.PHONY:
install: $(GRETLLIB) $(PLUGINS) $(URCDATA) $(DWDATA) installdirs
diff --git a/math/gretl/pkg-plist b/math/gretl/pkg-plist
index e1390e0b4099..2b972cbbe85c 100644
--- a/math/gretl/pkg-plist
+++ b/math/gretl/pkg-plist
@@ -79,67 +79,68 @@ include/gretl/uservar.h
include/gretl/var.h
include/gretl/varprint.h
include/gretl/vartest.h
-lib/gretl-gtk3/anova.so
-lib/gretl-gtk3/arbond.so
-lib/gretl-gtk3/arma.so
-lib/gretl-gtk3/arma_x12.so
-lib/gretl-gtk3/bdstest.so
-lib/gretl-gtk3/biprobit.so
-lib/gretl-gtk3/data/dfgls-beta-c.bin
-lib/gretl-gtk3/data/dfgls-beta-t.bin
-lib/gretl-gtk3/data/dwdata.gz
-lib/gretl-gtk3/data/npc.bin
-lib/gretl-gtk3/data/npt.bin
-lib/gretl-gtk3/data/pqc.bin
-lib/gretl-gtk3/data/pqt.bin
-lib/gretl-gtk3/data/s_alpha.bin
-lib/gretl-gtk3/data/urcdata.bin
-lib/gretl-gtk3/duration.so
-lib/gretl-gtk3/eviews_import.so
-%%GUI%%lib/gretl-gtk3/excel_import.so
-lib/gretl-gtk3/fractals.so
-lib/gretl-gtk3/garch.so
-lib/gretl-gtk3/geoplot.so
-%%GUI%%lib/gretl-gtk3/gnumeric_import.so
-%%NO_UNZIP%%lib/gretl-gtk3/gretlzip.so
-lib/gretl-gtk3/heckit.so
-lib/gretl-gtk3/interpolate.so
-lib/gretl-gtk3/interval.so
-lib/gretl-gtk3/iso3166.so
-lib/gretl-gtk3/jmulti_import.so
-lib/gretl-gtk3/johansen.so
-lib/gretl-gtk3/json_get.so
-lib/gretl-gtk3/kernel.so
-%%GUI%%lib/gretl-gtk3/leverage.so
-%%GUI%%lib/gretl-gtk3/mailer.so
-lib/gretl-gtk3/mp_ols.so
-lib/gretl-gtk3/nistcheck.so
-%%ODBC%%lib/gretl-gtk3/odbc_import.so
-%%GUI%%lib/gretl-gtk3/ods_import.so
-lib/gretl-gtk3/panurc.so
-%%GUI%%lib/gretl-gtk3/pca.so
-lib/gretl-gtk3/poisson.so
-%%GUI%%lib/gretl-gtk3/progress_bar.so
-lib/gretl-gtk3/purebin.so
-lib/gretl-gtk3/quantreg.so
-lib/gretl-gtk3/range-mean.so
-lib/gretl-gtk3/regls.so
-lib/gretl-gtk3/reprobit.so
-lib/gretl-gtk3/sas_import.so
-lib/gretl-gtk3/spss_import.so
-lib/gretl-gtk3/stata_export.so
-lib/gretl-gtk3/stata_import.so
-lib/gretl-gtk3/stats_tables.so
-lib/gretl-gtk3/svm.so
-lib/gretl-gtk3/sysest.so
-%%GUI%%lib/gretl-gtk3/tramo-x12a.so
-lib/gretl-gtk3/urcdist.so
-lib/gretl-gtk3/vif.so
-%%GUI%%lib/gretl-gtk3/xlsx_import.so
-%%GUI%%lib/gretl-gtk3/xml_get.so
+lib/gretl-gtk%%GTK_VER%%/anova.so
+lib/gretl-gtk%%GTK_VER%%/arma.so
+lib/gretl-gtk%%GTK_VER%%/arma_x12.so
+lib/gretl-gtk%%GTK_VER%%/bdstest.so
+lib/gretl-gtk%%GTK_VER%%/biprobit.so
+lib/gretl-gtk%%GTK_VER%%/data/dfgls-beta-c.bin
+lib/gretl-gtk%%GTK_VER%%/data/dfgls-beta-t.bin
+lib/gretl-gtk%%GTK_VER%%/data/dwdata.gz
+lib/gretl-gtk%%GTK_VER%%/data/npc.bin
+lib/gretl-gtk%%GTK_VER%%/data/npt.bin
+lib/gretl-gtk%%GTK_VER%%/data/pqc.bin
+lib/gretl-gtk%%GTK_VER%%/data/pqt.bin
+lib/gretl-gtk%%GTK_VER%%/data/s_alpha.bin
+lib/gretl-gtk%%GTK_VER%%/data/urcdata.bin
+lib/gretl-gtk%%GTK_VER%%/dpanel.so
+lib/gretl-gtk%%GTK_VER%%/duration.so
+lib/gretl-gtk%%GTK_VER%%/eviews_import.so
+%%GUI%%lib/gretl-gtk%%GTK_VER%%/excel_import.so
+lib/gretl-gtk%%GTK_VER%%/fractals.so
+lib/gretl-gtk%%GTK_VER%%/garch.so
+lib/gretl-gtk%%GTK_VER%%/geoplot.so
+%%GUI%%lib/gretl-gtk%%GTK_VER%%/gnumeric_import.so
+%%NO_UNZIP%%lib/gretl-gtk%%GTK_VER%%/gretlzip.so
+lib/gretl-gtk%%GTK_VER%%/heckit.so
+lib/gretl-gtk%%GTK_VER%%/interpolate.so
+lib/gretl-gtk%%GTK_VER%%/interval.so
+lib/gretl-gtk%%GTK_VER%%/iso3166.so
+lib/gretl-gtk%%GTK_VER%%/jmulti_import.so
+lib/gretl-gtk%%GTK_VER%%/johansen.so
+lib/gretl-gtk%%GTK_VER%%/json_get.so
+lib/gretl-gtk%%GTK_VER%%/kernel.so
+%%GUI%%lib/gretl-gtk%%GTK_VER%%/leverage.so
+%%GUI%%lib/gretl-gtk%%GTK_VER%%/lpsolve.so
+%%GUI%%lib/gretl-gtk%%GTK_VER%%/mailer.so
+lib/gretl-gtk%%GTK_VER%%/mp_ols.so
+lib/gretl-gtk%%GTK_VER%%/nistcheck.so
+%%ODBC%%lib/gretl-gtk%%GTK_VER%%/odbc_import.so
+%%GUI%%lib/gretl-gtk%%GTK_VER%%/ods_import.so
+lib/gretl-gtk%%GTK_VER%%/panurc.so
+%%GUI%%lib/gretl-gtk%%GTK_VER%%/pca.so
+lib/gretl-gtk%%GTK_VER%%/poisson.so
+%%GUI%%lib/gretl-gtk%%GTK_VER%%/progress_bar.so
+lib/gretl-gtk%%GTK_VER%%/purebin.so
+lib/gretl-gtk%%GTK_VER%%/quantreg.so
+lib/gretl-gtk%%GTK_VER%%/range-mean.so
+lib/gretl-gtk%%GTK_VER%%/regls.so
+lib/gretl-gtk%%GTK_VER%%/reprobit.so
+lib/gretl-gtk%%GTK_VER%%/sas_import.so
+lib/gretl-gtk%%GTK_VER%%/spss_import.so
+lib/gretl-gtk%%GTK_VER%%/stata_export.so
+lib/gretl-gtk%%GTK_VER%%/stata_import.so
+lib/gretl-gtk%%GTK_VER%%/stats_tables.so
+lib/gretl-gtk%%GTK_VER%%/svm.so
+lib/gretl-gtk%%GTK_VER%%/sysest.so
+%%GUI%%lib/gretl-gtk%%GTK_VER%%/tramo-x12a.so
+lib/gretl-gtk%%GTK_VER%%/urcdist.so
+lib/gretl-gtk%%GTK_VER%%/vif.so
+%%GUI%%lib/gretl-gtk%%GTK_VER%%/xlsx_import.so
+%%GUI%%lib/gretl-gtk%%GTK_VER%%/xml_get.so
lib/libgretl-1.0.so
-lib/libgretl-1.0.so.38
-lib/libgretl-1.0.so.38.0.0
+lib/libgretl-1.0.so.40
+lib/libgretl-1.0.so.40.0.0
libdata/pkgconfig/gretl.pc
man/man1/gretl.1.gz
%%GUI%%share/appdata/gretl.appdata.xml
@@ -214,7 +215,6 @@ man/man1/gretl.1.gz
%%DATADIR%%/data/misc/ooballot.gdt
%%DATADIR%%/data/misc/penngrow.gdt
%%DATADIR%%/data/misc/pension.gdt
-%%DATADIR%%/data/misc/poisson.gdt
%%DATADIR%%/data/misc/rac3d.gdt
%%DATADIR%%/data/misc/recid.gdt
%%DATADIR%%/data/misc/rwm.gdt
@@ -420,20 +420,23 @@ man/man1/gretl.1.gz
%%DATADIR%%/functions/gretlfunc.dtd
%%ADDONS%%%%DATADIR%%/functions/ivpanel/ivpanel.gfn
%%ADDONS%%%%DATADIR%%/functions/ivpanel/ivpanel.pdf
+%%ADDONS%%%%DATADIR%%/functions/logging/logging.gfn
+%%ADDONS%%%%DATADIR%%/functions/logging/logging.pdf
%%DATADIR%%/functions/packages.xml
-%%DATADIR%%/functions/regls/examples/README.txt
-%%DATADIR%%/functions/regls/examples/elnet_sequence.inp
-%%DATADIR%%/functions/regls/examples/fat.inp
-%%DATADIR%%/functions/regls/examples/fatplus.inp
-%%DATADIR%%/functions/regls/examples/lambda_sequence.inp
-%%DATADIR%%/functions/regls/examples/multiprint.inp
-%%DATADIR%%/functions/regls/examples/murder.gdt
-%%DATADIR%%/functions/regls/examples/ridge_compare.inp
-%%DATADIR%%/functions/regls/examples/ridge_single.inp
-%%DATADIR%%/functions/regls/examples/winequality-red.gdt
-%%DATADIR%%/functions/regls/examples/xvalidate_consec.inp
-%%DATADIR%%/functions/regls/regls.gfn
-%%DATADIR%%/functions/regls/regls.pdf
+%%ADDONS%%%%DATADIR%%/functions/regls/examples/README.txt
+%%ADDONS%%%%DATADIR%%/functions/regls/examples/elnet_sequence.inp
+%%ADDONS%%%%DATADIR%%/functions/regls/examples/fat.inp
+%%ADDONS%%%%DATADIR%%/functions/regls/examples/fatplus.inp
+%%ADDONS%%%%DATADIR%%/functions/regls/examples/lambda_sequence.inp
+%%ADDONS%%%%DATADIR%%/functions/regls/examples/multiprint.inp
+%%ADDONS%%%%DATADIR%%/functions/regls/examples/murder.gdt
+%%ADDONS%%%%DATADIR%%/functions/regls/examples/ridge_compare.inp
+%%ADDONS%%%%DATADIR%%/functions/regls/examples/ridge_single.inp
+%%ADDONS%%%%DATADIR%%/functions/regls/examples/winequality-red.gdt
+%%ADDONS%%%%DATADIR%%/functions/regls/examples/xvalidate_consec.inp
+%%ADDONS%%%%DATADIR%%/functions/regls/regls.gfn
+%%ADDONS%%%%DATADIR%%/functions/regls/regls.pdf
+%%GUI%%%%DATADIR%%/gretl-icons.gresource
%%GUI%%%%DATADIR%%/gretl-logo.xpm
%%DATADIR%%/gretl_cli_cmdref.en
%%DATADIR%%/gretl_cli_cmdref.es
@@ -455,11 +458,6 @@ man/man1/gretl.1.gz
%%DATADIR%%/gretl_gui_fnref.gl
%%DATADIR%%/gretl_gui_fnref.it
%%DATADIR%%/gretl_gui_fnref.pt
-%%DATADIR%%/gretl_gui_help.en
-%%DATADIR%%/gretl_gui_help.es
-%%DATADIR%%/gretl_gui_help.gl
-%%DATADIR%%/gretl_gui_help.it
-%%DATADIR%%/gretl_gui_help.pt
%%DATADIR%%/gretlhelp.refs
%%GUI%%%%DATADIR%%/gtksourceview/build.xml
%%GUI%%%%DATADIR%%/gtksourceview/darkslate.xml
@@ -467,6 +465,7 @@ man/man1/gretl.1.gz
%%GUI%%%%DATADIR%%/gtksourceview/gfnspec.lang
%%GUI%%%%DATADIR%%/gtksourceview/gnuplot.lang
%%GUI%%%%DATADIR%%/gtksourceview/gretl.lang
+%%GUI%%%%DATADIR%%/gtksourceview/lpsolve.lang
%%GUI%%%%DATADIR%%/gtksourceview/stata.lang
%%DATADIR%%/helpfigs/adf1.png
%%DATADIR%%/helpfigs/aic.png