aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-09-29 05:30:35 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-09-29 05:33:23 +0000
commit3300bf124cb2c160729141eab0d1a6e9ed23c18c (patch)
tree2d0756356172b322be1a3474d4006b677ff59dd1 /math
parent4989cee1745908d26d4256f958f9dd14e7689562 (diff)
downloadports-3300bf124cb2c160729141eab0d1a6e9ed23c18c.tar.gz
ports-3300bf124cb2c160729141eab0d1a6e9ed23c18c.zip
math/petanque: New port: Library that helps manipulate symbolic boolean expressions
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/petanque/Makefile24
-rw-r--r--math/petanque/distinfo3
-rw-r--r--math/petanque/files/patch-CMakeLists.txt13
-rw-r--r--math/petanque/pkg-descr3
-rw-r--r--math/petanque/pkg-plist13
6 files changed, 57 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index fcf99bcdc742..bc7e1deff7f0 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -752,6 +752,7 @@
SUBDIR += pecl-bitset
SUBDIR += pecl-stats2
SUBDIR += permlib
+ SUBDIR += petanque
SUBDIR += petiga
SUBDIR += php73-bcmath
SUBDIR += php73-gmp
diff --git a/math/petanque/Makefile b/math/petanque/Makefile
new file mode 100644
index 000000000000..88905189b9d8
--- /dev/null
+++ b/math/petanque/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= petanque
+DISTVERSIONPREFIX= release-
+DISTVERSION= 1.1.0
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Library that helps manipulate symbolic boolean expressions
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= cmake:testing compiler:c++14-lang
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= quarkslab
+GH_PROJECT= arybo
+
+WRKSRC_SUBDIR= ${PORTNAME}
+
+CMAKE_ON= BUILD_SHARED_LIBS
+CMAKE_TESTING_ON= WITH_TESTS # tests fail to find TBB, see https://github.com/quarkslab/arybo/issues/29
+
+.include <bsd.port.mk>
diff --git a/math/petanque/distinfo b/math/petanque/distinfo
new file mode 100644
index 000000000000..86999650e0ba
--- /dev/null
+++ b/math/petanque/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1632891698
+SHA256 (quarkslab-arybo-release-1.1.0_GH0.tar.gz) = 96749f152e366c16803c9239e05d15cc9d3f1c156203064519c325be66a57acb
+SIZE (quarkslab-arybo-release-1.1.0_GH0.tar.gz) = 940821
diff --git a/math/petanque/files/patch-CMakeLists.txt b/math/petanque/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..1b221a8caa89
--- /dev/null
+++ b/math/petanque/files/patch-CMakeLists.txt
@@ -0,0 +1,13 @@
+--- CMakeLists.txt.orig 2020-03-28 18:16:21 UTC
++++ CMakeLists.txt
+@@ -16,8 +16,8 @@ include_directories(${Boost_INCLUDE_DIRS})
+ include_directories(${CMAKE_SOURCE_DIR}/third-party)
+
+ add_subdirectory(src)
+-add_subdirectory(bindings)
+-if (NOT (DEFINED NO_TESTS OR NO_TESTS))
++#add_subdirectory(bindings)
++if (WITH_TESTS)
+ add_subdirectory(tests)
+ endif()
+ if (NOT (DEFINED NO_TOOLS OR NO_TOOLS))
diff --git a/math/petanque/pkg-descr b/math/petanque/pkg-descr
new file mode 100644
index 000000000000..bc9660acf4bc
--- /dev/null
+++ b/math/petanque/pkg-descr
@@ -0,0 +1,3 @@
+petanque is a library that helps manipulate symbolic boolean expressions.
+
+WWW: https://github.com/quarkslab/arybo/tree/master/petanque
diff --git a/math/petanque/pkg-plist b/math/petanque/pkg-plist
new file mode 100644
index 000000000000..b3ac0ccda0bc
--- /dev/null
+++ b/math/petanque/pkg-plist
@@ -0,0 +1,13 @@
+include/pa/analyses.h
+include/pa/app.h
+include/pa/bitfield.h
+include/pa/exprs.h
+include/pa/matrix.h
+include/pa/prettyprinter.h
+include/pa/subs.h
+include/pa/symbols.h
+include/pa/syms_hist.h
+include/pa/syms_set.h
+include/pa/traits.h
+include/pa/vector.h
+lib/libpetanque.so