aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-09-29 06:07:19 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-09-29 06:08:08 +0000
commit39cfa300db1b158f0a761255bdd27da44323d2b0 (patch)
tree135bdc938d370e86d14c4f57cb4369b9b29499be /math
parent1e427d25951275287b076cabfd8b0c941beec269 (diff)
downloadports-39cfa300db1b158f0a761255bdd27da44323d2b0.tar.gz
ports-39cfa300db1b158f0a761255bdd27da44323d2b0.zip
math/py-arybo: New port: Manipulation of mixed boolean-arithmetic symbolic expressions
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/py-arybo/Makefile23
-rw-r--r--math/py-arybo/distinfo3
-rw-r--r--math/py-arybo/pkg-descr8
4 files changed, 35 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index a5c3c9072703..9998d48d1b25 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -794,6 +794,7 @@
SUBDIR += py-amply
SUBDIR += py-apgl
SUBDIR += py-arviz
+ SUBDIR += py-arybo
SUBDIR += py-autograd
SUBDIR += py-baycomp
SUBDIR += py-bayesian-optimization
diff --git a/math/py-arybo/Makefile b/math/py-arybo/Makefile
new file mode 100644
index 000000000000..5e476bc0cd0d
--- /dev/null
+++ b/math/py-arybo/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= arybo
+DISTVERSION= 1.1.0
+CATEGORIES= math
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Manipulation of mixed boolean-arithmetic symbolic expressions
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ipython>0:devel/ipython@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}llvmlite>0:devel/py-llvmlite@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}networkx>=2.4:math/py-networkx@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytanque>=1.0:math/py-pytanque@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
+
+USES= compiler:c++14-lang python:3.5+
+USE_PYTHON= distutils concurrent autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/math/py-arybo/distinfo b/math/py-arybo/distinfo
new file mode 100644
index 000000000000..be813aa6b8fd
--- /dev/null
+++ b/math/py-arybo/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1632893913
+SHA256 (arybo-1.1.0.tar.gz) = 33fcee46786129bd43b8d8695164856f127761e32d57f03c0846ae2966ac62de
+SIZE (arybo-1.1.0.tar.gz) = 26998
diff --git a/math/py-arybo/pkg-descr b/math/py-arybo/pkg-descr
new file mode 100644
index 000000000000..265fd7d19312
--- /dev/null
+++ b/math/py-arybo/pkg-descr
@@ -0,0 +1,8 @@
+Arybo is a software for manipulating canonicalization and identification of
+mixed boolean-arithmetic symbolic expressions using bit vectors and gives a
+bit-per-bit symbolic representation.
+
+The ANF (Algebric Normal Form) form is used, which basically represents boolean
+expressions using the XOR and AND operators.
+
+WWW: https://github.com/quarkslab/arybo