aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-01-03 10:27:38 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-01-03 10:27:38 +0000
commitaa86583435780b2f9d5eda003686cb69e3f7262a (patch)
tree40bd2046539d593c2282ffcefd701cc992b014a4 /math
parent5bfb94574dfc2f0a62a4e86faa7a58eeff7a0421 (diff)
downloadports-aa86583435780b2f9d5eda003686cb69e3f7262a.tar.gz
ports-aa86583435780b2f9d5eda003686cb69e3f7262a.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/taucs/Makefile37
-rw-r--r--math/taucs/distinfo1
-rw-r--r--math/taucs/files/patch-config+FreeBSD.mk30
-rw-r--r--math/taucs/files/patch-configure11
-rw-r--r--math/taucs/pkg-descr22
-rw-r--r--math/taucs/pkg-plist6
7 files changed, 108 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 82713be4f6e3..b957ee51fc3c 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -192,6 +192,7 @@
SUBDIR += superlu
SUBDIR += superlu_mt
SUBDIR += surf
+ SUBDIR += taucs
SUBDIR += thx_1138
SUBDIR += topaz
SUBDIR += tvmet
diff --git a/math/taucs/Makefile b/math/taucs/Makefile
new file mode 100644
index 000000000000..8bd82508d8b7
--- /dev/null
+++ b/math/taucs/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: taucs
+# Date created: 5 July 2003
+# Whom: Pedro Giffuni <giffunip@asme.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= taucs
+PORTVERSION= 2.2
+CATEGORIES= math
+MASTER_SITES= http://www.tau.ac.il/~stoledo/taucs/${PORTVERSION}/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= C library of sparse linear solvers
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libf77blas.a:${PORTSDIR}/math/atlas \
+ ${LOCALBASE}/lib/liblapack.a:${PORTSDIR}/math/lapack \
+ ${LOCALBASE}/lib/libmetis.a:${PORTSDIR}/math/metis
+
+NO_WRKSUBDIR= yes
+HAS_CONFIGURE= yes
+MAKEFILE= makefile
+ALL_TARGET=
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/lib/FreeBSD/libtaucs.a ${PREFIX}/lib
+ @${INSTALL_PROGRAM} ${WRKSRC}/bin/FreeBSD/direct ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/bin/FreeBSD/iter ${PREFIX}/bin
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/*.pdf ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/taucs/distinfo b/math/taucs/distinfo
new file mode 100644
index 000000000000..afbffbc8579b
--- /dev/null
+++ b/math/taucs/distinfo
@@ -0,0 +1 @@
+MD5 (taucs.tgz) = ebb43f628c0d3c36873d8a4ec9a31888
diff --git a/math/taucs/files/patch-config+FreeBSD.mk b/math/taucs/files/patch-config+FreeBSD.mk
new file mode 100644
index 000000000000..3a8c79415b6e
--- /dev/null
+++ b/math/taucs/files/patch-config+FreeBSD.mk
@@ -0,0 +1,30 @@
+--- config/FreeBSD.mk.orig Wed Aug 27 15:22:40 2003
++++ config/FreeBSD.mk Wed Aug 27 15:24:30 2003
+@@ -9,11 +9,11 @@
+ DEFFLG=-D
+
+ FC ?= f77
+-FFLAGS += -Os -fno-second-underscore
++FFLAGS += -fno-second-underscore
+ FOUTFLG =-o
+
+ #CC = cc
+-CFLAGS += -Os -D_POSIX_C_SOURCE=199506L -fPIC
++CFLAGS += -D_POSIX_C_SOURCE=199506L -fPIC
+ COUTFLG = -o
+
+ LD = $(CC)
+@@ -26,10 +26,10 @@
+ RANLIB = ranlib
+ RM = rm -rf
+
+-LIBBLAS = -L/usr/local/lib -lf77blas -lcblas -latlas -lg2c
+-LIBLAPACK = -L/usr/local/lib -llapack
++LIBBLAS = -L${LOCALBASE}/lib -lf77blas -lcblas -latlas -lg2c
++LIBLAPACK = -L${LOCALBASE}/lib -llapack
+
+-LIBMETIS = -L/usr/local/lib -lmetis
++LIBMETIS = -L${LOCALBASE}/lib -lmetis
+
+ LIBF77 = -lg2c
+ #compat is required for ftime()
diff --git a/math/taucs/files/patch-configure b/math/taucs/files/patch-configure
new file mode 100644
index 000000000000..ffae32f4b181
--- /dev/null
+++ b/math/taucs/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Sat Jan 3 02:23:57 2004
++++ configure Sat Jan 3 02:24:07 2004
+@@ -29,7 +29,7 @@
+ # Solaris, OSTYPE=solaris but uname returns SunOS.
+
+ if [ ${OSTYPE:-fail} = "fail" ] ; then
+- OSTYPE=`uname | tr "A-Z" "a-z"`
++ OSTYPE=`uname`
+ fi
+
+ # If nothing works, we continue, but configurator will abort
diff --git a/math/taucs/pkg-descr b/math/taucs/pkg-descr
new file mode 100644
index 000000000000..5e9d23199018
--- /dev/null
+++ b/math/taucs/pkg-descr
@@ -0,0 +1,22 @@
+The current version of the library includes the following functionality:
+
+* Multifrontal Supernodal Cholesky Factorization.
+* Left-Looking Supernodal Cholesky Factorization.
+* Drop-Tolerance Incomplete-Cholesky Factorization.
+* LDL^T Factorization.
+* Out-of-Core, Left-Looking Supernodal Sparse Cholesky Factorization.
+* Out-of-Core Sparse LU with Partial Pivoting Factor and Solve.
+* Ordering Codes and Interfaces to Existing Ordering Codes.
+* Matrix Operations.
+* Matrix Input/Output.
+* Matrix Generators.
+* Iterative Solvers.
+* Vaidya's Preconditioners.
+* Recursive Vaidya's Preconditioners.
+* Multilevel-Support-Graph Preconditioners.
+* Utility Routines.
+
+Copyright (c) 2001 by Sivan Toledo, Tel-Aviv University,
+stoledo@tau.ac.il. All Rights Reserved.
+
+WWW: http://www.tau.ac.il/~stoledo/taucs/
diff --git a/math/taucs/pkg-plist b/math/taucs/pkg-plist
new file mode 100644
index 000000000000..828516f7bfdc
--- /dev/null
+++ b/math/taucs/pkg-plist
@@ -0,0 +1,6 @@
+bin/direct
+bin/iter
+lib/libtaucs.a
+%%PORTDOCS%%%%DOCSDIR%%/taucs.pdf
+%%PORTDOCS%%%%DOCSDIR%%/cilk-mf.pdf
+%%PORTDOCS%%@dirrm %%DOCSDIR%%