aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2003-07-14 02:53:03 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2003-07-14 02:53:03 +0000
commitb185046be2ec03555daaf4f26d38542c403a9955 (patch)
tree0274ce607614533de66837fc1f70d4c35770d9e1 /math
parent88d002074007544d532f2495aeb93729291e6275 (diff)
downloadports-b185046be2ec03555daaf4f26d38542c403a9955.tar.gz
ports-b185046be2ec03555daaf4f26d38542c403a9955.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/gexpr/Makefile9
-rw-r--r--math/gexpr/files/patch-Makefile8
-rw-r--r--math/mtrxmath/Makefile9
-rw-r--r--math/mtrxmath/files/patch-Makefile8
4 files changed, 18 insertions, 16 deletions
diff --git a/math/gexpr/Makefile b/math/gexpr/Makefile
index 8241d26cc26f..987763b06992 100644
--- a/math/gexpr/Makefile
+++ b/math/gexpr/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gexpr
PORTVERSION= 2.0.2
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= apps/math/calc
@@ -15,13 +16,11 @@ MASTER_SITE_SUBDIR= apps/math/calc
MAINTAINER= ijliao@FreeBSD.org
COMMENT= A shell calculator
-LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
-
+USE_GETOPT_LONG=yes
USE_REINPLACE= yes
+MAKE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
MAN1= gexpr.1
-post-patch:
- @${REINPLACE_CMD} -e "s,%%LOCALBASE%%,${LOCALBASE},g" ${WRKSRC}/Makefile
-
.include <bsd.port.mk>
diff --git a/math/gexpr/files/patch-Makefile b/math/gexpr/files/patch-Makefile
index 54f3d5c71b87..66a75a976db9 100644
--- a/math/gexpr/files/patch-Makefile
+++ b/math/gexpr/files/patch-Makefile
@@ -1,16 +1,16 @@
---- Makefile.orig Thu Jun 14 05:36:02 2001
-+++ Makefile Thu Jun 14 05:39:22 2001
+--- Makefile.orig Sat Feb 13 02:28:35 1999
++++ Makefile Sun Jul 6 20:06:03 2003
@@ -1,11 +1,10 @@
# Makefile for gexpr
# Last updated: 10 February 1999
-CC = gcc
-OPTS = -s -O2 -Wall
-+OPTS = ${CFLAGS} -I%%LOCALBASE%%/include
++OPTS = ${CFLAGS} ${CPPFLAGS}
OBJS = eval.o read_token.o commands.o output.o errors.o gexpr.o
GEXPR = gexpr
-LIBS = -lm
-+LIBS = -lm -L%%LOCALBASE%%/lib -lgnugetopt
++LIBS = -lm ${LDFLAGS}
all: $(GEXPR)
diff --git a/math/mtrxmath/Makefile b/math/mtrxmath/Makefile
index 1c7bec009a47..5da4f3f73698 100644
--- a/math/mtrxmath/Makefile
+++ b/math/mtrxmath/Makefile
@@ -5,15 +5,18 @@
# $FreeBSD$
#
-PORTNAME= mtrxmath
+PORTNAME= mtrxmath
PORTVERSION= 0.9.3
-CATEGORIES= math
+PORTREVISION= 1
+CATEGORIES= math
MASTER_SITES= http://www.angelfire.com/linux/linuxjeff/mtrxmath/files/
MAINTAINER= greid@ukug.uk.freebsd.org
COMMENT= A small tool for matrix mathemetics
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+USE_GETOPT_LONG=yes
+MAKE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/mtrxmath ${PREFIX}/bin
diff --git a/math/mtrxmath/files/patch-Makefile b/math/mtrxmath/files/patch-Makefile
index 4e9502de0bf9..f096036dd594 100644
--- a/math/mtrxmath/files/patch-Makefile
+++ b/math/mtrxmath/files/patch-Makefile
@@ -1,8 +1,8 @@
---- Makefile.orig Sun Jan 7 23:29:11 2001
-+++ Makefile Tue Jan 9 20:43:18 2001
+--- Makefile.orig Mon Jan 8 08:29:11 2001
++++ Makefile Sun Jul 6 20:09:15 2003
@@ -1,4 +1,4 @@
-CFLAGS=-Wall -g
-+CFLAGS+=-Wall -g -I${PREFIX}/include
++CFLAGS+=-Wall -g ${CPPFLAGS}
SRCS=add.c mtrxmath.c mult.c sub.c inverse.c
@@ -11,7 +11,7 @@
${EXE}: ${OBJS}
- ${CC} -o $@ ${OBJS}
-+ ${CC} -o $@ ${OBJS} -L${PREFIX}/lib -lgnugetopt
++ ${CC} -o $@ ${OBJS} ${LDFLAGS}
clean:
rm -f ${OBJS} ${EXE} *.orig