aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-08-30 01:52:16 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-08-30 01:52:16 +0000
commit2ab696ca9ac03a4413a166262409548966697a5d (patch)
treee5f93b58bffb0b98038837a845a86afe9cf9bb95 /math
parent1b8190e1ea951221363351a7898d7c50285a75c5 (diff)
downloadports-2ab696ca9ac03a4413a166262409548966697a5d.tar.gz
ports-2ab696ca9ac03a4413a166262409548966697a5d.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/yacas/Makefile5
-rw-r--r--math/yacas/distinfo4
-rw-r--r--math/yacas/files/patch-embed-example4.c29
-rw-r--r--math/yacas/files/patch-plugins::pcre::plugin.cc11
-rw-r--r--math/yacas/files/patch-plugins:filescanner::plugin.cc11
-rw-r--r--math/yacas/files/patch-scripts::compile.rep::compilecpp.ys11
-rw-r--r--math/yacas/files/patch-src::Makefile.in23
-rw-r--r--math/yacas/pkg-plist18
8 files changed, 63 insertions, 49 deletions
diff --git a/math/yacas/Makefile b/math/yacas/Makefile
index d7b3e71012f3..9ef4f135b174 100644
--- a/math/yacas/Makefile
+++ b/math/yacas/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= yacas
-PORTVERSION= 1.0.57
-PORTREVISION= 1
+PORTVERSION= 1.0.58
CATEGORIES= math
MASTER_SITES= http://yacas.sourceforge.net/backups/
@@ -39,7 +38,7 @@ PLIST_SUB+= GMP="@comment " NOGMP=""
.if defined(WITH_X11)
USE_GL= yes
-CONFIGURE_ARGS+=--with-x
+CONFIGURE_ARGS+= --with-x
PLIST_SUB+= X11=""
CPPFLAGS+= -I${X11BASE}/include
LDFLAGS+= -L${X11BASE}/lib
diff --git a/math/yacas/distinfo b/math/yacas/distinfo
index 4e60ed4b4dcd..00f7b7b9806b 100644
--- a/math/yacas/distinfo
+++ b/math/yacas/distinfo
@@ -1,2 +1,2 @@
-MD5 (yacas-1.0.57.tar.gz) = 0e5161457cb7d818aa8009676998696b
-SIZE (yacas-1.0.57.tar.gz) = 1974503
+MD5 (yacas-1.0.58.tar.gz) = fd7fa942789fdac8fa363e555c86cae9
+SIZE (yacas-1.0.58.tar.gz) = 2089209
diff --git a/math/yacas/files/patch-embed-example4.c b/math/yacas/files/patch-embed-example4.c
new file mode 100644
index 000000000000..03d31dec111e
--- /dev/null
+++ b/math/yacas/files/patch-embed-example4.c
@@ -0,0 +1,29 @@
+--- embed/example4.c.orig Mon Jul 18 04:54:09 2005
++++ embed/example4.c Sun Aug 7 22:28:37 2005
+@@ -22,10 +22,12 @@
+ }
+ void runexpr(void* object)
+ {
++ void* result;
++
+ printf("Input> ");
+ print_expr(object);
+ printf("\n");
+- void* result = yacas_execute(object);
++ result = yacas_execute(object);
+ printf("Output> ");
+ print_expr(result);
+ printf("\n");
+@@ -35,9 +37,10 @@
+ int main(int argc, char** argv)
+ {
+ int i;
++ void *input;
+ yacas_init();
+-
+- void *input =
++
++ input =
+ yacas_create_sublist(
+ yacas_link_objects(
+ yacas_create_atom("+"),
diff --git a/math/yacas/files/patch-plugins::pcre::plugin.cc b/math/yacas/files/patch-plugins::pcre::plugin.cc
deleted file mode 100644
index ffdf460d0ae5..000000000000
--- a/math/yacas/files/patch-plugins::pcre::plugin.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- plugins/pcre/plugin.cc.orig Sun Aug 24 14:17:25 2003
-+++ plugins/pcre/plugin.cc Thu Jul 29 16:05:37 2004
-@@ -180,7 +180,7 @@
- return NEW PcrePlugin;
- }
-
--};
-+}
-
-
-
diff --git a/math/yacas/files/patch-plugins:filescanner::plugin.cc b/math/yacas/files/patch-plugins:filescanner::plugin.cc
deleted file mode 100644
index fd897fa7dd5a..000000000000
--- a/math/yacas/files/patch-plugins:filescanner::plugin.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- plugins/filescanner/plugin.cc.orig Sun Aug 24 14:17:44 2003
-+++ plugins/filescanner/plugin.cc Thu Jul 29 16:07:27 2004
-@@ -81,7 +81,7 @@
- return NEW FileScannerPlugin;
- }
-
--};
-+}
-
-
-
diff --git a/math/yacas/files/patch-scripts::compile.rep::compilecpp.ys b/math/yacas/files/patch-scripts::compile.rep::compilecpp.ys
deleted file mode 100644
index bc28ab9211d7..000000000000
--- a/math/yacas/files/patch-scripts::compile.rep::compilecpp.ys
+++ /dev/null
@@ -1,11 +0,0 @@
---- scripts/compile.rep/compilecpp.ys.orig Sun Aug 24 14:35:27 2003
-+++ scripts/compile.rep/compilecpp.ys Thu Jul 29 15:48:30 2004
-@@ -395,7 +395,7 @@
-
- // The define OPTIMIZE_COMPILED_PLUGIN_SIZE should be defined somewhere else.
- #ifndef WIN32 // some macro expansion is failing on Win platform, no idea why.
--#define OPTIMIZE_COMPILED_PLUGIN_SIZE
-+// #define OPTIMIZE_COMPILED_PLUGIN_SIZE
- #endif // WIN32
-
- #ifdef OPTIMIZE_COMPILED_PLUGIN_SIZE
diff --git a/math/yacas/files/patch-src::Makefile.in b/math/yacas/files/patch-src::Makefile.in
index e6818f64fda0..d93003d073e5 100644
--- a/math/yacas/files/patch-src::Makefile.in
+++ b/math/yacas/files/patch-src::Makefile.in
@@ -1,11 +1,26 @@
---- src/Makefile.in.orig Wed May 21 05:56:37 2003
-+++ src/Makefile.in Wed May 21 12:55:31 2003
-@@ -809,7 +809,7 @@
+--- src/Makefile.in.orig Sun Aug 7 17:56:40 2005
++++ src/Makefile.in Sun Aug 7 22:02:49 2005
+@@ -878,12 +878,12 @@
# The libmath.cpp source file is generated as follows
- $(srcdir)/libmath.cpp: $(top_srcdir)/scripts/base.rep/math.ys yacas$(EXEEXT)
+ $(srcdir)/libmath.cpp: $(top_srcdir)/scripts/base.rep/math.ys yacas$(EXEEXT) check_plugins
- (cd ../scripts && make packages.ys corefunctions.ys)
+ (cd ../scripts && $(MAKE) packages.ys corefunctions.ys)
echo "Set(LoadPlugIns,False);Use(\"yacasinit.ys\");" > compileinit.txt
echo "CompileCpp(\"base.rep/math.ys\",\"libmath\");" > compile.txt
./yacas$(EXEEXT) --rootdir $(top_srcdir)/scripts -pc --init compileinit.txt compile.txt
+ ./check_plugins
+- make
++ $(MAKE)
+
+ $(srcdir)/platmath.cpp: fastprimes.c
+
+@@ -917,7 +917,7 @@
+
+ pcre_plugin_stub.cpp:plugin_stub_gen $(srcdir)/plugins_available.h
+ ./plugin_stub_gen pcre_plugin_stub.cpp ../plugins/pcre/plugin.cpp
+- cd ../plugins/pcre/ ; make chartables.c
++ cd ../plugins/pcre/ ; $(MAKE) chartables.c
+
+ filescanner_stub.cpp:plugin_stub_gen $(srcdir)/plugins_available.h
+ ./plugin_stub_gen filescanner_stub.cpp filescanner.cpp
diff --git a/math/yacas/pkg-plist b/math/yacas/pkg-plist
index 512e9c59c4da..2e8ea4f774b1 100644
--- a/math/yacas/pkg-plist
+++ b/math/yacas/pkg-plist
@@ -23,16 +23,16 @@ lib/libyacasplatform.so
lib/libyacasplatform.so.0
lib/yacas/example.la
lib/yacas/example.so
-lib/yacas/filescanner.so
lib/yacas/filescanner.la
+lib/yacas/filescanner.so
lib/yacas/forth.la
lib/yacas/forth.so
lib/yacas/libmath.a
lib/yacas/libmath.la
lib/yacas/libmath.so
lib/yacas/libmath.so.0
-lib/yacas/pcre.so
lib/yacas/pcre.la
+lib/yacas/pcre.so
%%X11%%lib/yacas/opengl.la
%%X11%%lib/yacas/opengl.so
lib/yacas/yacas_gsl.la
@@ -123,6 +123,8 @@ lib/yacas/yacas_gsl.so
%%DATADIR%%/documentation/codingmanual.html
%%DATADIR%%/documentation/essays.html
%%DATADIR%%/documentation/essayschapter1.html
+%%DATADIR%%/documentation/essayschapter10.html
+%%DATADIR%%/documentation/essayschapter11.html
%%DATADIR%%/documentation/essayschapter12.html
%%DATADIR%%/documentation/essayschapter2.html
%%DATADIR%%/documentation/essayschapter3.html
@@ -134,6 +136,7 @@ lib/yacas/yacas_gsl.so
%%DATADIR%%/documentation/essayschapter9.html
%%DATADIR%%/documentation/essayschapters.html
%%DATADIR%%/documentation/essaysmanual.html
+%%DATADIR%%/documentation/hints
%%DATADIR%%/documentation/intro.html
%%DATADIR%%/documentation/introchapter1.html
%%DATADIR%%/documentation/introchapter2.html
@@ -182,9 +185,6 @@ lib/yacas/yacas_gsl.so
%%DATADIR%%/documentation/refprogchapters.html
%%DATADIR%%/documentation/refprogmanual.html
%%DATADIR%%/documentation/yacaslogo.gif
-%%DATADIR%%/documentation/hints
-%%DATADIR%%/documentation/essayschapter10.html
-%%DATADIR%%/documentation/essayschapter11.html
%%DATADIR%%/example.rep/code.ys
%%DATADIR%%/example.rep/code.ys.def
%%DATADIR%%/examples/ABIN.ys
@@ -273,6 +273,7 @@ lib/yacas/yacas_gsl.so
%%DATADIR%%/include/plat/linux32/platfileio.h
%%DATADIR%%/include/plat/linux32/stubs.inl
%%DATADIR%%/include/platmath.h
+%%DATADIR%%/include/plugins_available.h
%%DATADIR%%/include/refcount.h
%%DATADIR%%/include/standard.h
%%DATADIR%%/include/standard.inl
@@ -296,6 +297,7 @@ lib/yacas/yacas_gsl.so
%%DATADIR%%/include/yacasprivate.h
%%DATADIR%%/integrate.rep/code.ys
%%DATADIR%%/integrate.rep/code.ys.def
+%%DATADIR%%/integrate.rep/om.ys
%%DATADIR%%/io.rep/code.ys
%%DATADIR%%/io.rep/code.ys.def
%%DATADIR%%/io.rep/defaultprint.ys
@@ -386,6 +388,7 @@ lib/yacas/yacas_gsl.so
%%DATADIR%%/specfunc.rep/gamma.ys.def
%%DATADIR%%/specfunc.rep/gammaconst.ys
%%DATADIR%%/specfunc.rep/gammaconst.ys.def
+%%DATADIR%%/specfunc.rep/om.ys
%%DATADIR%%/specfunc.rep/zeta.ys
%%DATADIR%%/specfunc.rep/zeta.ys.def
%%DATADIR%%/standard.ys
@@ -403,6 +406,8 @@ lib/yacas/yacas_gsl.so
%%DATADIR%%/statistics.rep/statistics.ys.def
%%DATADIR%%/stats.rep/code.ys
%%DATADIR%%/stats.rep/code.ys.def
+%%DATADIR%%/stdarith.ys
+%%DATADIR%%/stdarith.ys.def
%%DATADIR%%/stdfuncs.rep/code.ys
%%DATADIR%%/stdfuncs.rep/code.ys.def
%%DATADIR%%/stdfuncs.rep/elemfuncs.ys
@@ -420,6 +425,7 @@ lib/yacas/yacas_gsl.so
%%DATADIR%%/substitute.rep/code.ys.def
%%DATADIR%%/sums.rep/code.ys
%%DATADIR%%/sums.rep/code.ys.def
+%%DATADIR%%/sums.rep/om.ys
%%DATADIR%%/sums.rep/taylor.ys
%%DATADIR%%/sums.rep/taylor.ys.def
%%DATADIR%%/sums.rep/taylor3.ys
@@ -442,8 +448,6 @@ lib/yacas/yacas_gsl.so
%%DATADIR%%/univar.rep/sparse.ys.def
%%DATADIR%%/univar.rep/sturm.ys
%%DATADIR%%/univar.rep/sturm.ys.def
-%%DATADIR%%/stdarith.ys
-%%DATADIR%%/stdarith.ys.def
%%DATADIR%%/yacas-gmtplot2d.sh
%%DATADIR%%/yacas-gmtplot3d.sh
%%DATADIR%%/yacasinit.ys