aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2010-02-16 06:54:31 +0000
committerMaho Nakata <maho@FreeBSD.org>2010-02-16 06:54:31 +0000
commit79cefd0274aa148ae5de47867c7766b2c01f935b (patch)
treeeb5a6b240ed983001f80a7623c6bdd7bbf189aed /math
parentf0ddab7e17beba8ee3ffe518de36f97c28804e4b (diff)
downloadports-79cefd0274aa148ae5de47867c7766b2c01f935b.tar.gz
ports-79cefd0274aa148ae5de47867c7766b2c01f935b.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/octave/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
index 9ca2a8e92aba..1b1eb154a299 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -47,7 +47,7 @@ MAN1= octave.1 octave-bug.1 mkoctfile.1 octave-config.1
USE_BLAS?= reference
-.if exists(${LOCALBASE}/lib/libgoto.so)
+.if exists(${LOCALBASE}/lib/libgoto2.so)
USE_BLAS= gotoblas
.elif exists(${LOCALBASE}/lib/libatlas_r.so)
USE_BLAS= atlas
@@ -59,10 +59,9 @@ LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
BLAS= -lblas
LAPACK= -llapack
.elif ${USE_BLAS} == gotoblas
-LIB_DEPENDS+= goto:${PORTSDIR}/math/gotoblas
-LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
-BLAS= -lgotop
-LAPACK= -lgotop -llapack
+LIB_DEPENDS+= goto2:${PORTSDIR}/math/gotoblas
+BLAS= -lgoto2p
+LAPACK= -lgoto2p
.elif ${USE_BLAS} == atlas
LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
BLAS= -lptf77blas -lptcblas -latlas_r