aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2009-08-02 19:36:34 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2009-08-02 19:36:34 +0000
commit789d75c728ef23566a07bf5b9bc2190bf34ff4f1 (patch)
treedc7540d42fa2d5d7c1c74515e3bdbf6ab842cd17 /math
parentd1a9e827c98542eb35619dffa314cba50fb08b58 (diff)
downloadports-789d75c728ef23566a07bf5b9bc2190bf34ff4f1.tar.gz
ports-789d75c728ef23566a07bf5b9bc2190bf34ff4f1.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/GiNaC/Makefile2
-rw-r--r--math/blitz++/Makefile2
-rw-r--r--math/cln/Makefile2
-rw-r--r--math/dieharder/Makefile9
-rw-r--r--math/fftw/Makefile2
-rw-r--r--math/fityk/Makefile2
-rw-r--r--math/freefem/Makefile2
-rw-r--r--math/fung-calc/Makefile2
-rw-r--r--math/gambit/Makefile2
-rw-r--r--math/gcalctool/Makefile2
-rw-r--r--math/gmp/Makefile2
-rw-r--r--math/gretl/Makefile2
-rw-r--r--math/guppi/Makefile2
-rw-r--r--math/koctave/Makefile2
-rw-r--r--math/labplot/Makefile2
-rw-r--r--math/lapack++/Makefile2
-rw-r--r--math/libgmp4/Makefile2
-rw-r--r--math/libmath++/Makefile4
-rw-r--r--math/libneural/Makefile2
-rw-r--r--math/libqalculate/Makefile2
-rw-r--r--math/ltl/Makefile2
-rw-r--r--math/pgcalc/Makefile2
-rw-r--r--math/plplot/Makefile4
-rw-r--r--math/pspp/Makefile2
-rw-r--r--math/qhull/Makefile2
-rw-r--r--math/qhull5/Makefile2
-rw-r--r--math/rkward/Makefile2
-rw-r--r--math/spar/Makefile2
-rw-r--r--math/tvmet/Makefile2
-rw-r--r--math/yacas/Makefile2
30 files changed, 39 insertions, 32 deletions
diff --git a/math/GiNaC/Makefile b/math/GiNaC/Makefile
index 6ce8645963cd..92c64b94bdac 100644
--- a/math/GiNaC/Makefile
+++ b/math/GiNaC/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= cln.5:${PORTSDIR}/math/cln
USE_BZIP2= yes
USE_GNOME= gnomehack pkgconfig
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes
diff --git a/math/blitz++/Makefile b/math/blitz++/Makefile
index 721bd3fa1dc7..c005be3a6896 100644
--- a/math/blitz++/Makefile
+++ b/math/blitz++/Makefile
@@ -25,7 +25,7 @@ MAKE_ARGS= NOPORTDOCS=yes
.endif
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GNOME= gnometarget gnomehack
CONFIGURE_ARGS= --with-cxx=gcc --disable-doxygen
MAKE_ARGS+= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
diff --git a/math/cln/Makefile b/math/cln/Makefile
index f55ab3071b14..c107b638a684 100644
--- a/math/cln/Makefile
+++ b/math/cln/Makefile
@@ -19,7 +19,7 @@ COMMENT= Class Library for Numbers
LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_BZIP2= yes
USE_GNOME= gnomehack gnometarget pkgconfig
USE_GMAKE= yes
diff --git a/math/dieharder/Makefile b/math/dieharder/Makefile
index e9e9d1dadb30..16d77356537b 100644
--- a/math/dieharder/Makefile
+++ b/math/dieharder/Makefile
@@ -16,13 +16,20 @@ COMMENT= A random number generator testsuite
LIB_DEPENDS= gsl:${PORTSDIR}/math/gsl
-USE_AUTOTOOLS= aclocal:110 autoheader:262 libtool:15
+USE_AUTOTOOLS= aclocal:110 autoheader:262 libtool:22
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
USE_LDCONFIG= yes
MAN1= dieharder.1
MAN3= libdieharder.3
+post-patch:
+ @${REINPLACE_CMD} -e "s|./configure|#./configure|g" \
+ ${WRKSRC}/autogen.sh
+
run-autotools:
@(cd ${WRKSRC}; ${SETENV} ${AUTOTOOLS_ENV} ${SH} ./autogen.sh)
+ @${REINPLACE_CMD} -e "/^ltmain=/!s^\$$ac_aux_dir/ltmain.sh^${LIBTOOLFLAGS} ${LTMAIN}^g" \
+ -e '/^LIBTOOL=/s^\$$(top_builddir)/libtool^${LIBTOOL}^g' \
+ ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/math/fftw/Makefile b/math/fftw/Makefile
index f0cfdc064d7d..4937c7651c23 100644
--- a/math/fftw/Makefile
+++ b/math/fftw/Makefile
@@ -22,7 +22,7 @@ COMMENT?= Fast C routines to compute the Discrete Fourier Transform
FFTW_FLAVOR?= default
FFTW_SUFIX=
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_FORTRAN= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/math/fityk/Makefile b/math/fityk/Makefile
index 3358b6f1ce49..643e4112a37a 100644
--- a/math/fityk/Makefile
+++ b/math/fityk/Makefile
@@ -23,7 +23,7 @@ USE_GNOME= gtk20
USE_WX= 2.8+
WX_CONF_ARGS= absolute
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-xylib
USE_LDCONFIG= yes
diff --git a/math/freefem/Makefile b/math/freefem/Makefile
index d06d10bfce90..48d0607296a9 100644
--- a/math/freefem/Makefile
+++ b/math/freefem/Makefile
@@ -16,7 +16,7 @@ COMMENT= A language for the Finite Element Method
USE_XORG= ice sm x11 xt
USE_GNOME= gnometarget
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_LDCONFIG= yes
MAN1= freefem.1
diff --git a/math/fung-calc/Makefile b/math/fung-calc/Makefile
index 69046f2c74b9..82b73161ade9 100644
--- a/math/fung-calc/Makefile
+++ b/math/fung-calc/Makefile
@@ -18,7 +18,7 @@ USE_KDELIBS_VER=3
USE_GL= glut
USE_GMAKE= yes
USE_LDCONFIG= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
pre-configure:
diff --git a/math/gambit/Makefile b/math/gambit/Makefile
index b954ced76426..613a62e129ec 100644
--- a/math/gambit/Makefile
+++ b/math/gambit/Makefile
@@ -17,7 +17,7 @@ COMMENT= A library of tools for doing computation in game theory
USE_GNOME= gnometarget gtk20
USE_WX= 2.6+
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes
diff --git a/math/gcalctool/Makefile b/math/gcalctool/Makefile
index fe8f4671df03..59199f5fa4ce 100644
--- a/math/gcalctool/Makefile
+++ b/math/gcalctool/Makefile
@@ -22,7 +22,7 @@ USE_BISON= build
INSTALLS_OMF= yes
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GNOME= gnomeprefix gnomehack intlhack gconf2 gnomedocutils libglade2
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/math/gmp/Makefile b/math/gmp/Makefile
index 44428141fe31..8bf24ff8bef1 100644
--- a/math/gmp/Makefile
+++ b/math/gmp/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= ale@FreeBSD.org
COMMENT= A free library for arbitrary precision arithmetic
USE_BZIP2= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
GNU_CONFIGURE= yes
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
CONFIGURE_ARGS= --enable-cxx
diff --git a/math/gretl/Makefile b/math/gretl/Makefile
index e41f77664d22..359c436a775f 100644
--- a/math/gretl/Makefile
+++ b/math/gretl/Makefile
@@ -24,7 +24,7 @@ WANT_GNOME= yes
USE_GNOME= gnomehier gtk20 gtksourceview2 libxml2
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${GCCLIBDIR}"
CONFIGURE_ARGS= --enable-static --enable-shared --with-gmake --without-gnome
diff --git a/math/guppi/Makefile b/math/guppi/Makefile
index 00e2e8f34ae7..93bc585a00c9 100644
--- a/math/guppi/Makefile
+++ b/math/guppi/Makefile
@@ -22,7 +22,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack gnomelibs bonobo libglade gal gnometarget
USE_PYTHON= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-gnumeric --enable-explicit-python-linking
diff --git a/math/koctave/Makefile b/math/koctave/Makefile
index 2773988693f5..3aa8231ab4ca 100644
--- a/math/koctave/Makefile
+++ b/math/koctave/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= octave:${PORTSDIR}/math/octave
USE_QT_VER= 3
USE_KDELIBS_VER=3
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
post-patch:
${REINPLACE_CMD} -e '/kde_appsdir/s|applnk||g' ${WRKSRC}/configure
diff --git a/math/labplot/Makefile b/math/labplot/Makefile
index 586f008a4420..2d57b91fe681 100644
--- a/math/labplot/Makefile
+++ b/math/labplot/Makefile
@@ -28,7 +28,7 @@ USE_QT_VER= 3
USE_KDELIBS_VER=3
USE_GL= glu
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
USE_GETTEXT= yes
diff --git a/math/lapack++/Makefile b/math/lapack++/Makefile
index 689908f07aeb..d5c4ad97ee31 100644
--- a/math/lapack++/Makefile
+++ b/math/lapack++/Makefile
@@ -36,7 +36,7 @@ LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
USE_FORTRAN= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GMAKE= yes
.if defined(WITH_ATLAS)
BLAS_LIB= -L${LOCALBASE}/lib -lf77blas -latlas
diff --git a/math/libgmp4/Makefile b/math/libgmp4/Makefile
index 44428141fe31..8bf24ff8bef1 100644
--- a/math/libgmp4/Makefile
+++ b/math/libgmp4/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= ale@FreeBSD.org
COMMENT= A free library for arbitrary precision arithmetic
USE_BZIP2= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
GNU_CONFIGURE= yes
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
CONFIGURE_ARGS= --enable-cxx
diff --git a/math/libmath++/Makefile b/math/libmath++/Makefile
index 54d76377c2f7..19c5a1c0eb97 100644
--- a/math/libmath++/Makefile
+++ b/math/libmath++/Makefile
@@ -13,9 +13,9 @@ MASTER_SITES= http://www.robertjohnkaper.com/downloads/atlantik/
MAINTAINER= jhb@FreeBSD.org
COMMENT= C++ Library for Symbolic and Numeric Calculus Applications
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/math/libneural/Makefile b/math/libneural/Makefile
index 5aee5329cab3..702e98f4179e 100644
--- a/math/libneural/Makefile
+++ b/math/libneural/Makefile
@@ -14,7 +14,7 @@ MASTER_SITES= http://www.freebsdbrasil.com.br/~jmelo/
MAINTAINER= ports@FreeBSD.org
COMMENT= C++ implementation of the classic 3-layer perceptron in library form
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/math/libqalculate/Makefile b/math/libqalculate/Makefile
index cd0332aeb904..bfabb984890f 100644
--- a/math/libqalculate/Makefile
+++ b/math/libqalculate/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= cln.5:${PORTSDIR}/math/cln
USE_GNOME= glib20 gnomehack gnometarget intlhack libxml2
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_LDCONFIG= yes
post-patch:
diff --git a/math/ltl/Makefile b/math/ltl/Makefile
index 330f1e2fce9e..fa15868feba7 100644
--- a/math/ltl/Makefile
+++ b/math/ltl/Makefile
@@ -16,7 +16,7 @@ COMMENT= A C++ class SSE library for scientific computing
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
CONFIGURE_ARGS= --with-cxx=gcc --disable-doxygen --prefix=${PREFIX} --includedir=${PREFIX}/include/LTL
MAKE_ENV= prefix=${PREFIX} exec_prefix=${PREFIX}
MAKE_ARGS+= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
diff --git a/math/pgcalc/Makefile b/math/pgcalc/Makefile
index f0b39452b8e7..9e2a5076e0b7 100644
--- a/math/pgcalc/Makefile
+++ b/math/pgcalc/Makefile
@@ -17,7 +17,7 @@ COMMENT= A powerful scientific skinnable calculator
USE_QT_VER= 3
USE_KDELIBS_VER= 3
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
INSTALLS_ICONS= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/math/plplot/Makefile b/math/plplot/Makefile
index 060875fbcea5..7689634c5775 100644
--- a/math/plplot/Makefile
+++ b/math/plplot/Makefile
@@ -7,7 +7,7 @@
PORTNAME= plplot
PORTVERSION= 5.8.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math science
MASTER_SITES= SF
@@ -18,7 +18,7 @@ LIB_DEPENDS= unicode.0:${PORTSDIR}/devel/libunicode \
gd.4:${PORTSDIR}/graphics/gd \
qhull.5:${PORTSDIR}/math/qhull
-USE_AUTOTOOLS= libltdl:15
+USE_AUTOTOOLS= libltdl:22
USE_PERL5_BUILD=yes
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/math/pspp/Makefile b/math/pspp/Makefile
index db9aa794295c..62c8bec69404 100644
--- a/math/pspp/Makefile
+++ b/math/pspp/Makefile
@@ -24,7 +24,7 @@ USE_GNOME= libxml2
USE_PERL5_BUILD=yes
USE_ICONV= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
INFO= pspp pspp-dev
diff --git a/math/qhull/Makefile b/math/qhull/Makefile
index 5bdb03b8b359..d4ddbc802564 100644
--- a/math/qhull/Makefile
+++ b/math/qhull/Makefile
@@ -14,7 +14,7 @@ DISTNAME= ${PORTNAME}-2003.1
MAINTAINER= stephen@missouri.edu
COMMENT= Qhull computes convex hulls, Delaunay triangulations and halfspaces
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GMAKE= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/math/qhull5/Makefile b/math/qhull5/Makefile
index 5bdb03b8b359..d4ddbc802564 100644
--- a/math/qhull5/Makefile
+++ b/math/qhull5/Makefile
@@ -14,7 +14,7 @@ DISTNAME= ${PORTNAME}-2003.1
MAINTAINER= stephen@missouri.edu
COMMENT= Qhull computes convex hulls, Delaunay triangulations and halfspaces
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GMAKE= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/math/rkward/Makefile b/math/rkward/Makefile
index e98614062091..8cc52671adcf 100644
--- a/math/rkward/Makefile
+++ b/math/rkward/Makefile
@@ -24,7 +24,7 @@ USE_KDELIBS_VER=3
USE_PHP= yes
WANT_PHP_CLI= yes
USE_GETTEXT= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
CONFIGURE_ARGS= --disable-fast-perl
diff --git a/math/spar/Makefile b/math/spar/Makefile
index d93d4d50dc52..cd56780879a1 100644
--- a/math/spar/Makefile
+++ b/math/spar/Makefile
@@ -16,7 +16,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A modular math parser
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/math/tvmet/Makefile b/math/tvmet/Makefile
index 2701b59324c3..2e02c92a3b55 100644
--- a/math/tvmet/Makefile
+++ b/math/tvmet/Makefile
@@ -16,7 +16,7 @@ COMMENT= Tiny Vector and Matrix template library
USE_BZIP2= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
MAKE_ARGS= CXX="${CXX}" CXXFLAGS="${CXXFLAGS}"
MAN1= tvmet-config.1
diff --git a/math/yacas/Makefile b/math/yacas/Makefile
index 65237041e944..f8f48be08fd5 100644
--- a/math/yacas/Makefile
+++ b/math/yacas/Makefile
@@ -17,7 +17,7 @@ COMMENT= Yet Another Computer Algebra System
LIB_DEPENDS= gsl.13:${PORTSDIR}/math/gsl
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_PERL5_BUILD= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes