aboutsummaryrefslogtreecommitdiff
path: root/mbone/speak_freely/files
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2011-03-06 22:36:23 +0000
committerPav Lucistnik <pav@FreeBSD.org>2011-03-06 22:36:23 +0000
commitde05c59dc7246a3a49595d7bb9db844d9a0dd9c2 (patch)
treee0c639a12886e6a16b6b23e3aecc811616aa2654 /mbone/speak_freely/files
parent5edd0ddb0bbe600fec0d67dde57590957228358a (diff)
downloadports-de05c59dc7246a3a49595d7bb9db844d9a0dd9c2.tar.gz
ports-de05c59dc7246a3a49595d7bb9db844d9a0dd9c2.zip
Notes
Diffstat (limited to 'mbone/speak_freely/files')
-rw-r--r--mbone/speak_freely/files/patch-aa93
-rw-r--r--mbone/speak_freely/files/patch-ac69
-rw-r--r--mbone/speak_freely/files/patch-ad11
-rw-r--r--mbone/speak_freely/files/patch-ae24
-rw-r--r--mbone/speak_freely/files/patch-af11
-rw-r--r--mbone/speak_freely/files/patch-ag8
-rw-r--r--mbone/speak_freely/files/patch-ah11
-rw-r--r--mbone/speak_freely/files/patch-speakfree.h13
8 files changed, 0 insertions, 240 deletions
diff --git a/mbone/speak_freely/files/patch-aa b/mbone/speak_freely/files/patch-aa
deleted file mode 100644
index f328cf09d01c..000000000000
--- a/mbone/speak_freely/files/patch-aa
+++ /dev/null
@@ -1,93 +0,0 @@
---- Makefile.orig Sun Jun 8 22:21:55 2003
-+++ Makefile Sun Jun 8 22:33:37 2003
-@@ -6,7 +6,7 @@
- #DEBUG = -O
- #DEBUG = -g -DHEXDUMP
- #DEBUG = -g -DHEXDUMP -DNOCRYPTO
--DEBUG = -O3 -DHEXDUMP
-+#DEBUG = -O3 -DHEXDUMP
-
- # Installation
-
-@@ -50,13 +50,13 @@
- # of the available flags which follows these declarations.
- #
- #CCFLAGS = -DAUDIO_BLOCKING -DLINUX -DHALF_DUPLEX -DM_LITTLE_ENDIAN
--CCFLAGS = -DAUDIO_BLOCKING -DLINUX -DHALF_DUPLEX -DM_LITTLE_ENDIAN -DNEEDED_LINEAR -DLINUX_DSP_SMALL_BUFFER -DHAVE_DEV_RANDOM
--CC = gcc -Wall # for GNU's gcc compiler
-+#CCFLAGS = -DAUDIO_BLOCKING -DLINUX -DHALF_DUPLEX -DM_LITTLE_ENDIAN -DNEEDED_LINEAR -DLINUX_DSP_SMALL_BUFFER -DHAVE_DEV_RANDOM
-+#CC = gcc -Wall # for GNU's gcc compiler
- # CELPFLAGS below are tweaked for GCC 2.96 on Intel Pentium.
- # Comment out if you are using a compiler which doesn't
- # understand these options.
--CELPFLAGS = -fomit-frame-pointer -ffast-math -funroll-loops
--LFLAGS = -lncurses -lm
-+#CELPFLAGS = -fomit-frame-pointer -ffast-math -funroll-loops
-+#LFLAGS = -lncurses -lm
-
-
- # If you want to use ALSA instead of OSS, uncomment the following
-@@ -269,8 +269,8 @@
- # Depending on how your driver handles non-blocking I/O,
- # you may also have to add -DAUDIO_BLOCKING to the
- # CCFLAGS line.
--#CCFLAGS = -DM_LITTLE_ENDIAN
--#LFLAGS = -lcurses -ltermcap -lcompat -lm
-+CCFLAGS = -DM_LITTLE_ENDIAN -DAUDIO_BLOCKING -DNEEDED_LINEAR -DLINUX_DSP_SMALL_BUFFER
-+LFLAGS = -lcurses -ltermcap -lm
-
- # Hewlett-Packard
- # (courtesy of Marc Kilian)
-@@ -318,7 +318,7 @@
-
- # Compiler flags
-
--CFLAGS = $(DEBUG) $(PKOPTS) -Iadpcm -Iaes -Icelp -Ilpc -Igsm/inc -Ilpc10 -Imd5 -Ides -Iidea -Ilibdes -Iblowfish $(CARGS) $(DUPLEX) $(CCFLAGS) $(DOMAIN)
-+CFLAGS = $(OPTFLAGS) $(DEBUG) $(PKOPTS) -Iadpcm -Iaes -Icelp -Ilpc -I$(LOCALBASE)/include -Igsm/inc -Ilpc10 -Imd5 -Ides -Iidea -Ilibdes -Iblowfish $(CARGS) $(DUPLEX) $(CCFLAGS) $(DOMAIN)
-
- BINARIES = sfspeaker sfmike sflaunch sflwld sflwl sfecho sfreflect
-
-@@ -333,12 +333,12 @@
- SPKROBJS = speaker.o codecs.o deskey.o g711.o rate.o rtpacket.o soundbyte.o tempfile.o ulaw.o usleep.o vatpkt.o vox.o audio_hp.o audio_sgi.o audio_alsa.o common.o
-
- sfspeaker: $(SPKROBJS) adpcmlib.o aeslib.o celplib.o libblowfish.o lpclib.o lpc10lib.o gsmlib.o deslib.o md5lib.o idealib.o libdes.o xdsub.o
-- $(CC) $(SPKROBJS) adpcm/adpcm-u.o aes/aes.a blowfish/libblowfish.a celp/celp.o des/des.a md5/md5.o idea/idea.a lpc10/liblpc10.a gsm/lib/libgsm.a lpc/lpc.o xdsub.o libdes/libdes.a $(LFLAGS) $(SOUNDLIB) -o sfspeaker
-+ $(CC) $(SPKROBJS) adpcm/adpcm-u.o aes/aes.a blowfish/libblowfish.a celp/celp.o des/des.a -lmd idea/idea.a lpc10/liblpc10.a gsm/lib/libgsm.a lpc/lpc.o xdsub.o libdes/libdes.a $(LFLAGS) $(SOUNDLIB) -o sfspeaker
-
- MIKEOBJS = mike.o codecs.o deskey.o g711.o rate.o rtpacket.o soundbyte.o tempfile.o ulaw.o usleep.o vatpkt.o xdsub.o audio_hp.o audio_sgi.o audio_alsa.o
-
- sfmike: $(MIKEOBJS) adpcmlib.o aeslib.o celplib.o libblowfish.o lpclib.o lpc10lib.o gsmlib.o deslib.o md5lib.o idealib.o libdes.o
-- $(CC) $(MIKEOBJS) adpcm/adpcm-u.o aes/aes.a celp/celp.o des/des.a md5/md5.o idea/idea.a -lm blowfish/libblowfish.a lpc10/liblpc10.a gsm/lib/libgsm.a lpc/lpc.o libdes/libdes.a $(LFLAGS) $(SOUNDLIB) -o sfmike
-+ $(CC) $(MIKEOBJS) adpcm/adpcm-u.o aes/aes.a celp/celp.o des/des.a -lmd idea/idea.a -lm blowfish/libblowfish.a lpc10/liblpc10.a gsm/lib/libgsm.a lpc/lpc.o libdes/libdes.a $(LFLAGS) $(SOUNDLIB) -o sfmike
-
- LAUNCHOBJS = launch.o soundbyte.o usleep.o g711.o
-
-@@ -358,12 +358,12 @@
- ECHOOBJS = echo.o codecs.o g711.o rtpacket.o ulaw.o xdsub.o
-
- sfecho: $(ECHOOBJS) md5lib.o
-- $(CC) $(ECHOOBJS) md5/md5.o adpcm/adpcm-u.o lpc/lpc.o $(LFLAGS) -o sfecho
-+ $(CC) $(ECHOOBJS) -lmd adpcm/adpcm-u.o lpc/lpc.o $(LFLAGS) -o sfecho
-
- REFLECTOBJS = reflect.o codecs.o html.o g711.o rtpacket.o ulaw.o xdsub.o
-
- sfreflect: $(REFLECTOBJS) md5lib.o
-- $(CC) $(REFLECTOBJS) md5/md5.o adpcm/adpcm-u.o lpc/lpc.o $(LFLAGS) -o sfreflect
-+ $(CC) $(REFLECTOBJS) -lmd adpcm/adpcm-u.o lpc/lpc.o $(LFLAGS) -o sfreflect
-
- # Configure the voice on demand server for the platform's
- # location of Perl and network constant definitions.
-@@ -412,11 +412,11 @@
- echo "BLOWFISH" >libblowfish.o
-
- libdes.o:
-- ( echo "Building LIBDES library."; cd libdes ; make -f Makefile.sf CC="$(CC) $(CCFLAGS) $(DEBUG)" )
-+ ( echo "Building LIBDES library."; cd libdes ; make -f Makefile.sf CC="$(CC) $(OPTFLAGS) $(CCFLAGS) $(DEBUG)" )
- echo "LIBDES" >libdes.o
-
- lpclib.o:
-- ( echo "Building LPC library."; cd lpc ; make CC="$(CC) $(CCFLAGS) $(DEBUG)" )
-+ ( echo "Building LPC library."; cd lpc ; make CC="$(CC) $(OPTFLAGS) $(CCFLAGS) $(DEBUG)" )
- echo "LPC" >lpclib.o
-
- lpc10lib.o:
diff --git a/mbone/speak_freely/files/patch-ac b/mbone/speak_freely/files/patch-ac
deleted file mode 100644
index e9d8a5977a47..000000000000
--- a/mbone/speak_freely/files/patch-ac
+++ /dev/null
@@ -1,69 +0,0 @@
---- mike.c.orig Mon Aug 19 17:20:52 2002
-+++ mike.c Thu Dec 12 02:46:38 2002
-@@ -130,8 +130,8 @@
- #endif /* UNIX420 */
-
- #ifdef UNIX5
--#include <termio.h>
--static struct termio old_term_params;
-+#include <termios.h>
-+static struct termios old_term_params;
- #endif /* UNIX5 */
-
- /* Set raw mode on terminal file. Basically, get the terminal into a
-@@ -150,16 +150,16 @@
- #endif /* UNIX420 */
-
- #ifdef UNIX5
-- struct termio term_params;
-+ struct termios term_params;
-
-- ioctl(fileno(stdin), TCGETA, &old_term_params);
-+ tcgetattr(fileno(stdin), &old_term_params);
- term_params = old_term_params;
- term_params.c_iflag &= ~(ICRNL|IXON|IXOFF); /* no cr translation */
- term_params.c_iflag &= ~(ISTRIP); /* no stripping of high order bit */
- term_params.c_oflag &= ~(OPOST); /* no output processing */
- term_params.c_lflag &= ~(ISIG|ICANON|ECHO); /* raw mode */
- term_params.c_cc[4] = 1; /* satisfy read after 1 char */
-- ioctl(fileno(stdin), TCSETAF, &term_params);
-+ tcsetattr(fileno(stdin), TCSAFLUSH, &term_params);
- #endif /* UNIX5 */
- /*printf("\n(raw)\n");*/
- }
-@@ -178,7 +178,7 @@
- #endif /* UNIX420 */
-
- #ifdef UNIX5
-- ioctl(fileno(stdin), TCSETAF, &old_term_params);
-+ tcsetattr(fileno(stdin), TCSAFLUSH, &old_term_params);
- #endif /* UNIX5 */
- /*printf("\n(cooked)\n");*/
- }
-@@ -1135,7 +1135,7 @@
- /* SENDFILE -- Send a file or, if the file name is NULL or a
- single period, send real-time sound input. */
-
--static int sendfile(char *f)
-+static int sfsendfile(char *f)
- {
- soundbuf netbuf;
- #define buf netbuf.buffer.buffer_val
-@@ -2306,7 +2306,7 @@
- return 1;
- }
- } else {
-- int ok = sendfile(op);
-+ int ok = sfsendfile(op);
- if (ok != 0)
- return ok;
- sentfile++;
-@@ -2318,7 +2318,7 @@
- usage();
- } else {
- if (sentfile == 0) {
-- return sendfile(NULL);
-+ return sfsendfile(NULL);
- }
- }
-
diff --git a/mbone/speak_freely/files/patch-ad b/mbone/speak_freely/files/patch-ad
deleted file mode 100644
index b0ebafecdf39..000000000000
--- a/mbone/speak_freely/files/patch-ad
+++ /dev/null
@@ -1,11 +0,0 @@
---- adpcm/Makefile.orig Sat Oct 13 15:00:05 2001
-+++ adpcm/Makefile Thu Dec 12 02:47:59 2002
-@@ -2,7 +2,7 @@
- # Makefile for adpcm and test programs
- # -------------------
-
--CFLAGS = -I..
-+CFLAGS += -I..
-
- all: adpcm-u.o
-
diff --git a/mbone/speak_freely/files/patch-ae b/mbone/speak_freely/files/patch-ae
deleted file mode 100644
index 6a3b0db9c2e1..000000000000
--- a/mbone/speak_freely/files/patch-ae
+++ /dev/null
@@ -1,24 +0,0 @@
-
-$FreeBSD$
-
---- soundbyte.c.orig Fri Feb 28 23:18:38 2003
-+++ soundbyte.c Wed Jun 25 19:42:45 2003
-@@ -13,7 +13,9 @@
- #ifdef Solaris
- #include <sys/filio.h>
- #else
-+#ifndef __FreeBSD__
- #include <sys/dir.h>
-+#endif
- #include <sys/file.h>
- #endif
-
-@@ -32,7 +34,7 @@
- #ifdef LINUX
- #include <linux/soundcard.h>
- #else /*!LINUX */
--#include <machine/soundcard.h>
-+#include <sys/soundcard.h>
- #endif /* LINUX */
- #endif /* sun */
-
diff --git a/mbone/speak_freely/files/patch-af b/mbone/speak_freely/files/patch-af
deleted file mode 100644
index 8f99c43f7cd2..000000000000
--- a/mbone/speak_freely/files/patch-af
+++ /dev/null
@@ -1,11 +0,0 @@
---- blowfish/Makefile.orig Wed Jan 5 20:12:14 2000
-+++ blowfish/Makefile Wed Jan 5 20:15:02 2000
-@@ -18,7 +18,7 @@
-
- MAKE=make -f Makefile
- CC=cc
--CFLAG= -O
-+CFLAG= $(OPTFLAGS)
-
- #CC=gcc
- #CFLAG= -O4 -funroll-loops -fomit-frame-pointer
diff --git a/mbone/speak_freely/files/patch-ag b/mbone/speak_freely/files/patch-ag
deleted file mode 100644
index 8de3e742784f..000000000000
--- a/mbone/speak_freely/files/patch-ag
+++ /dev/null
@@ -1,8 +0,0 @@
---- des/Makefile.orig Wed Jan 5 20:20:30 2000
-+++ des/Makefile Wed Jan 5 20:20:44 2000
-@@ -1,4 +1,4 @@
--CFLAGS=-O
-+CFLAGS=$(OPTFLAGS)
-
- all: des.a
-
diff --git a/mbone/speak_freely/files/patch-ah b/mbone/speak_freely/files/patch-ah
deleted file mode 100644
index 0986b11e721d..000000000000
--- a/mbone/speak_freely/files/patch-ah
+++ /dev/null
@@ -1,11 +0,0 @@
---- lpc10/Makefile.orig Wed Jun 9 04:07:02 2004
-+++ lpc10/Makefile Wed Jun 9 04:07:16 2004
-@@ -14,6 +14,8 @@
- placev.o preemp.o random.o round.o rcchk.o setup.o synths.o \
- tbdm.o voice.o voice_nn.o vparms.o
-
-+CFLAGS += -D_ANSI_SOURCE
-+
- LSRC = $(LOBJECTS:.o=.c)
-
- LIBS = -lm
diff --git a/mbone/speak_freely/files/patch-speakfree.h b/mbone/speak_freely/files/patch-speakfree.h
deleted file mode 100644
index 8642a62620fa..000000000000
--- a/mbone/speak_freely/files/patch-speakfree.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- speakfree.h
-+++ speakfree.h
-@@ -13,10 +13,6 @@
- #define BSD_like
- #endif
-
--#ifdef __FreeBSD__
--#define BSD_like
--#endif
--
- #ifdef sgi
- #define _BSD_SIGNALS
- #endif