aboutsummaryrefslogtreecommitdiff
path: root/mbone/wb
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-08-31 00:44:39 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-08-31 00:44:39 +0000
commit656a9479b91ae8dc1a5be278722b438ccda22d57 (patch)
tree726b998d9f6144d640e16cc7ee2358fa8d623c44 /mbone/wb
parente0db397055e1ba617a675251e651472c5ed87226 (diff)
downloadports-656a9479b91ae8dc1a5be278722b438ccda22d57.tar.gz
ports-656a9479b91ae8dc1a5be278722b438ccda22d57.zip
Notes
Diffstat (limited to 'mbone/wb')
-rw-r--r--mbone/wb/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/mbone/wb/Makefile b/mbone/wb/Makefile
index ed7e8f45cd98..3e981484efba 100644
--- a/mbone/wb/Makefile
+++ b/mbone/wb/Makefile
@@ -19,7 +19,13 @@ NO_BUILD= yes
USE_X_PREFIX= yes
# XXX ghostscript, ghostscript3, ghostscript4 or ghostscript5 will all do.
-RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript-gnu
+.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
+GSPORT?= print/ghostscript-afpl
+.else
+GSPORT?= print/ghostscript-gnu
+.endif
+
+RUN_DEPENDS= gs:${PORTSDIR}/${GSPORT}
.include <bsd.port.pre.mk>
@@ -27,6 +33,14 @@ RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript-gnu
STRIP=
.endif
+pre-fetch:
+.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
+ @${ECHO} ""
+ @${ECHO} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
+ @${ECHO} " AFPL Postscript interpreter instead of GNU one"
+ @${ECHO} ""
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/wb ${PREFIX}/bin
.if !defined(NOPORTDOCS)