aboutsummaryrefslogtreecommitdiff
path: root/mbone
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2005-03-20 23:13:45 +0000
committerMikhail Teterin <mi@FreeBSD.org>2005-03-20 23:13:45 +0000
commit7cd341218d611966bc3af58ebea46a62b5179f15 (patch)
tree4de994b9b476b7052a879f571e7c49ca6587bd88 /mbone
parentddb6aff37533e3d269b6d3eb175d40c372c1b6ed (diff)
downloadports-7cd341218d611966bc3af58ebea46a62b5179f15.tar.gz
ports-7cd341218d611966bc3af58ebea46a62b5179f15.zip
Notes
Diffstat (limited to 'mbone')
-rw-r--r--mbone/vic/Makefile30
-rw-r--r--mbone/vic/distinfo3
-rw-r--r--mbone/vic/files/patch-Makefile.in37
-rw-r--r--mbone/vic/files/patch-Tcl.cpp13
-rw-r--r--mbone/vic/files/patch-config25
-rw-r--r--mbone/vic/files/patch-configure.in.tk20
-rw-r--r--mbone/vic/files/patch-const60
-rw-r--r--mbone/vic/files/patch-encoder-jpeg.cpp16
-rw-r--r--mbone/vic/files/patch-inet6.c14
-rw-r--r--mbone/vic/files/patch-mbus_handler9
-rw-r--r--mbone/vic/files/patch-net-ipv6.cpp37
-rw-r--r--mbone/vic/files/patch-nomalloc_h8
-rw-r--r--mbone/vic/files/patch-renderer-window14
-rw-r--r--mbone/vic/pkg-descr2
14 files changed, 188 insertions, 100 deletions
diff --git a/mbone/vic/Makefile b/mbone/vic/Makefile
index a8219c25b40f..c5b190c504f6 100644
--- a/mbone/vic/Makefile
+++ b/mbone/vic/Makefile
@@ -6,22 +6,18 @@
#
PORTNAME= vic
-PORTVERSION= 2.8.1.1.3
-PORTREVISION= 1
-CATEGORIES= mbone tk83 ipv6
-MASTER_SITES= http://www-mice.cs.ucl.ac.uk/multimedia/software/vic/2.8ucl-1.1.3/
-DISTNAME= ${PORTNAME}-2.8ucl-1.1.3
+PORTVERSION= 2.8.1.1.6
+CATEGORIES= mbone tk84 ipv6
+MASTER_SITES= http://www-mice.cs.ucl.ac.uk/multimedia/software/vic/2.8ucl1.1.6/
+DISTNAME= ${PORTNAME}-2.8ucl1.1.6
-MAINTAINER= fenner@FreeBSD.org
+MAINTAINER= mi@aldan.algebra.com
COMMENT= MBONE video tool
-LIB_DEPENDS= tk83.1:${PORTSDIR}/x11-toolkits/tk83
-BUILD_DEPENDS= ${LOCALBASE}/lib/libuclmmbase.a:${PORTSDIR}/devel/uclmmbase
-
-WRKSRC= ${WRKDIR}/vic-2.8ucl-1.1.3/vic
+LIB_DEPENDS= tk84.1:${PORTSDIR}/x11-toolkits/tk84 \
+ uclmmbase:${PORTSDIR}/devel/uclmmbase
USE_AUTOCONF_VER= 213
-USE_PERL5_BUILD=yes
USE_X_PREFIX= yes
CONFIGURE_ARGS= -x-libraries=${PREFIX}/lib \
-x-includes=${PREFIX}/include \
@@ -32,18 +28,8 @@ CONFIGURE_ARGS= -x-libraries=${PREFIX}/lib \
-enable-ipv6
MAN1= vic.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
-pre-patch:
- @${FIND} ${WRKSRC} -name "*.[c,h]" | ${XARGS} ${PERL} -pi -e \
- 's|malloc.h|stdlib.h|'
-
post-install:
${STRIP_CMD} ${PREFIX}/bin/vic
${STRIP_CMD} ${PREFIX}/bin/histtolut
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mbone/vic/distinfo b/mbone/vic/distinfo
index b9faf5a35270..c8e64b1e5c2b 100644
--- a/mbone/vic/distinfo
+++ b/mbone/vic/distinfo
@@ -1 +1,2 @@
-MD5 (vic-2.8ucl-1.1.3.tar.gz) = 55e792aa8f370fc15a197bb1b910a704
+MD5 (vic-2.8ucl1.1.6.tar.gz) = f2330ad98655ad43d489a023847645c0
+SIZE (vic-2.8ucl1.1.6.tar.gz) = 1119176
diff --git a/mbone/vic/files/patch-Makefile.in b/mbone/vic/files/patch-Makefile.in
index 24d9a710cec8..7bd7723d3ee0 100644
--- a/mbone/vic/files/patch-Makefile.in
+++ b/mbone/vic/files/patch-Makefile.in
@@ -1,15 +1,30 @@
---- Makefile.in.orig Thu Feb 17 21:59:08 2000
-+++ Makefile.in Tue May 8 09:06:28 2001
-@@ -85,7 +85,7 @@
+--- Makefile.in Wed Apr 30 07:50:17 2003
++++ Makefile.in Thu Sep 23 18:42:54 2004
+@@ -58,7 +58,7 @@
+ INCLUDE_TK = @V_INCLUDE_TK@
+ INCLUDE_TCL = @V_INCLUDE_TCL@
+ INCLUDE_X11 = @V_INCLUDE_X11@
+-INCLUDE_MISC = @V_INCLUDE@ -I. -Icodec/tmndec -Icodec/tmn-x -Icodec/h263 -Irtp -Irender -Inet -Ivideo -Icodec -I../common/src
++INCLUDE_MISC = @V_INCLUDE@ -I. -Icodec/tmndec -Icodec/tmn-x -Icodec/h263 -Irtp -Irender -Inet -Ivideo -Icodec -I@prefix@/include/uclmmbase
+
+ STATIC = @V_STATIC@
+ MKDEP = ./mkdep
+@@ -89,12 +89,12 @@
OBJ_XIL = @V_OBJ_XIL@
OBJ_CRYPT = @V_OBJ_CRYPT@
LIB = $(LIB_GRABBER) @V_LIB_TK@ @V_LIB_TCL@ @V_LIB_X11@ @V_LIB@ \
-- codec/tmndec/libh263.a codec/tmn-x/libh263coder.a ../common/libuclmmbase.a -lm
-+ codec/tmndec/libh263.a codec/tmn-x/libh263coder.a /usr/local/lib/libuclmmbase.a -lm
+- codec/tmndec/libh263.a codec/tmn-x/libh263coder.a ../common/src/libuclmmbase.a -lm
++ codec/tmndec/libh263.a codec/tmn-x/libh263coder.a -L@prefix@/lib -luclmmbase -lm
INCLUDE = $(INCLUDE_MISC) $(INCLUDE_GRABBER) $(INCLUDE_TK) $(INCLUDE_TCL) \
$(INCLUDE_X11) $(MD_INC) -Icodec/jpeg -Icodec/p64 -I.
DEFINE = @V_DEFINE@ -DED_YBITS=$(ED_YBITS) -DSIGRET=@V_SIGRET@ -DNLAYER=8
-@@ -329,7 +329,7 @@
+ BFLAGS = $(DEFINE) $(INCLUDE)
+-CFLAGS = $(CCOPT) $(BFLAGS)
++CFLAGS += $(BFLAGS)
+
+ #
+ # Remember to add a dependency if you add any tcl sources here.
+@@ -333,7 +333,7 @@
chown bin @prefix@/bin/vic
chgrp bin @prefix@/bin/vic
chmod 555 @prefix@/bin/vic
@@ -18,3 +33,13 @@
cp histtolut @prefix@/bin/histtolut
chown bin @prefix@/bin/histtolut
chgrp bin @prefix@/bin/histtolut
+@@ -410,7 +410,7 @@
+
+
+ codec/tmn-x/libh263coder.a:
+- (cd codec/tmn-x; $(MAKE) CC=$(CC) CCOPT="$(CCOPT)" )
++ (cd codec/tmn-x; $(MAKE) CC=$(CC) CCOPT="$(CFLAGS)" )
+
+ codec/tmndec/libh263.a:
+- (cd codec/tmndec; $(MAKE) CC=$(CC) CCOPT="$(CCOPT)" -f Makefile.lib)
++ (cd codec/tmndec; $(MAKE) CC=$(CC) CCOPT="$(CFLAGS)" -f Makefile.lib)
diff --git a/mbone/vic/files/patch-Tcl.cpp b/mbone/vic/files/patch-Tcl.cpp
index 881919b5448f..cf26626a5499 100644
--- a/mbone/vic/files/patch-Tcl.cpp
+++ b/mbone/vic/files/patch-Tcl.cpp
@@ -1,5 +1,5 @@
---- Tcl.cpp.org Mon May 7 15:55:17 2001
-+++ Tcl.cpp Mon May 7 15:55:34 2001
+--- Tcl.cpp Thu Sep 9 08:21:53 1999
++++ Tcl.cpp Thu Sep 23 18:59:59 2004
@@ -66,6 +66,7 @@
{
instance_.tcl_ = tcl;
@@ -8,3 +8,12 @@
}
void Tcl::evalc(const char* s)
+@@ -214,7 +215,7 @@
+ }
+ }
+
+-int TclObject::callback(ClientData cd, Tcl_Interp*, int ac, char** av)
++int TclObject::callback(ClientData cd, Tcl_Interp*, int ac, const char** av)
+ {
+ TclObject* tc = (TclObject*)cd;
+ return (tc->command(ac, (const char*const*)av));
diff --git a/mbone/vic/files/patch-config b/mbone/vic/files/patch-config
new file mode 100644
index 000000000000..dd572f7a85c8
--- /dev/null
+++ b/mbone/vic/files/patch-config
@@ -0,0 +1,25 @@
+--- config.h Thu Apr 10 13:57:28 2003
++++ config.h Thu Sep 23 18:37:11 2004
+@@ -38,11 +38,6 @@
+
+ #if defined(sgi) || defined(__bsdi__) || defined(__FreeBSD__)
+ #include <sys/types.h>
+-#ifndef uint16_t
+-typedef unsigned char uint8_t;
+-typedef unsigned short uint16_t;
+-typedef unsigned int uint32_t;
+-#endif
+ #elif defined(sun)
+
+ #include <sys/types.h>
+@@ -91,10 +86,6 @@
+ #include "debug.h"
+ #include <stdlib.h>
+ #include <time.h> /* For clock_t */
+-
+-#ifdef HAVE_MALLOC_H
+-#include <malloc.h>
+-#endif /* HAVE_MALLOC_H */
+
+ #if defined(NEED_SUNOS_PROTOS)
+ #if defined(__cplusplus)
diff --git a/mbone/vic/files/patch-configure.in.tk b/mbone/vic/files/patch-configure.in.tk
index aee5d9ad4021..d4fdc8a8a3da 100644
--- a/mbone/vic/files/patch-configure.in.tk
+++ b/mbone/vic/files/patch-configure.in.tk
@@ -6,15 +6,15 @@
fi
- V_INCLUDE_TCL=-I$d/include
- if test ! -r $d/include/tcl.h ; then
-+ V_INCLUDE_TCL=-I$d/include/tcl8.3/
-+ if test ! -r $d/include/tcl8.3/tcl.h ; then
++ V_INCLUDE_TCL=-I$d/include/tcl8.4/
++ if test ! -r $d/include/tcl8.4/tcl.h ; then
echo "can't find tcl.h in $d/include"
exit 1
fi
- places="$d/lib/libtcl8.0.so \
- $d/lib/libtcl8.0.a \
-+ places="$d/lib/libtcl83.so \
-+ $d/lib/libtcl83.a \
++ places="$d/lib/libtcl84.so \
++ $d/lib/libtcl84.a \
$d/lib/libtcl.so \
$d/lib/libtcl.a"
V_LIB_TCL=FAIL
@@ -23,7 +23,7 @@
exit 1
fi
- places="$d/lib/tcl-8.0 \
-+ places="$d/lib/tcl8.3 \
++ places="$d/lib/tcl8.4 \
$d/lib/tcl8.0 \
$d/lib/tcl"
V_LIBRARY_TCL=FAIL
@@ -33,15 +33,15 @@
fi
- V_INCLUDE_TK=-I$d/include
- if test ! -r $d/include/tk.h ; then
-+ V_INCLUDE_TK=-I$d/include/tk8.3
-+ if test ! -r $d/include/tk8.3/tk.h ; then
++ V_INCLUDE_TK=-I$d/include/tk8.4
++ if test ! -r $d/include/tk8.4/tk.h ; then
echo "can't find tk.h in $d/include"
exit 1
fi
- places="$d/lib/libtk8.0.so \
- $d/lib/libtk8.0.a \
-+ places="$d/lib/libtk83.so \
-+ $d/lib/libtk83.a \
++ places="$d/lib/libtk84.so \
++ $d/lib/libtk84.a \
$d/lib/libtk.so \
$d/lib/libtk.a"
V_LIB_TK=FAIL
@@ -50,7 +50,7 @@
exit 1
fi
- places="$d/lib/tk8.0 \
-+ places="$d/lib/tk8.3 \
++ places="$d/lib/tk8.4 \
$d/lib/tk"
V_LIBRARY_TK=FAIL
for dir in $places; do
diff --git a/mbone/vic/files/patch-const b/mbone/vic/files/patch-const
new file mode 100644
index 000000000000..328bfda065af
--- /dev/null
+++ b/mbone/vic/files/patch-const
@@ -0,0 +1,60 @@
+--- tkStripchart.c Mon Jun 29 15:17:00 1998
++++ tkStripchart.c Thu Sep 23 18:50:39 2004
+@@ -364,5 +364,5 @@
+ int
+ Tk_StripchartCmd(ClientData clientData, Tcl_Interp *interp, int argc,
+- char **argv)
++ CONST char **argv)
+ {
+ Tk_Window tkwin = (Tk_Window) clientData;
+--- main.cpp Tue Feb 25 12:55:08 2003
++++ main.cpp Thu Sep 23 18:51:59 2004
+@@ -407,5 +407,5 @@
+ }
+
+-extern "C" int Tk_StripchartCmd(ClientData, Tcl_Interp*, int ac, char** av);
++extern "C" int Tk_StripchartCmd(ClientData, Tcl_Interp*, int ac, const char** av);
+ #ifdef WIN32
+ extern "C" int WinPutsCmd(ClientData, Tcl_Interp*, int ac, char** av);
+--- vic_tcl.h Thu Sep 9 08:05:49 1999
++++ vic_tcl.h Thu Sep 23 19:00:33 2004
+@@ -74,6 +77,6 @@
+ error(file);
+ }
+- inline char* var(const char* varname, int flags = TCL_GLOBAL_ONLY) {
+- return (Tcl_GetVar(tcl_, (char*)varname, flags));
++ inline CONST char* var(const char* varname, int flags = TCL_GLOBAL_ONLY) {
++ return (Tcl_GetVar(tcl_, varname, flags));
+ }
+ /*
+@@ -125,5 +128,5 @@
+ void class_name(const char*);
+ /* make this public for Sun's compiler */
+- static int callback(ClientData, Tcl_Interp*, int ac, char** av);
++ static int callback(ClientData, Tcl_Interp*, int ac, CONST char** av);
+ static void reset_all();
+ protected:
+--- rate-variable.cpp Thu Sep 9 08:21:55 1999
++++ rate-variable.cpp Thu Sep 23 18:55:10 2004
+@@ -62,11 +62,11 @@
+ RateVariable(const char* name) : TclObject(name) { }
+ protected:
+- static char* update_rate_var(ClientData, Tcl_Interp*, char* name1,
+- char* name2, int flags);
++ static char* update_rate_var(ClientData, Tcl_Interp*, const char* name1,
++ const char* name2, int flags);
+ int command(int argc, const char*const* argv);
+ } rate_variable_cmd("rate_variable");
+
+ char* RateVariable::update_rate_var(ClientData clientData, Tcl_Interp* tcl,
+- char* name1, char* name2, int flags)
++ const char* name1, const char* name2, int flags)
+ {
+ rv_data* rv = (rv_data*)clientData;
+@@ -81,5 +81,5 @@
+ char res[128];
+ flags &= TCL_GLOBAL_ONLY;
+- char* cv = Tcl_GetVar2(tcl, name1, name2, flags);
++ const char* cv = Tcl_GetVar2(tcl, name1, name2, flags);
+ if (cv == NULL)
+ return (tcl->result);
diff --git a/mbone/vic/files/patch-encoder-jpeg.cpp b/mbone/vic/files/patch-encoder-jpeg.cpp
deleted file mode 100644
index 7a8fed0d8b42..000000000000
--- a/mbone/vic/files/patch-encoder-jpeg.cpp
+++ /dev/null
@@ -1,16 +0,0 @@
---- codec/encoder-jpeg.cpp.orig Thu Jan 23 18:22:29 2003
-+++ codec/encoder-jpeg.cpp Thu Jan 23 18:22:37 2003
-@@ -127,12 +127,12 @@
- void size(int w, int h);
- int consume(const VideoFrame*);
-
-- protected:
- struct huffentry {
- u_short val;
- u_short nb;
- };
-
-+ protected:
- int command(int argc, const char*const* argv);
-
- int flush(pktbuf* pb, int nbit, pktbuf* npb);
diff --git a/mbone/vic/files/patch-inet6.c b/mbone/vic/files/patch-inet6.c
deleted file mode 100644
index 3d1ba594a6f2..000000000000
--- a/mbone/vic/files/patch-inet6.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- net/inet6.c.org Mon Feb 4 17:51:32 2002
-+++ net/inet6.c Mon Feb 4 17:52:02 2002
-@@ -64,11 +64,7 @@
- memcpy(addr->s6_addr, &(((struct sockaddr_in6 *)(ai->ai_addr))->sin6_addr), sizeof(struct in6_addr));
- return (0);
- #else
--#ifdef MUSICA_IPV6
- hp = gethostbyname2(hostname, AF_INET6);
--#else
-- hp = getnodebyname(hostname, AF_INET6,AI_DEFAULT);
--#endif /*MUSICA_IPV6*/
- #endif /*LINUX_IPV6*/
- #endif /*SOLARIS7_IPV6*/
- if (hp == 0) return (-1);
diff --git a/mbone/vic/files/patch-mbus_handler b/mbone/vic/files/patch-mbus_handler
new file mode 100644
index 000000000000..8237fee3b279
--- /dev/null
+++ b/mbone/vic/files/patch-mbus_handler
@@ -0,0 +1,9 @@
+--- net/mbus_handler.h Thu Mar 16 08:21:37 2000
++++ net/mbus_handler.h Thu Sep 23 21:31:33 2004
+@@ -50,6 +50,4 @@
+ #include "memory.h"
+ #include "mbus.h"
+-#include "mbus_config.h"
+-
+
+ #ifdef WIN32
diff --git a/mbone/vic/files/patch-net-ipv6.cpp b/mbone/vic/files/patch-net-ipv6.cpp
index 26397cdde8ff..4e8812eff9ff 100644
--- a/mbone/vic/files/patch-net-ipv6.cpp
+++ b/mbone/vic/files/patch-net-ipv6.cpp
@@ -1,29 +1,10 @@
---- net/net-ipv6.cpp.org Mon Feb 4 17:51:46 2002
-+++ net/net-ipv6.cpp Mon Feb 4 17:52:08 2002
-@@ -277,7 +277,7 @@
- p->sin6_family = AF_INET6;
- int len = sizeof(*p), result = 0;
+--- net/net-ipv6.cpp Thu Apr 24 10:53:26 2003
++++ net/net-ipv6.cpp Thu Sep 23 19:08:53 2004
+@@ -59,7 +59,6 @@
+ #include "config.h"
+ #include "net.h"
+ #include "vic_tcl.h"
+-#include "inet_ntop.h"
-- if ((result = getsockname(ssock_, (struct sockaddr *)p, &len)) < 0) {
-+ if ((result = getsockname(ssock_, (struct sockaddr *)p, (socklen_t *)&len)) < 0) {
- perror("getsockname");
- p->sin6_addr = in6addr_any;
- p->sin6_port = 0;
-@@ -364,7 +364,7 @@
- * with bated breath.
- */
- #if defined(__FreeBSD__)
-- struct oipv6_mreq mr;
-+ struct ipv6_mreq mr;
- #else
- struct ipv6_mreq mr;
- #endif
-@@ -522,7 +522,7 @@
- sockaddr_in6 sfrom;
- int fromlen = sizeof(sfrom);
- int cc = ::recvfrom(fd, (char*)buf, len, 0,
-- (sockaddr*)&sfrom, &fromlen);
-+ (sockaddr*)&sfrom, (socklen_t *)&fromlen);
- if (cc < 0) {
- if (errno != EWOULDBLOCK)
- perror("recvfrom");
+ #include "inet6.h"
+ #include "net-addr.h"
diff --git a/mbone/vic/files/patch-nomalloc_h b/mbone/vic/files/patch-nomalloc_h
new file mode 100644
index 000000000000..0d7613d84587
--- /dev/null
+++ b/mbone/vic/files/patch-nomalloc_h
@@ -0,0 +1,8 @@
+--- codec/h263/Util.h Thu Sep 9 08:45:56 1999
++++ codec/h263/Util.h Thu Sep 23 18:31:34 2004
+@@ -7,5 +7,4 @@
+ #define _UTIL_
+
+-#include <malloc.h>
+ #include "error.h"
+ #include <stdlib.h>
diff --git a/mbone/vic/files/patch-renderer-window b/mbone/vic/files/patch-renderer-window
new file mode 100644
index 000000000000..8e940d34f0b4
--- /dev/null
+++ b/mbone/vic/files/patch-renderer-window
@@ -0,0 +1,14 @@
+--- render/renderer-window.h Thu Sep 9 08:38:16 1999
++++ render/renderer-window.h Thu Sep 23 21:43:13 2004
+@@ -54,10 +54,10 @@
+ int minx, int maxx) const;
+ void sync() const;
+ void resize(int w, int h);
+- protected:
+ /*XXX*/
+ void dither_null(const u_char* frm, u_int off, u_int x,
+ u_int width, u_int height) const;
++ protected:
+ virtual void setcolor(int c);
+ void compute_scale(int w, int h);
+ virtual void alloc_image() = 0;
diff --git a/mbone/vic/pkg-descr b/mbone/vic/pkg-descr
index 457adff21faf..720c00f6188e 100644
--- a/mbone/vic/pkg-descr
+++ b/mbone/vic/pkg-descr
@@ -1,4 +1,4 @@
This package contains the binary release of LBL's `vic' network video
conferencing tool.
-NOTE: This kit requires XFree86 3.1, Tk, and Tcl shared libraries.
+WWW: http://www-mice.cs.ucl.ac.uk/multimedia/software/vic/