aboutsummaryrefslogtreecommitdiff
path: root/misc/34upgrade
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>2000-01-06 06:57:50 +0000
committerSatoshi Asami <asami@FreeBSD.org>2000-01-06 06:57:50 +0000
commitfb5af37acdd27e1431c50d9e1903019175e4a99e (patch)
tree0cd6dfbdc8fc014e83ac30ce617dd58d322455fe /misc/34upgrade
parent977a0a5eaa0369303d495a9f6d24627a3e2b51ef (diff)
downloadports-fb5af37acdd27e1431c50d9e1903019175e4a99e.tar.gz
ports-fb5af37acdd27e1431c50d9e1903019175e4a99e.zip
Notes
Diffstat (limited to 'misc/34upgrade')
-rw-r--r--misc/34upgrade/Makefile35
-rw-r--r--misc/34upgrade/pkg-comment1
-rw-r--r--misc/34upgrade/pkg-descr5
-rw-r--r--misc/34upgrade/pkg-install5
-rw-r--r--misc/34upgrade/pkg-plist1
-rw-r--r--misc/34upgrade/pkg-req5
6 files changed, 52 insertions, 0 deletions
diff --git a/misc/34upgrade/Makefile b/misc/34upgrade/Makefile
new file mode 100644
index 000000000000..c7fc76f338fa
--- /dev/null
+++ b/misc/34upgrade/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: 3.3/3.4R to 3-stable upgrade kit
+# Version required: n/a
+# Date created: 5 Jan 2000
+# Whom: asami
+#
+# $FreeBSD$
+#
+
+DISTNAME= 34upgrade-2000.01.05
+CATEGORIES= misc
+DISTFILES= # empty
+
+MAINTAINER= asami@FreeBSD.org
+
+.include <bsd.port.pre.mk>
+
+.if !defined(PACKAGE_BUILDING)
+BROKEN= this \"port\" is for building packages for distribution only, please get the package from http://www.freebsd.org/ports/ if you need an upgrade
+.elif ${OSVERSION} < 340000
+FORBIDDEN= this needs to be built on a recent 3-stable system
+.endif
+NO_MTREE= yes
+PREFIX= /
+NO_BUILD= yes
+PKGINSTALL= ${WRKDIR}/INSTALL
+
+do-install:
+ ${SED} -e "s/%%VERSION%%/${BSDPORTMKVERSION}/" ${PKGDIR}/INSTALL \
+ > ${PKGINSTALL}
+
+deinstall:
+ @${ECHO} "You can't delete this port."
+ @${FALSE}
+
+.include <bsd.port.post.mk>
diff --git a/misc/34upgrade/pkg-comment b/misc/34upgrade/pkg-comment
new file mode 100644
index 000000000000..86b177cfd09d
--- /dev/null
+++ b/misc/34upgrade/pkg-comment
@@ -0,0 +1 @@
+A convenience package to upgrade your 3.3 or 3.4 system to 3-stable for ports
diff --git a/misc/34upgrade/pkg-descr b/misc/34upgrade/pkg-descr
new file mode 100644
index 000000000000..d71e734d187a
--- /dev/null
+++ b/misc/34upgrade/pkg-descr
@@ -0,0 +1,5 @@
+This package will allow you to upgrade your 3.3R or 3.4R system to
+3-stable, so you can compile and use all ports in ports-current.
+
+Satoshi
+asami@freebsd.org
diff --git a/misc/34upgrade/pkg-install b/misc/34upgrade/pkg-install
new file mode 100644
index 000000000000..8ed8de67d62f
--- /dev/null
+++ b/misc/34upgrade/pkg-install
@@ -0,0 +1,5 @@
+#!/bin/sh
+if [ "$2" != "PRE-INSTALL" ]; then
+ exit 0
+fi
+echo %%VERSION%% > /var/db/port.mkversion
diff --git a/misc/34upgrade/pkg-plist b/misc/34upgrade/pkg-plist
new file mode 100644
index 000000000000..cec34aba3f94
--- /dev/null
+++ b/misc/34upgrade/pkg-plist
@@ -0,0 +1 @@
+usr/lib/libc_r.so.4
diff --git a/misc/34upgrade/pkg-req b/misc/34upgrade/pkg-req
new file mode 100644
index 000000000000..1eb81c651314
--- /dev/null
+++ b/misc/34upgrade/pkg-req
@@ -0,0 +1,5 @@
+#!/bin/sh
+if [ $2 = "DEINSTALL" ]; then
+ echo "Package $1 cannot be removed -- to do so will render your system useless."
+ exit 1
+fi