aboutsummaryrefslogtreecommitdiff
path: root/misc/alevt
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2008-04-30 12:39:14 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2008-04-30 12:39:14 +0000
commitf9082c0cebf031d387dd57afe65693409d09fa1e (patch)
tree7831ed9780e08aa3f9fd0335463893ba5d3dbda6 /misc/alevt
parent9ab92517285712a784f151d870e2bcc865a55582 (diff)
downloadports-f9082c0cebf031d387dd57afe65693409d09fa1e.tar.gz
ports-f9082c0cebf031d387dd57afe65693409d09fa1e.zip
Notes
Diffstat (limited to 'misc/alevt')
-rw-r--r--misc/alevt/Makefile3
-rw-r--r--misc/alevt/distinfo6
-rw-r--r--misc/alevt/files/patch-aa26
-rw-r--r--misc/alevt/files/patch-xio.c28
4 files changed, 24 insertions, 39 deletions
diff --git a/misc/alevt/Makefile b/misc/alevt/Makefile
index 9024a70ed830..3d3a6eb461a2 100644
--- a/misc/alevt/Makefile
+++ b/misc/alevt/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= alevt
-PORTVERSION= 1.6.1
-PORTREVISION= 3
+PORTVERSION= 1.6.2
CATEGORIES= misc
MASTER_SITES= http://www.goron.de/~froese/alevt/
diff --git a/misc/alevt/distinfo b/misc/alevt/distinfo
index 44ff8f9333cb..44a30bd99dcf 100644
--- a/misc/alevt/distinfo
+++ b/misc/alevt/distinfo
@@ -1,3 +1,3 @@
-MD5 (alevt-1.6.1.tar.gz) = df6e241c6e2c6505c95d50cde0e1bc73
-SHA256 (alevt-1.6.1.tar.gz) = 38a3cf23afd48970ee2bc0c63d2152614082cefc7b5ab346c5f4cda22ea707b7
-SIZE (alevt-1.6.1.tar.gz) = 117731
+MD5 (alevt-1.6.2.tar.gz) = e5a32776e7eff48ec48449b3c3c1cc23
+SHA256 (alevt-1.6.2.tar.gz) = 9347c2af4b528edec87df8a424ddccebcc252ca7a06f6b18310733cfa547e5f5
+SIZE (alevt-1.6.2.tar.gz) = 133234
diff --git a/misc/alevt/files/patch-aa b/misc/alevt/files/patch-aa
index 90d529d266c1..23bdb58d8a27 100644
--- a/misc/alevt/files/patch-aa
+++ b/misc/alevt/files/patch-aa
@@ -1,8 +1,8 @@
---- Makefile.orig Tue Aug 20 05:17:53 2002
-+++ Makefile Wed May 25 13:55:10 2005
-@@ -1,33 +1,35 @@
- VER=1.6.1
--OPT=-O2 -s
+--- Makefile.orig 2007-12-03 05:19:54.000000000 +0000
++++ Makefile 2008-04-30 12:36:24.000000000 +0000
+@@ -1,37 +1,40 @@
+ VER=1.6.2
+-OPT=-O2 -s -w
-#OPT=-O -g
+
+.if defined(WITH_PNG)
@@ -14,11 +14,18 @@
+FONT=neep9
+.else
FONT=vtxt
+-USR_X11R6=/usr/X11R6
++.endif
++
++USR_X11R6=/usr/local
+ #USR_X11R6=/usr
+ MAN_DIR=man
+ #MAN_DIR=share/man
+ HOSTCC=$(CC)
-# a smaller and thinner font
-#FONT=neep9
-+.endif
--CFLAGS=$(OPT) -DVERSION=\"$(VER)\" $(DEFS) -I/usr/X11R6/include -I/usr/local/include -W
+-CFLAGS=$(OPT) -DVERSION=\"$(VER)\" $(DEFS) -I$(USR_X11R6)/include
+CFLAGS+=-DVERSION=\"$(VER)\" $(DEFS) -I${LOCALBASE}/include -W
+X11_LIBS=-L${LOCALBASE}/lib -lX11
@@ -28,14 +35,13 @@
COBJS=alevt-cap.o vbi.o fdset.o misc.o hamm.o lang.o $(EXPOBJS)
-ifneq ($(findstring WITH_PNG,$(DEFS)),)
--EXPLIBS=-L/usr/local/lib -lpng -lz -lm
+-EXPLIBS=-lpng -lz -lm
-endif
-
all: alevt alevt-date alevt-cap alevt.1x alevt-date.1 alevt-cap.1
- sync
alevt: $(OBJS)
-- $(CC) $(OPT) $(OBJS) -o alevt -L/usr/X11R6/lib -lX11 $(EXPLIBS)
+- $(CC) $(OPT) $(OBJS) -o alevt -L$(USR_X11R6)/lib -L$(USR_X11R6)/lib64 -lX11 $(EXPLIBS)
+ $(CC) $(CFLAGS) $(OBJS) -o alevt $(PNG_LIBS) $(X11_LIBS)
alevt-date: $(TOBJS)
diff --git a/misc/alevt/files/patch-xio.c b/misc/alevt/files/patch-xio.c
index 0f80a2cdf1b2..9f8a5cd55ef6 100644
--- a/misc/alevt/files/patch-xio.c
+++ b/misc/alevt/files/patch-xio.c
@@ -1,30 +1,10 @@
---- xio.c.orig 2002-08-20 05:09:38.000000000 +0200
-+++ xio.c 2007-08-23 07:48:59.587926513 +0200
-@@ -31,11 +31,11 @@
-
- static struct dl_head dpys[1]; /* list of all displays */
-
-+static void xio_timer();
-
- static int
- timer_init(int argc, char **argv)
- {
-- static void xio_timer();
- int p[2], timer_pid, i;
-
- if (pipe(p) == -1)
-@@ -154,13 +154,12 @@
- fdset_del_fd(fds, fd);
+--- xio.c.orig 2007-12-03 06:18:04.000000000 +0000
++++ xio.c 2008-04-30 12:37:57.000000000 +0000
+@@ -156,6 +156,7 @@
}
--
+
+static void handle_event(); //forward ref
struct xio *
xio_open_dpy(char *dpy, int argc, char **argv)
- {
- XClassHint classhint[1];
-- static void handle_event(); //forward ref
- struct xio *xio;
-
- if (local_init(argc, argv) == -1)