aboutsummaryrefslogtreecommitdiff
path: root/misc/amanda-server/Makefile
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2009-02-04 22:55:46 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2009-02-04 22:55:46 +0000
commit128a9e143018f18d73286013d1d23438eaa6f224 (patch)
tree7020e7d3b9ac6600b4321b28a1ca83789f21478d /misc/amanda-server/Makefile
parent9d240f3b3c6d5b43b904c995a7e96b78da78c493 (diff)
downloadports-128a9e143018f18d73286013d1d23438eaa6f224.tar.gz
ports-128a9e143018f18d73286013d1d23438eaa6f224.zip
Notes
Diffstat (limited to 'misc/amanda-server/Makefile')
-rw-r--r--misc/amanda-server/Makefile99
1 files changed, 65 insertions, 34 deletions
diff --git a/misc/amanda-server/Makefile b/misc/amanda-server/Makefile
index 070b4ab1281d..0240b8687e9b 100644
--- a/misc/amanda-server/Makefile
+++ b/misc/amanda-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= amanda
-PORTVERSION= 2.6.0p2
+PORTVERSION= 2.6.1
PORTEPOCH= 1
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -29,24 +29,24 @@ CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
--without-amlibexecdir \
--with-amandahosts --with-fqdn \
--with-dump-honor-nodump --with-buffered-dump \
- --disable-libtool --prefix=${PREFIX} \
+ --prefix=${PREFIX} \
--disable-glibtest \
--with-user=${AMANDA_USER} --with-group=${AMANDA_GROUP} \
- --with-bsdtcp-security --with-bsdudp-security
+ --with-bsdtcp-security --with-bsdudp-security \
+ --with-ssh-security
USE_LDCONFIG= yes
-WANT_PERL= yes
+USE_PERL5= yes
-OPTIONS= GNUTAR "use GNU tar" on \
- SSH "enable ssh-auth" off
+OPTIONS= GNUTAR "use GNU tar" on
.include <bsd.port.pre.mk>
AMANDA_USER?= operator
AMANDA_GROUP?= operator
AMANDA_GNUTAR_LISTDIR?= ${PREFIX}/var/amanda/gnutar-lists
-AMANDA_DATES?= ${PREFIX}/var/amanda/amandadates
-PLIST_SUB= SHLIBVER=${PORTVERSION} AMANDA_DATES=${PREFIX}/var/amanda/amandadates
+AMANDA_DATES?= ${PREFIX}/var/amanda/amandates
+PLIST_SUB= SHLIBVER=${PORTVERSION} AMANDA_DATES=${AMANDA_DATES}
# amanda-server/amanda-client common part
.if defined (AMANDA_SERVER)
@@ -62,10 +62,6 @@ CONFIGURE_ARGS+= --with-config=${AMANDA_CONFIG}
CONFIGURE_ARGS+= --with-udpportrange=${AMANDA_UDPPORTRANGE}
.endif
-.if defined (WITH_SSH)
-CONFIGURE_ARGS+= --with-ssh-security
-.endif
-
.if defined (AMANDA_TCPPORTRANGE)
CONFIGURE_ARGS+= --with-tcpportrange=${AMANDA_TCPPORTRANGE}
.endif
@@ -89,7 +85,7 @@ pre-fetch:
@${ECHO} " AMANDA_TAPE=tape to specify the default tape device"
@${ECHO} " The default is /dev/nrsa0"
@${ECHO} " AMANDA_CONFIG=config to specify the default configuration"
- @${ECHO} " The default is user"
+ @${ECHO} " The default is DailySet1"
@${ECHO} " AMANDA_USER=user to specify the default user"
@${ECHO} " The default is operator"
@${ECHO} " AMANDA_GROUP=group to specify the default group"
@@ -102,9 +98,9 @@ pre-fetch:
@${ECHO} " between low and high when connecting from the client"
@${ECHO} " to the server. Use ports below 1024."
@${ECHO} " The default is no restriction on UDP ports."
+ @${ECHO} " AMANDA_DATES=path to client amandates file"
@${ECHO} ""
-USE_PERL5= yes
CONFLICTS= amanda-server-2.5.*
BUILD_DEPENDS+= ${LOCALBASE}/lib/amanda/libamandad-${PORTVERSION}.so:${PORTSDIR}/misc/amanda-client
@@ -112,28 +108,36 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/amanda/libamandad-${PORTVERSION}.so:${PORTSDIR}/m
CONFIGURE_ARGS+=--without-client
+MAN5= disklist.5 \
+ tapelist.5
+MAN7= amanda-changers.7 \
+ amanda-devices.7
MAN8= amaddclient.8 amadmin.8 amaespipe.8 amcheck.8 \
amcheckdb.8 amcheckdump.8 amcleanup.8 \
amcrypt.8 amcryptsimple.8 amcrypt-ossl-asym.8 amcrypt-ossl.8 \
- amdd.8 amdevcheck.8 \
+ amdevcheck.8 \
amdump.8 amfetchdump.8 amflush.8 amgetconf.8 amgpgcrypt.8 \
- amlabel.8 ammt.8 \
+ amlabel.8 \
amoverview.8 amreport.8 amrestore.8 amrmtape.8 \
- amserverconfig.8 amstatus.8 \
- amtape.8 amtoc.8 amverify.8 amverifyrun.8 amtapetype.8
+ amserverconfig.8 amservice.8 amstatus.8 \
+ amtape.8 amtoc.8 amtapetype.8 \
+ amvault.8
OPTIONS+= PLOT "enable ploting, requires X11 libraries" off\
SAMBA "enable the use of smbclient" off \
MTX "enable the use of mtx changer scripts" off \
- AESPIPE "enable encryption. Needed by amcrypt" off
+ AESPIPE "enable encryption. Needed by amcrypt" off \
+ S3 "enable Amazon S3 device support" off
.if defined (WITH_PLOT)
BUILD_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
RUN_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
MAN8+= amplot.8
PLIST_SUB+= PLOT=''
+CONFIGURE_ARGS+= --with-gnuplot=${LOCALBASE}/bin/gnuplot
.else
PLIST_SUB+= PLOT='@comment '
+CONFIGURE_ARGS+= --without-gnuplot
.endif
.if defined (WITH_SAMBA)
@@ -149,6 +153,17 @@ RUN_DEPENDS+= mtx:${PORTSDIR}/misc/mtx
.if defined (WITH_AESPIPE)
RUN_DEPENDS+= aespipe:${PORTSDIR}/security/aespipe
+.else
+.endif
+
+# If configure founds libcurl, automatically enabled it (with plist change).
+.if defined(WITH_S3)
+LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+CONFIGURE_ARGS+= --enable-s3-device
+PLIST_SUB+= S3DEVICE=''
+.else
+CONFIGURE_ARGS+= --disable-s3-device
+PLIST_SUB+= S3DEVICE='@comment '
.endif
.if defined (AMANDA_TAPE)
@@ -165,10 +180,10 @@ pre-fetch:
@${ECHO} " AMANDA_SERVER=server to specify a server name"
@${ECHO} " The default is `uname -n`"
@${ECHO} " AMANDA_CONFIG=config to specify the default configuation"
- @${ECHO} " The default is user"
+ @${ECHO} " The default is DailySet1"
@${ECHO} " AMANDA_GNUTAR_LISTDIR=dir to specify the directory that"
@${ECHO} " the gnutar index files should live in"
- @${ECHO} " The default is /var/amanda/gnutar-lists"
+ @${ECHO} " The default is ${PREFIX}/var/amanda/gnutar-lists"
@${ECHO} " AMANDA_USER=user to specify the default user"
@${ECHO} " The default is operator"
@${ECHO} " AMANDA_GROUP=group to specify the default group"
@@ -184,36 +199,52 @@ pre-fetch:
@${ECHO} " AMANDA_DATES=path to client amandates file"
@${ECHO} ""
+OPTIONS+= ZFSCOMP "accurate estimation of compressed ZFS filesystems" off
+
CONFLICTS= amanda-client-2.5.*
CONFIGURE_ARGS+=--without-server --with-amandates=${AMANDA_DATES}
-MAN5= amanda.conf.5 amanda-client.conf.5
-MAN8= amanda.8 amrecover.8
-
-OPTIONS+= DUMP_SNAPSHOT "use snapshot by using dump -L" off
+MAN5= amanda-archive-format.5 \
+ amanda-client.conf.5 \
+ amanda.conf.5
+MAN7= amanda-applications.7 \
+ amanda-auth.7 \
+ amanda-scripts.7
+MAN8= amanda.8 \
+ amarchiver.8 \
+ amgtar.8 \
+ amrecover.8 \
+ amsamba.8 \
+ amstar.8 \
+ amzfs-sendrecv.8 \
+ amzfs-snapshot.8 \
+ script-email.8
post-install:
- ${MKDIR} ${PREFIX}/share/examples/amanda
- ${CP} -R ${WRKSRC}/example/amanda.conf \
- ${WRKSRC}/example/chg-multi.conf \
+.ifndef(NOPORTDOCS)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/example/chg-multi.conf \
${WRKSRC}/example/chg-scsi.conf \
${WRKSRC}/example/disklist \
- ${PREFIX}/share/examples/amanda
+ ${EXAMPLESDIR}
+.endif
${MKDIR} ${AMANDA_GNUTAR_LISTDIR}
${CHOWN} ${AMANDA_USER}:${AMANDA_GROUP} ${AMANDA_GNUTAR_LISTDIR}
${TOUCH} ${AMANDA_DATES}
${CHOWN} ${AMANDA_USER}:${AMANDA_GROUP} ${AMANDA_DATES}
-.if defined (WITH_DUMP_SNAPSHOT)
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-sendbackup-dump.c
.endif
+.if defined(WITH_ZFSCOMP)
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-application-src::amzfs-sendrecv.pl
.endif
+# MEMO:
+# Prefix @WANT_SERVER_TRUE@ for server only files.
+# Prefix @WANT_CLIENT_TRUE@ for client only files.
# Maintainer TODO:
-# o amanda-server installs lib/libamandad.a which should be handled by
-# amanda-client only.
-# o man pages have incorrect markups.
+# o amanda-server installs libexec/amanda/amandad, sbin/amarchiver
+# which should be handled by amanda-client only.
# o pthread issue: http://wiki.zmanda.com/index.php/Installation/OS_Specific_Notes/Installing_Amanda_on_FreeBSD#Threading_and_-pthread
.include <bsd.port.post.mk>