aboutsummaryrefslogtreecommitdiff
path: root/misc/amanda/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-12-23 16:18:36 +0000
committerSteve Price <steve@FreeBSD.org>1999-12-23 16:18:36 +0000
commit06bc5745f8b3af1936bbf8f8c0c4aff80eb6fa85 (patch)
tree3e27d79fa22038eb364b4fe2b9eecf97408a2298 /misc/amanda/Makefile
parentd112d0f6ccd58fac3c3b7783a71378c44765fbae (diff)
downloadports-06bc5745f8b3af1936bbf8f8c0c4aff80eb6fa85.tar.gz
ports-06bc5745f8b3af1936bbf8f8c0c4aff80eb6fa85.zip
Notes
Diffstat (limited to 'misc/amanda/Makefile')
-rw-r--r--misc/amanda/Makefile37
1 files changed, 30 insertions, 7 deletions
diff --git a/misc/amanda/Makefile b/misc/amanda/Makefile
index 8595ff69645d..df0471af745d 100644
--- a/misc/amanda/Makefile
+++ b/misc/amanda/Makefile
@@ -12,15 +12,38 @@ MASTER_SITES= ftp://ftp.cs.umd.edu/pub/amanda/old-versions/
MAINTAINER= ports@FreeBSD.org
-PATCH_STRIP=
-MAN8= amanda.8 amadmin.8 amcheck.8 amcleanup.8 amdump.8 \
- amflush.8 amlabel.8 amrestore.8 amtape.8
+MAN8= amadmin.8 amanda.8 amcheck.8 amcleanup.8 amdump.8 amflush.8 \
+ amlabel.8 amrestore.8 amtape.8
-pre-configure:
- ${ECHO} "${CFLAGS}" > /tmp/build-ports-misc-amanda-cflags
+LIBEXEC_BIN= amandad calcsize driver dumper getconf planner reporter \
+ runtar selfcheck sendbackup-dump sendbackup-gnutar sendsize \
+ taper
+SBIN_BIN= amadmin amcheck amflush amlabel amrestore amtape
+
+post-patch:
+ @${LN} -sf config.h-freebsd2 ${WRKSRC}/config/config.h
+ @${SED} -e 's:%%CC%%:${CC}:g' \
+ -e 's:%%CFLAGS%%:${CFLAGS}:g' \
+ -e 's:%%INSTALL%%:${INSTALL}:g' \
+ -e 's:%%PREFIX%%:${PREFIX}:g' \
+ ${WRKSRC}/config/options.h-vanilla > ${WRKSRC}/config/options.h
+.for file in amanda.8 amcleanup.8 amflush.8 amlabel.8
+ @cd ${WRKSRC}/man/; ${MV} ${file} ${file}.in; \
+ ${SED} -e 's:%%PREFIX%%:${PREFIX}:g' ${file}.in > ${file}
+.endfor
post-install:
- ${MKDIR} ${PREFIX}/share/examples/amanda
- ${CP} -R ${WRKSRC}/example/* ${PREFIX}/share/examples/amanda
+.for file in ${LIBEXEC_BIN}
+ @if [ -f ${PREFIX}/libexec/amanda/${file} ]; then \
+ strip ${PREFIX}/libexec/amanda/${file}; \
+ fi
+.endfor
+.for file in ${SBIN_BIN}
+ @if [ -f ${PREFIX}/sbin/${file} ]; then \
+ strip ${PREFIX}/sbin/${file}; \
+ fi
+.endfor
+ @${MKDIR} ${PREFIX}/share/examples/amanda
+ ${INSTALL_DATA} ${WRKSRC}/example/* ${PREFIX}/share/examples/amanda
.include <bsd.port.mk>