aboutsummaryrefslogtreecommitdiff
path: root/misc/artikulate/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2014-10-19 15:57:27 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2014-10-19 15:57:27 +0000
commit0ea52f99b465b681e2a4bf7c44a8f7093f40fc68 (patch)
tree7d99a8b7b1226b2da14c7c6d04800d30a417873e /misc/artikulate/Makefile
parent24055ead515d6e00a9aaf5c651358eb4e8f56300 (diff)
downloadports-0ea52f99b465b681e2a4bf7c44a8f7093f40fc68.tar.gz
ports-0ea52f99b465b681e2a4bf7c44a8f7093f40fc68.zip
Notes
Diffstat (limited to 'misc/artikulate/Makefile')
-rw-r--r--misc/artikulate/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/misc/artikulate/Makefile b/misc/artikulate/Makefile
new file mode 100644
index 000000000000..ddfe8d6c5335
--- /dev/null
+++ b/misc/artikulate/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= artikulate
+PORTVERSION= ${KDE4_VERSION}
+CATEGORIES= misc kde
+MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
+DIST_SUBDIR= KDE/${PORTVERSION}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Pronunciation trainer for KDE
+
+LIB_DEPENDS= libQtGStreamer-1.0.so:${PORTSDIR}/multimedia/gstreamer1-qt4 \
+ libboost_thread.so:${PORTSDIR}/devel/boost-libs
+RUN_DEPENDS= ${LOCALBASE}/lib/kde4/imports/org/kde/charts/qmldir:${PORTSDIR}/graphics/kqtquickcharts
+
+IGNORE= not usable, links to both GStreamer 0.10.x and 1.x
+
+USE_KDE4= automoc4 kdelibs kdeprefix libkdeedu runtime_run
+USES= cmake:outsource tar:xz
+USE_QT4= moc_build qmake_build rcc_build uic_build
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>