aboutsummaryrefslogtreecommitdiff
path: root/misc/asbutton/Makefile
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-04-21 10:41:18 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-04-21 10:41:18 +0000
commit4a4866776ad39be741f61679729d2e4e6c2fed4f (patch)
tree4326c3920fc6619e67cb9b24ceebc89dd12d0106 /misc/asbutton/Makefile
parent32fd349c35b37080959fa2d433c00e21815ff02a (diff)
downloadports-4a4866776ad39be741f61679729d2e4e6c2fed4f.tar.gz
ports-4a4866776ad39be741f61679729d2e4e6c2fed4f.zip
Notes
Diffstat (limited to 'misc/asbutton/Makefile')
-rw-r--r--misc/asbutton/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/misc/asbutton/Makefile b/misc/asbutton/Makefile
index fbecde49c515..94ad8ec75c4c 100644
--- a/misc/asbutton/Makefile
+++ b/misc/asbutton/Makefile
@@ -13,9 +13,16 @@ MASTER_SITES= http://www.tigr.net/afterstep/download/asbutton/
MAINTAINER= ports@FreeBSD.org
COMMENT= A dockapp that displays 4 or 9 buttons to run apps of your choice
+USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_XPM= yes
ALL_TARGET= asbutton
+MAKE_ARGS= INCLUDES="-I${X11BASE}/include/X11 -I${X11BASE}/include" \
+ LIBINC="-L${X11BASE}/lib" LIBS="-lm -lX11 -lXpm -lXext" \
+ CCFLAGS="${CFLAGS}"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's:gcc :${CC} :' ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/asbutton ${PREFIX}/bin