aboutsummaryrefslogtreecommitdiff
path: root/misc/asbutton/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-02-27 08:43:08 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-02-27 08:43:08 +0000
commit0a665fd9a1e9136dd0f4c432d6a0d069b33e06a8 (patch)
treec2591f04782bbf585e1de932213b3542c3efe7af /misc/asbutton/Makefile
parent016bc48eb55f50ed4ae4868def3e0cf5ed74640c (diff)
downloadports-0a665fd9a1e9136dd0f4c432d6a0d069b33e06a8.tar.gz
ports-0a665fd9a1e9136dd0f4c432d6a0d069b33e06a8.zip
Notes
Diffstat (limited to 'misc/asbutton/Makefile')
-rw-r--r--misc/asbutton/Makefile37
1 files changed, 18 insertions, 19 deletions
diff --git a/misc/asbutton/Makefile b/misc/asbutton/Makefile
index caff989ccd74..e6d2dd40be0e 100644
--- a/misc/asbutton/Makefile
+++ b/misc/asbutton/Makefile
@@ -5,13 +5,13 @@ PORTNAME= asbutton
PORTVERSION= 0.3
PORTREVISION= 3
CATEGORIES= misc windowmaker afterstep
-MASTER_SITES= http://www.tigr.net/afterstep/download/asbutton/
+MASTER_SITES= AFTERSTEP/apps/asbutton/ \
+ http://tigr.net/afterstep/download/asbutton/
MAINTAINER= ports@FreeBSD.org
COMMENT= Dockapp that displays 4 or 9 buttons to run apps of your choice
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2014-03-07
+LICENSE= GPLv2
USE_XORG= x11 xpm
ALL_TARGET= asbutton
@@ -19,23 +19,22 @@ MAKE_ARGS= INCLUDES="-I${LOCALBASE}/include/X11 -I${LOCALBASE}/include" \
LIBINC="-L${LOCALBASE}/lib" LIBS="-lm -lX11 -lXpm -lXext" \
CCFLAGS="${CFLAGS}"
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= EXAMPLES
post-patch:
- @${REINPLACE_CMD} -e 's:gcc :${CC} :' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|gcc |$${CC} |' ${WRKSRC}/Makefile
+
+post-build:
+ @${LN} -sf .asbuttonrc ${WRKSRC}/asbuttonrc
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/asbutton ${PREFIX}/bin
- @${ECHO} "===> Installing icons in ${PREFIX}/share/asbutton"
- @${MKDIR} ${PREFIX}/share/asbutton && ${CHMOD} a+rx ${PREFIX}/share/asbutton
- ${INSTALL_DATA} ${WRKSRC}/icons/*.xpm ${PREFIX}/share/asbutton
-
-post-install:
- @${ECHO} "===> Installing sample asbuttonrc in ${PREFIX}/share/examples/asbutton"
- @${ECHO} "===> Copy to ~/.asbuttonrc and modify to desired config."
- @${MKDIR} ${PREFIX}/share/examples/asbutton && ${CHMOD} a+rx ${PREFIX}/share/examples/asbutton
- ${INSTALL_DATA} ${WRKSRC}/.asbuttonrc ${PREFIX}/share/examples/asbutton/asbuttonrc && ${CHMOD} u+rw ${PREFIX}/share/examples/asbutton/asbuttonrc
- @${ECHO} "===> Use 'asbutton -h' for help."
-
-.include <bsd.port.post.mk>
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} asbutton \
+ ${STAGEDIR}${PREFIX}/bin)
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${WRKSRC}/icons && ${INSTALL_DATA} *.xpm \
+ ${STAGEDIR}${DATADIR})
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} asbuttonrc \
+ ${STAGEDIR}${EXAMPLESDIR})
+
+.include <bsd.port.mk>