aboutsummaryrefslogtreecommitdiff
path: root/misc/bibletime-kde3/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2002-11-23 03:33:20 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2002-11-23 03:33:20 +0000
commit8a633b59afd4f481baf50e14c9eaea961d0b059d (patch)
treeba3d8fc4ef411364895e27cef3859d94aa23ac9d /misc/bibletime-kde3/Makefile
parent62cb7b1a93521579ec5965c11574deceef11bbf3 (diff)
New port: misc/bibletime
BibleTime is a powerful Bible study application for the K Desktop Environment running on Unix operating systems. BibleTime is based on the Sword library which provides access to all the different text modules created by the Crosswire Bible Society. PR: ports/34981 Submitted by: Willem van Engen <wvengen+port@stack.nl>
Notes
Notes: svn path=/head/; revision=70810
Diffstat (limited to 'misc/bibletime-kde3/Makefile')
-rw-r--r--misc/bibletime-kde3/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/misc/bibletime-kde3/Makefile b/misc/bibletime-kde3/Makefile
new file mode 100644
index 000000000000..92f5a7ff2c2b
--- /dev/null
+++ b/misc/bibletime-kde3/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: bibletime
+# Date created: 3 May 2002
+# Whom: Willem van Engen <wvengen@stack.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bibletime
+PORTVERSION= 1.2.1
+CATEGORIES= misc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= wvengen@stack.nl
+
+LIB_DEPENDS= sword.1:${PORTSDIR}/misc/sword
+.if !defined(NOPORTDOCS)
+RUN_DEPENDS= ${LOCALBASE}/share/doc/HTML/en/bibletime:${PORTSDIR}/misc/bibletime-doc
+.endif
+
+USE_KDELIBS_VER=3
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_BZIP2= yes
+USE_REINPLACE= yes
+CONFIGURE_ARGS+=--program-transform-name="" \
+ --with-sworddir=${PREFIX}
+
+post-patch:
+ @${REINPLACE_CMD} -e "s^-lpthread^${PTHREAD_LIBS}^g" ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e "s^-lpthread^${PTHREAD_LIBS}^g" ${WRKSRC}/bibletime/Makefile.in
+
+.include <bsd.port.mk>