aboutsummaryrefslogtreecommitdiff
path: root/misc/biblical-curse/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2005-11-08 17:34:51 +0000
committerAnton Berezin <tobez@FreeBSD.org>2005-11-08 17:34:51 +0000
commit05473992491986c6640d07cbfd1a3bfe3d778a20 (patch)
tree7e66c646ea51f76c3462db0a67a218057bac9d25 /misc/biblical-curse/Makefile
parentb7b4aa1a89514dc1b76b3b8271582b98a34c6fab (diff)
Notes
Diffstat (limited to 'misc/biblical-curse/Makefile')
-rw-r--r--misc/biblical-curse/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/misc/biblical-curse/Makefile b/misc/biblical-curse/Makefile
new file mode 100644
index 000000000000..522279ca51aa
--- /dev/null
+++ b/misc/biblical-curse/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: biblical-curse
+# Date created: 08 Nov 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+# This port is self contained in the src directory.
+#
+
+PORTNAME= biblical-curse
+PORTVERSION= 0.02
+CATEGORIES= misc
+MASTER_SITES= # none
+DISTFILES= # none
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Fake biblical curse generator
+
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/src
+USE_PERL5_RUN= yes
+USE_REINPLACE= yes
+
+SRC= ${.CURDIR}/src
+
+do-fetch:
+ @${DO_NADA}
+
+pre-patch:
+ @${CP} -R ${SRC} ${WRKDIR}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|' ${WRKSRC}/biblical-curse
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/biblical-curse ${PREFIX}/bin/biblical-curse
+
+.include <bsd.port.mk>