aboutsummaryrefslogtreecommitdiff
path: root/misc/brs
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2003-07-11 04:59:09 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2003-07-11 04:59:09 +0000
commit9e9945966a4e7d3d19af4533176cd59f2ad97f0a (patch)
tree728f5c9b9c938884568591168d17165fd2a1105e /misc/brs
parentf71bf2cb70f346178e2dde0b6b80506c1ad0282f (diff)
downloadports-9e9945966a4e7d3d19af4533176cd59f2ad97f0a.tar.gz
ports-9e9945966a4e7d3d19af4533176cd59f2ad97f0a.zip
update misc/brs: 4.0 -> 4.03
PR: 54353 Submitted by: Kim Scarborough <sluggo@unknown.nu> (maintainer)
Notes
Notes: svn path=/head/; revision=84638
Diffstat (limited to 'misc/brs')
-rw-r--r--misc/brs/Makefile19
-rw-r--r--misc/brs/distinfo3
-rw-r--r--misc/brs/files/patch-aa173
-rw-r--r--misc/brs/files/patch-ab25
-rw-r--r--misc/brs/pkg-descr2
-rw-r--r--misc/brs/pkg-plist6
6 files changed, 178 insertions, 50 deletions
diff --git a/misc/brs/Makefile b/misc/brs/Makefile
index 88fabfa3a7bd..e6eb71bac60d 100644
--- a/misc/brs/Makefile
+++ b/misc/brs/Makefile
@@ -6,17 +6,26 @@
#
PORTNAME= brs
-PORTVERSION= 4.0
+PORTVERSION= 4.03
CATEGORIES= misc
-MASTER_SITES= ${MASTER_SITE_SUNSITE}
-MASTER_SITE_SUBDIR= apps/religion
-DISTNAME= brs.4.00.l1
+MASTER_SITES= ftp://classworld.com/BRS/ \
+ http://www.unknown.nu/ports/
+DISTFILES= bible.data.tar bible.tar.Z
+DIST_SUBDIR= brs
MAINTAINER= user@unknown.nu
COMMENT= An interactive King James Bible
-WRKSRC= ${WRKDIR}/bible
+NO_WRKSUBDIR= yes
ALL_TARGET=
MAN1= bible.1
+post-patch:
+ @${MV} ${WRKSRC}/brl.c ${WRKSRC}/brl.c.sed
+ ${SED} -e "s=%%PREFIX%%=${PREFIX}=g" \
+ ${WRKSRC}/brl.c.sed > ${WRKSRC}/brl.c
+ @${MV} ${WRKSRC}/bible.1 ${WRKSRC}/bible.1.sed
+ ${SED} -e "s=%%PREFIX%%=${PREFIX}=g" \
+ ${WRKSRC}/bible.1.sed > ${WRKSRC}/bible.1
+
.include <bsd.port.mk>
diff --git a/misc/brs/distinfo b/misc/brs/distinfo
index 1ab52ccd74bf..277edf63a68a 100644
--- a/misc/brs/distinfo
+++ b/misc/brs/distinfo
@@ -1 +1,2 @@
-MD5 (brs.4.00.l1.tar.gz) = 260b789e0ff401293ef05809fc42581b
+MD5 (brs/bible.data.tar) = 34b9aed98f4430f305b97d2d086e9a6c
+MD5 (brs/bible.tar.Z) = 196f058590acf14c1e4050c2d25c1c4c
diff --git a/misc/brs/files/patch-aa b/misc/brs/files/patch-aa
index 8ea4cda6b904..5969044dcc74 100644
--- a/misc/brs/files/patch-aa
+++ b/misc/brs/files/patch-aa
@@ -1,38 +1,135 @@
---- Makefile.orig Wed Jul 12 23:30:36 2000
-+++ Makefile Wed Jul 12 23:32:29 2000
-@@ -46,7 +46,7 @@
- NINSTPKG = $(PROGRAM).pkg
-
- # where to install this stuff
--DEST = /usr
-+DEST = $(PREFIX)
- #DEST = $(HOME)/local
- DESTBIN = $(DEST)/bin
- DESTLIB = $(DEST)/lib
-@@ -405,23 +405,20 @@
- @if [ $(DESTBIN) != . ]; then \
- ((cd $(DESTBIN);rm -f $(PROGRAM)); \
- cp $(PROGRAM) $(DESTBIN)); \
-- chown bin $(DESTBIN)/$(PROGRAM); \
-- chgrp bin $(DESTBIN)/$(PROGRAM); \
-+ chown root:wheel $(DESTBIN)/$(PROGRAM); \
- chmod 755 $(DESTBIN)/$(PROGRAM); fi
- @echo Installing $(DATA) and $(DATA).conc in $(DESTLIB)
- @if [ ! -r $(DESTLIB) ]; then mkdir $(DESTLIB); fi
- @if [ $(DESTLIB) != . ]; then \
- cp $(DATA) $(DATA).conc $(DESTLIB); \
-- chown bin $(DESTLIB)/$(DATA) $(DESTLIB)/$(DATA).conc; \
-- chgrp bin $(DESTLIB)/$(DATA) $(DESTLIB)/$(DATA).conc; \
-+ chown root:wheel $(DESTLIB)/$(DATA) $(DESTLIB)/$(DATA).conc; \
- chmod 644 $(DESTLIB)/$(DATA) $(DESTLIB)/$(DATA).conc; fi
- @if [ ! -r $(DESTMAN) ]; then mkdir $(DESTMAN); fi
- @echo Installing $(MAN) in $(DESTMAN1)
- @if [ ! -r $(DESTMAN1) ]; then mkdir $(DESTMAN1); fi
- @if [ $(DESTMAN1) != . ]; then \
- cp $(MAN) $(DESTMAN1)/$(MAN); \
-- chown bin $(DESTMAN1)/$(MAN); \
-- chgrp bin $(DESTMAN1)/$(MAN); \
-+ chown root:wheel $(DESTMAN1)/$(MAN); \
- chmod 644 $(DESTMAN1)/$(MAN); fi
-
- uninstall:; @echo Un-installing $(PROGRAM), $(DATA) and $(MAN)
+*** Makefile.orig Wed Aug 9 18:49:09 1995
+--- Makefile Thu Jul 10 22:40:43 2003
+***************
+*** 177,185 ****
+ # primary man page
+ MAN = $(PROGRAM).1
+
+- # raw data file
+- RAWDATA = $(PROGRAM).rawtext
+-
+ # Derived data file. Comes from processing raw data file.
+ DATA = $(PROGRAM).data
+
+--- 177,182 ----
+***************
+*** 187,198 ****
+ NINSTPKG = $(PROGRAM).pkg
+
+ # where to install this stuff
+! DEST = /usr/local
+ #DEST = $(HOME)/local
+ DESTBIN = $(DEST)/bin
+! DESTLIB = $(DEST)/lib
+ DESTMAN = $(DEST)/man
+! DESTMAN1 = $(DESTMAN)/man1.Z
+
+ # release directories. Nobody should care about this but me
+ FTPHOME = /mnt/ftp
+--- 184,195 ----
+ NINSTPKG = $(PROGRAM).pkg
+
+ # where to install this stuff
+! DEST = $(PREFIX)
+ #DEST = $(HOME)/local
+ DESTBIN = $(DEST)/bin
+! DESTLIB = $(DEST)/share/brs
+ DESTMAN = $(DEST)/man
+! DESTMAN1 = $(DESTMAN)/man1
+
+ # release directories. Nobody should care about this but me
+ FTPHOME = /mnt/ftp
+***************
+*** 349,358 ****
+ else rm squish.tmpdata squish.stats; fi
+
+
+- $(PROGINDEX).c: $(RAWDATA)
+- make makeindex
+- ./makeindex $(RAWDATA) > $@
+-
+ $(DATA): squish.stats squish.data
+ make buildcmp
+ ./buildcmp
+--- 346,351 ----
+***************
+*** 366,384 ****
+ # Note that $(PROGINDEX).c is included in source distributions, while
+ # $(RAWDATA) is NOT included in all distributions. $(PROGINDEX).c does NOT
+ # need to be rebuilt unless someone (probably me) has munged $(RAWDATA).
+- SAFEDATE = 0101000193
+- $(RAWDATA):
+- @touch $(SAFEDATE) $@
+- @if [ -r $(SAFEDATE) ]; then \
+- /bin/rm $(SAFEDATE) $@; \
+- if [ -x /usr/5bin/touch ]; then \
+- /usr/5bin/touch $(SAFEDATE) $@; \
+- else \
+- # major kludge alert! ... \
+- touch brl-startverse.h brl-startchapter.h $(PROGINDEX).c; \
+- fi; \
+- fi
+- @echo " A dummy $(RAWDATA) file has been created."
+
+ # The dependency on $(RAWDATA) helps to ensure that the raw concordance file
+ # is not rebuilt unnecessarily.
+--- 359,364 ----
+***************
+*** 392,401 ****
+ ./makeconc.pl
+ # ./makeconcordance
+
+- $(MAN).Z: $(MAN)
+- /bin/rm $@
+- compress < $(MAN) > $(MAN).Z
+-
+ clean:; @rm -f $(PROGOBJS) $(TOOLOBJS) core
+
+ clobber:; @rm -f $(PROGOBJS) $(TOOLOBJS) $(PROGRAM) $(TOOLS) $(DATA) \
+--- 372,377 ----
+***************
+*** 543,565 ****
+ @if [ $(DESTBIN) != . ]; then \
+ ((cd $(DESTBIN);rm -f $(PROGRAM)); \
+ cp $(PROGRAM) $(DESTBIN)); \
+! chown bin $(DESTBIN)/$(PROGRAM); \
+! chgrp bin $(DESTBIN)/$(PROGRAM); \
+ chmod 755 $(DESTBIN)/$(PROGRAM); fi
+ @echo Installing $(DATA) and $(DATA).conc in $(DESTLIB)
+ @if [ ! -r $(DESTLIB) ]; then mkdir $(DESTLIB); fi
+ @if [ $(DESTLIB) != . ]; then \
+ cp $(DATA) $(DATA).conc $(DESTLIB); \
+! chown bin $(DESTLIB)/$(DATA) $(DESTLIB)/$(DATA).conc; \
+! chgrp bin $(DESTLIB)/$(DATA) $(DESTLIB)/$(DATA).conc; \
+ chmod 644 $(DESTLIB)/$(DATA) $(DESTLIB)/$(DATA).conc; fi
+ @if [ ! -r $(DESTMAN) ]; then mkdir $(DESTMAN); fi
+ @echo Installing $(MAN) in $(DESTMAN1)
+ @if [ ! -r $(DESTMAN1) ]; then mkdir $(DESTMAN1); fi
+ @if [ $(DESTMAN1) != . ]; then \
+! cp $(MAN).Z $(DESTMAN1)/$(MAN); \
+! chown bin $(DESTMAN1)/$(MAN); \
+! chgrp bin $(DESTMAN1)/$(MAN); \
+ chmod 644 $(DESTMAN1)/$(MAN); fi
+
+ uninstall:; @echo Un-installing $(PROGRAM), $(DATA) and $(MAN)
+--- 519,538 ----
+ @if [ $(DESTBIN) != . ]; then \
+ ((cd $(DESTBIN);rm -f $(PROGRAM)); \
+ cp $(PROGRAM) $(DESTBIN)); \
+! chown root:wheel $(DESTBIN)/$(PROGRAM); \
+ chmod 755 $(DESTBIN)/$(PROGRAM); fi
+ @echo Installing $(DATA) and $(DATA).conc in $(DESTLIB)
+ @if [ ! -r $(DESTLIB) ]; then mkdir $(DESTLIB); fi
+ @if [ $(DESTLIB) != . ]; then \
+ cp $(DATA) $(DATA).conc $(DESTLIB); \
+! chown root:wheel $(DESTLIB)/$(DATA) $(DESTLIB)/$(DATA).conc; \
+ chmod 644 $(DESTLIB)/$(DATA) $(DESTLIB)/$(DATA).conc; fi
+ @if [ ! -r $(DESTMAN) ]; then mkdir $(DESTMAN); fi
+ @echo Installing $(MAN) in $(DESTMAN1)
+ @if [ ! -r $(DESTMAN1) ]; then mkdir $(DESTMAN1); fi
+ @if [ $(DESTMAN1) != . ]; then \
+! cp $(MAN) $(DESTMAN1)/$(MAN); \
+! chown root:wheel $(DESTMAN1)/$(MAN); \
+ chmod 644 $(DESTMAN1)/$(MAN); fi
+
+ uninstall:; @echo Un-installing $(PROGRAM), $(DATA) and $(MAN)
diff --git a/misc/brs/files/patch-ab b/misc/brs/files/patch-ab
index a6294b5b92a0..be490a2586a5 100644
--- a/misc/brs/files/patch-ab
+++ b/misc/brs/files/patch-ab
@@ -1,5 +1,5 @@
-*** bible.1.orig Mon Dec 12 13:05:28 1994
---- bible.1 Mon Jul 10 13:34:08 2000
+*** bible.1.orig Fri Apr 23 15:07:57 1993
+--- bible.1 Thu Jul 10 22:55:07 2003
***************
*** 314,330 ****
Miscellaneous program control commands:
@@ -37,3 +37,24 @@
Stop writing to a file.
.TP
.B \>, \<
+***************
+*** 369,377 ****
+ results in a range of Matthew 1:1 to Revelation 1:1, instead of extending
+ all the way to Revelation 22:21.
+ .SH FILES
+! /usr/local/lib/bible.data
+ .br
+! /usr/local/lib/bible.data.conc
+ .SH SEE ALSO
+ Rev3:20
+ .SH AUTHOR
+--- 369,377 ----
+ results in a range of Matthew 1:1 to Revelation 1:1, instead of extending
+ all the way to Revelation 22:21.
+ .SH FILES
+! %%PREFIX%%/share/brs/bible.data
+ .br
+! %%PREFIX%%/share/brs/bible.data.conc
+ .SH SEE ALSO
+ Rev3:20
+ .SH AUTHOR
diff --git a/misc/brs/pkg-descr b/misc/brs/pkg-descr
index 5091ae830d9b..f0bccb458ecb 100644
--- a/misc/brs/pkg-descr
+++ b/misc/brs/pkg-descr
@@ -3,5 +3,3 @@ Authorized ("King James") Version of the Old and New Testaments, a set
of libraries for finding and retrieving text, and a program ("bible")
which uses the libraries to retrieve Bible passages given references
on the command line or from standard input.
-
-WWW: http://bible.theverge.com/brs.html
diff --git a/misc/brs/pkg-plist b/misc/brs/pkg-plist
index d127cd53958d..ffc52d4e6165 100644
--- a/misc/brs/pkg-plist
+++ b/misc/brs/pkg-plist
@@ -1,3 +1,5 @@
bin/bible
-lib/bible.data
-lib/bible.data.conc
+share/brs/bible.data
+share/brs/bible.data.conc
+
+@dirrm share/brs