aboutsummaryrefslogtreecommitdiff
path: root/misc/buffer/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-12-13 17:33:18 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-12-13 17:33:18 +0000
commitfae54139e3ac8b6689c7ba0af8b13e278351a4de (patch)
treee9104eb67a7a3a3eb0c14692c15c43cc9ce9f88f /misc/buffer/Makefile
parentebaf56d84b4cc50fd005689a8c5bdb008cc1df27 (diff)
downloadports-fae54139e3ac8b6689c7ba0af8b13e278351a4de.tar.gz
ports-fae54139e3ac8b6689c7ba0af8b13e278351a4de.zip
Notes
Diffstat (limited to 'misc/buffer/Makefile')
-rw-r--r--misc/buffer/Makefile20
1 files changed, 15 insertions, 5 deletions
diff --git a/misc/buffer/Makefile b/misc/buffer/Makefile
index 9eafc6832a9f..c006aed408d5 100644
--- a/misc/buffer/Makefile
+++ b/misc/buffer/Makefile
@@ -6,17 +6,27 @@
#
PORTNAME= buffer
-PORTVERSION= 1.17.1
+PORTVERSION= 1.19
CATEGORIES= misc
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= steve
+MASTER_SITES= ${MASTER_SITE_GENTOO} \
+ http://www.mondorescue.org/download/MondoCD/TGZS/
+MASTER_SITE_SUBDIR= distfiles
+EXTRACT_SUFX= .tgz
MAINTAINER= jonny@jonny.eng.br
COMMENT= Buffer sporadic I/O for faster tape and pipe throughput
-USE_BZIP2= yes
-NO_WRKSUBDIR= yes
+USE_REINPLACE= yes
+
MAN1= buffer.1
PLIST_FILES= bin/buffer
+post-patch:
+ @${REINPLACE_CMD} -E \
+ -e 's|^(CC[[:space:]]*=).*$$|\1${CC}|' \
+ -e 's|^(CFLAGS[[:space:]]*=).*$$|\1${CFLAGS}|' \
+ -e 's|^(INSTBIN[[:space:]]*=).*$$|\1${PREFIX}/bin|' \
+ -e 's|^(INSTMAN[[:space:]]*=).*$$|\1${MAN1PREFIX}/man/man1|' \
+ ${WRKSRC}/Makefile
+
.include <bsd.port.mk>