aboutsummaryrefslogtreecommitdiff
path: root/misc/cave/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-30 19:24:46 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-30 19:24:46 +0000
commit1c39d223b7d6d9230f3b10bcc55dffff6431035a (patch)
tree0c325fad59ae4039317262cf64833eac5399b70d /misc/cave/Makefile
parent2c0a6c05c4e40baedd3476e050485b0f3ea1cc99 (diff)
downloadports-1c39d223b7d6d9230f3b10bcc55dffff6431035a.tar.gz
ports-1c39d223b7d6d9230f3b10bcc55dffff6431035a.zip
Notes
Diffstat (limited to 'misc/cave/Makefile')
-rw-r--r--misc/cave/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/misc/cave/Makefile b/misc/cave/Makefile
new file mode 100644
index 000000000000..6ca3a6ed90c4
--- /dev/null
+++ b/misc/cave/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# Ports collection makefile for: cave
+# Date created: Dec 30, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= cave
+PORTVERSION= 0.3
+CATEGORIES= misc
+MASTER_SITES= http://m-net.arbornet.org/~bjk/cave/download/
+
+MAINTAINER= ports@FreeBSD.org
+
+MAN1= cave.1
+
+post-patch:
+ @${PERL} -pi -e "s,^CC,#CC,g ; s,^CFLAGS,#CFLAGS,g" ${WRKSRC}/Makefile
+
+pre-install:
+ @${GZIP_CMD} -d ${WRKSRC}/${MAN1}.gz
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>