aboutsummaryrefslogtreecommitdiff
path: root/misc/compat4x
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-08-13 04:32:06 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-08-13 04:32:06 +0000
commit1ebdec8e3d910496e4fd9b4965e4467698777174 (patch)
tree06f62b7b9e9c68c3d3269b851c8f1acdb200d635 /misc/compat4x
parent19c9cd5c8e9eed083a22e90db5abbaff80e468dd (diff)
downloadports-1ebdec8e3d910496e4fd9b4965e4467698777174.tar.gz
ports-1ebdec8e3d910496e4fd9b4965e4467698777174.zip
Notes
Diffstat (limited to 'misc/compat4x')
-rw-r--r--misc/compat4x/Makefile71
-rw-r--r--misc/compat4x/distinfo13
-rw-r--r--misc/compat4x/pkg-comment1
-rw-r--r--misc/compat4x/pkg-descr2
-rw-r--r--misc/compat4x/pkg-plist6
5 files changed, 93 insertions, 0 deletions
diff --git a/misc/compat4x/Makefile b/misc/compat4x/Makefile
new file mode 100644
index 000000000000..a3cbe289b938
--- /dev/null
+++ b/misc/compat4x/Makefile
@@ -0,0 +1,71 @@
+# New ports collection makefile for: compat4x libraries
+# Date created: 01 Aug 2001
+# Whom: Scot W. Hetzel
+#
+# $FreeBSD$
+#
+
+PORTNAME= compat4x
+PORTVERSION= ${COMPAT4X_PORTVERSION}
+CATEGORIES= misc
+MASTER_SITES= ${COMPAT4X_MASTER_SITES}
+PKGNAMESUFFIX= -${ARCH}
+DISTFILES= ${COMPAT4X_DISTFILES}
+DIST_SUBDIR= ${ARCH}/${PORTVERSION}
+
+MAINTAINER= hetzels@westbend.net
+
+PREFIX?= /usr
+
+WRKSRC= ${WRKDIR}/usr/lib/compat
+NO_MTREE= yes
+NO_BUILD= yes
+
+TARGET_DIR= ${PREFIX}/lib/compat
+
+INSTALLS_SHLIB= yes
+LDCONFIG_DIRS= %%PREFIX%%/lib/compat
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500000
+COMPAT4X_PORTVERSION= 5.0
+COMPAT4X_MASTER_SITES= ftp://current.FreeBSD.org/pub/FreeBSD/%SUBDIR%/
+.if ${ARCH} == i386
+MASTER_SITE_SUBDIR= snapshots/${ARCH}/${PORTVERSION}-20010618-CURRENT/${PORTNAME}
+COMPAT4X_DISTFILES= ${PORTNAME}.aa \
+ ${PORTNAME}.ab \
+ ${PORTNAME}.ac \
+ ${PORTNAME}.ad
+.elif ${ARCH} == alpha
+MASTER_SITE_SUBDIR= snapshots/${ARCH}/${PORTVERSION}-20010721-CURRENT/${PORTNAME}
+COMPAT4X_DISTFILES= ${PORTNAME}.aa \
+ ${PORTNAME}.ab \
+ ${PORTNAME}.ac \
+ ${PORTNAME}.ad \
+ ${PORTNAME}.ae
+.endif
+PLIST_SUB= CURRENT_ONLY:=""
+.else
+COMPAT4X_PORTVERSION= 4.3
+COMPAT4X_MASTER_SITES= ${MASTER_SITE_FREEBSD_ORG}
+MASTER_SITE_SUBDIR= releases/${ARCH}/${PORTVERSION}-RELEASE/${PORTNAME}
+COMPAT4X_DISTFILES= ${PORTNAME}.aa \
+ ${PORTNAME}.ab
+PLIST_SUB= CURRENT_ONLY:="@comment "
+.endif
+
+do-extract:
+ ${MKDIR} ${WRKDIR}
+ cd ${_DISTDIR} && ${CAT} ${DISTFILES} | ${TAR} -xzf - -C ${WRKDIR}
+.if ${OSVERSION} >= 500000
+ ${MV} ${WRKSRC}/libc_r.so.4 ${WRKSRC}/libc_r.so.4.compat4x
+.endif
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/* ${TARGET_DIR}/
+.if ${OSVERSION} >= 500000
+ ${LN} -sf ${TARGET_DIR}/libc_r.so.4.compat4x ${TARGET_DIR}/libc_r.so.4
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/misc/compat4x/distinfo b/misc/compat4x/distinfo
new file mode 100644
index 000000000000..b85c770f033d
--- /dev/null
+++ b/misc/compat4x/distinfo
@@ -0,0 +1,13 @@
+MD5 (alpha/4.3/compat4x.aa) = 0b08beae12dc0c5208c29b6ee68d914d
+MD5 (alpha/4.3/compat4x.ab) = 3e99d2e35c9705dbedef096ed12fe7b3
+MD5 (alpha/5.0/compat4x.aa) = 5c052f279d18b7a2d68ef9eb5b1f1505
+MD5 (alpha/5.0/compat4x.ab) = a86f387a12a0dba266b1eecdd2fd91eb
+MD5 (alpha/5.0/compat4x.ac) = 9cc91bf7f1a9d255f575ab538c3a15b4
+MD5 (alpha/5.0/compat4x.ad) = eb2681b993cc8829e1e947f00f5a5394
+MD5 (alpha/5.0/compat4x.ae) = 0df08287196d13eef071ec6ff12a3768
+MD5 (i386/4.3/compat4x.aa) = 8087f85456553dbc90b35b5b7a9895ed
+MD5 (i386/4.3/compat4x.ab) = a25bf5d6a9ddf9ae42e9a68385860661
+MD5 (i386/5.0/compat4x.aa) = 5ee249c0b58886e35738f3a3ea0c4efd
+MD5 (i386/5.0/compat4x.ab) = ddf578a4b8ca91fb5adf44ad09c37032
+MD5 (i386/5.0/compat4x.ac) = 524b995bc36f70fef378d29db0294118
+MD5 (i386/5.0/compat4x.ad) = b32e9498ceec34c2100332e35d5bd61f
diff --git a/misc/compat4x/pkg-comment b/misc/compat4x/pkg-comment
new file mode 100644
index 000000000000..829f29a62e1c
--- /dev/null
+++ b/misc/compat4x/pkg-comment
@@ -0,0 +1 @@
+A convenience package to install the compat4x libraries
diff --git a/misc/compat4x/pkg-descr b/misc/compat4x/pkg-descr
new file mode 100644
index 000000000000..5f6826914af9
--- /dev/null
+++ b/misc/compat4x/pkg-descr
@@ -0,0 +1,2 @@
+This package allows you to install the compat4x libraries on your
+system, so you can use legacy binaries that depend on them.
diff --git a/misc/compat4x/pkg-plist b/misc/compat4x/pkg-plist
new file mode 100644
index 000000000000..e5f6e048bfef
--- /dev/null
+++ b/misc/compat4x/pkg-plist
@@ -0,0 +1,6 @@
+%%CURRENT_ONLY:%%lib/compat/libc.so.4
+%%CURRENT_ONLY:%%@unexec if [ -e %B/libc_r.so.4.compat3x ]; then ln -sf %B/libc_r.so.4.compat3x %B/libc_r.so.4; else rm %B/libc_r.so.4; fi
+%%CURRENT_ONLY:%%lib/compat/libc_r.so.4.compat4x
+%%CURRENT_ONLY:%%@exec ln -sf %B/%f %B/libc_r.so.4
+lib/compat/libcrypto.so.1
+lib/compat/libssl.so.1