aboutsummaryrefslogtreecommitdiff
path: root/misc/compat6x
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2009-08-27 15:48:59 +0000
committerRenato Botelho <garga@FreeBSD.org>2009-08-27 15:48:59 +0000
commit42f56a1128defa66d4d427e680d2f2bf15424b1d (patch)
tree791f7a90e67c0de2ae8539d3deb890d854db1460 /misc/compat6x
parentb267fcde3baa5333cd65314ebbe0c938cc221c06 (diff)
When installing on 8.x (>= 800105), don't install libpthread.so.2 but create a
symlink to /usr/lib/libpthr.so Discussed with: jhb Approved by: mnag (maintainer)
Notes
Notes: svn path=/head/; revision=240412
Diffstat (limited to 'misc/compat6x')
-rw-r--r--misc/compat6x/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/misc/compat6x/Makefile b/misc/compat6x/Makefile
index e24051342eb7..0fa87e50c0d7 100644
--- a/misc/compat6x/Makefile
+++ b/misc/compat6x/Makefile
@@ -7,6 +7,7 @@
PORTNAME= compat6x
PORTVERSION= 6.4.604000.200810
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_LOCAL} \
http://people.freebsd.org/~${MASTER_SITE_SUBDIR}/
@@ -38,9 +39,17 @@ USE_LDCONFIG32= ${TARGET32_DIR}
do-install:
@${MKDIR} ${TARGET_DIR}
+.if ${OSVERSION} >= 800105
+ ${RM} -f ${WRKSRC}/libpthread.so.2
+ (cd ${TARGET_DIR} && ${LN} -s /usr/lib/libpthr.so ./libpthread.so.2)
+.endif
(cd ${WRKSRC}/lib && ${INSTALL_DATA} *.so.* ${TARGET_DIR})
.if ${ARCH} == amd64
@${MKDIR} ${TARGET32_DIR}
+. if ${OSVERSION} >= 800105
+ ${RM} -f ${WRKSRC}/lib32/libpthread.so.2
+ (cd ${TARGET32_DIR} && ${LN} -s /usr/lib32/libpthr.so ./libpthread.so.2)
+. endif
(cd ${WRKSRC}/lib32 && ${INSTALL_DATA} *.so.* ${TARGET32_DIR})
.endif