aboutsummaryrefslogtreecommitdiff
path: root/misc/countrycodes/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-07-24 19:42:03 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-07-24 19:42:03 +0000
commit24d34901c997ba6491887730acc151241f3f4e8c (patch)
treeb19e86ad0a187584a00e585b6faa948958362bf4 /misc/countrycodes/Makefile
parent84849899478f6acf938643c6bcde360c988ffd28 (diff)
Notes
Diffstat (limited to 'misc/countrycodes/Makefile')
-rw-r--r--misc/countrycodes/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/misc/countrycodes/Makefile b/misc/countrycodes/Makefile
new file mode 100644
index 000000000000..a9f6ed4755e2
--- /dev/null
+++ b/misc/countrycodes/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: countrycodes
+# Date created: 6 Jul 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= countrycodes
+PORTVERSION= 1.0.5
+CATEGORIES= misc
+MASTER_SITES= http://www.grigna.com/diego/linux/countrycodes/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= An ISO 3166 country code finder
+
+BUILD_WRKSRC= ${WRKSRC}/src
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+PLIST_FILES= bin/iso3166
+PORTDOCS= README
+MAN1= iso3166.1
+MAKE_ARGS= prefix="${PREFIX}" CC="${CC}" CCOPTS="${CFLAGS}" WARNINGS=""
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>