aboutsummaryrefslogtreecommitdiff
path: root/misc/countrycodes
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-07-24 19:42:03 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-07-24 19:42:03 +0000
commit24d34901c997ba6491887730acc151241f3f4e8c (patch)
treeb19e86ad0a187584a00e585b6faa948958362bf4 /misc/countrycodes
parent84849899478f6acf938643c6bcde360c988ffd28 (diff)
Notes
Diffstat (limited to 'misc/countrycodes')
-rw-r--r--misc/countrycodes/Makefile30
-rw-r--r--misc/countrycodes/distinfo2
-rw-r--r--misc/countrycodes/files/patch-src_Makefile32
-rw-r--r--misc/countrycodes/pkg-descr8
4 files changed, 72 insertions, 0 deletions
diff --git a/misc/countrycodes/Makefile b/misc/countrycodes/Makefile
new file mode 100644
index 000000000000..a9f6ed4755e2
--- /dev/null
+++ b/misc/countrycodes/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: countrycodes
+# Date created: 6 Jul 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= countrycodes
+PORTVERSION= 1.0.5
+CATEGORIES= misc
+MASTER_SITES= http://www.grigna.com/diego/linux/countrycodes/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= An ISO 3166 country code finder
+
+BUILD_WRKSRC= ${WRKSRC}/src
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+PLIST_FILES= bin/iso3166
+PORTDOCS= README
+MAN1= iso3166.1
+MAKE_ARGS= prefix="${PREFIX}" CC="${CC}" CCOPTS="${CFLAGS}" WARNINGS=""
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/misc/countrycodes/distinfo b/misc/countrycodes/distinfo
new file mode 100644
index 000000000000..a9a62b851116
--- /dev/null
+++ b/misc/countrycodes/distinfo
@@ -0,0 +1,2 @@
+MD5 (countrycodes-1.0.5.tar.gz) = 9decb29be88236791fcb3f036095c018
+SIZE (countrycodes-1.0.5.tar.gz) = 18621
diff --git a/misc/countrycodes/files/patch-src_Makefile b/misc/countrycodes/files/patch-src_Makefile
new file mode 100644
index 000000000000..a380c7705775
--- /dev/null
+++ b/misc/countrycodes/files/patch-src_Makefile
@@ -0,0 +1,32 @@
+--- src/Makefile.orig Sat Feb 1 16:56:08 2003
++++ src/Makefile Sun Jul 24 21:39:05 2005
+@@ -58,11 +58,14 @@
+
+ PROGRAM = iso3166
+
+-all: $(PROGRAM)
++all: $(PROGRAM) iso3166.1
+
+ $(PROGRAM): $(ISO3166OBJ)
+ $(CC) $(CCOPTS) $(ISO3166OBJ) -o $@
+
++iso3166.1: ${docdir}/iso3166.1.in
++ @$(SEDBIN) $(SEDCMDS) $> > $@
++
+ clean:
+ rm -f $(ISO3166OBJ) core defines.h $(PROGRAM)
+
+@@ -70,11 +73,8 @@
+ strip $(PROGRAM)
+
+ install:
+- $(INSTALL) -g root -m $(BINMODE) -o root -s ${srcdir}/$(PROGRAM) ${bindir}
+- @echo "Installing man page..."
+- @$(SEDBIN) $(SEDCMDS) ${docdir}/iso3166.1.in > ${mandir}/iso3166.1
+- @chown 0.0 ${mandir}/iso3166.1
+- @echo
++ $(BSD_INSTALL_PROGRAM) ${srcdir}/$(PROGRAM) ${bindir}
++ $(BSD_INSTALL_MAN) iso3166.1 ${mandir}
+
+ uninstall:
+ rm -f ${bindir}/$(PROGRAM)
diff --git a/misc/countrycodes/pkg-descr b/misc/countrycodes/pkg-descr
new file mode 100644
index 000000000000..ba47f9a6f2e1
--- /dev/null
+++ b/misc/countrycodes/pkg-descr
@@ -0,0 +1,8 @@
+Countrycodes is an ISO 3166 country code finder. It is mainly used to know
+the country a domain name belongs to. It also allows searching by 2 or 3
+letters codes, country number and country name.
+
+WWW: http://www.grigna.com/diego/linux/countrycodes/
+
+- ehaupt
+ehaupt@critical.ch