aboutsummaryrefslogtreecommitdiff
path: root/misc/cs
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-09-07 08:55:47 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-09-07 08:55:47 +0000
commit8eb611f997fffcdaba8b5a60d801fa208936108e (patch)
tree1212bc3738f490e46a0690213004c44741b1d550 /misc/cs
parent5e3557638e10a5ee61bb81f3e3f8589516a14251 (diff)
downloadports-8eb611f997fffcdaba8b5a60d801fa208936108e.tar.gz
ports-8eb611f997fffcdaba8b5a60d801fa208936108e.zip
Notes
Diffstat (limited to 'misc/cs')
-rw-r--r--misc/cs/Makefile34
-rw-r--r--misc/cs/distinfo2
-rw-r--r--misc/cs/pkg-descr3
3 files changed, 39 insertions, 0 deletions
diff --git a/misc/cs/Makefile b/misc/cs/Makefile
new file mode 100644
index 000000000000..f116362a3abd
--- /dev/null
+++ b/misc/cs/Makefile
@@ -0,0 +1,34 @@
+# ex:ts=8
+# Ports collection makefile for: cs
+# Date created: Jun 30, 2005
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= cs
+PORTVERSION= 0.9.5
+CATEGORIES= misc
+MASTER_SITES= http://njhurst.org/programming/cross-stitch/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= pav
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= pav@FreeBSD.org
+COMMENT= Cross Stitch software
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/PIL/Image.py:${PORTSDIR}/graphics/py-imaging
+
+USE_REINPLACE= yes
+USE_PYTHON= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/xs
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,/usr/bin/python,${SETENV} python," ${WRKSRC}/xs.py
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/xs.py ${PREFIX}/bin/xs
+
+.include <bsd.port.mk>
diff --git a/misc/cs/distinfo b/misc/cs/distinfo
new file mode 100644
index 000000000000..be5504fbc52b
--- /dev/null
+++ b/misc/cs/distinfo
@@ -0,0 +1,2 @@
+MD5 (cs-0.9.5.tgz) = f21ab196fd1ba9b997a0b3ed42178793
+SIZE (cs-0.9.5.tgz) = 73206
diff --git a/misc/cs/pkg-descr b/misc/cs/pkg-descr
new file mode 100644
index 000000000000..788bcd6557d6
--- /dev/null
+++ b/misc/cs/pkg-descr
@@ -0,0 +1,3 @@
+Cross Stitch software.
+
+WWW: http://njhurst.org/programming/cross-stitch/