aboutsummaryrefslogtreecommitdiff
path: root/misc/cwish
diff options
context:
space:
mode:
authorMichael Haro <mharo@FreeBSD.org>1999-04-18 23:15:11 +0000
committerMichael Haro <mharo@FreeBSD.org>1999-04-18 23:15:11 +0000
commit3ca49d9d8b4d367d269d3975bc99df6b9ca265c7 (patch)
tree4476d14cdd8ff6ec7dd3a61f36304ec1e23bcfbd /misc/cwish
parent14ab1fad9ba7bca16832682db96ae37b5c60e974 (diff)
downloadports-3ca49d9d8b4d367d269d3975bc99df6b9ca265c7.tar.gz
ports-3ca49d9d8b4d367d269d3975bc99df6b9ca265c7.zip
fix so it isn't BROKEN
Reviewed by: obrien Obtained from: bento.freebsd.org
Notes
Notes: svn path=/head/; revision=17982
Diffstat (limited to 'misc/cwish')
-rw-r--r--misc/cwish/Makefile12
-rw-r--r--misc/cwish/files/patch-0314
2 files changed, 17 insertions, 9 deletions
diff --git a/misc/cwish/Makefile b/misc/cwish/Makefile
index 5d78f7d0d436..0999e7da0b98 100644
--- a/misc/cwish/Makefile
+++ b/misc/cwish/Makefile
@@ -4,7 +4,7 @@
# Date created: Thur Sept 25, 1998
# Whom: David O'Brien (obrien@NUXI.com)
#
-# $Id: Makefile,v 1.1.1.1 1998/09/25 10:57:57 obrien Exp $
+# $Id: Makefile,v 1.2 1998/11/11 05:37:27 asami Exp $
#
DISTNAME= cwish
@@ -15,15 +15,9 @@ MASTER_SITES= http://www.hcs.de/users/hm/packages/
MAINTAINER= obrien@FreeBSD.org
NO_WRKSUBDIR= yes
-ALL_TARGET= #emtpy
+ALL_TARGET= cwish
MAN1= cwish.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 300000
-BROKEN= "headers problem"
-.endif
-
pre-configure:
${CP} ${WRKSRC}/Makefile.freebsd ${WRKSRC}/Makefile
@@ -31,4 +25,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/cwish ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/cwish.1 ${PREFIX}/man/man1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/misc/cwish/files/patch-03 b/misc/cwish/files/patch-03
new file mode 100644
index 000000000000..81c6c71d64af
--- /dev/null
+++ b/misc/cwish/files/patch-03
@@ -0,0 +1,14 @@
+--- files.c.orig Sun Apr 18 14:16:10 1999
++++ files.c Sun Apr 18 14:17:43 1999
+@@ -45,6 +45,11 @@
+
+ #include "cwish.h" /* global include file */
+
++#ifdef __FreeBSD__
++#include <sys/disklabel.h>
++#define MOUNT_CD9660 FS_ISO9660
++#endif
++
+ #ifdef ultrix
+
+ #include <sys/fs_types.h>