aboutsummaryrefslogtreecommitdiff
path: root/misc/detachtty/Makefile
diff options
context:
space:
mode:
authorFoxfair Hu <foxfair@FreeBSD.org>2003-09-07 00:14:04 +0000
committerFoxfair Hu <foxfair@FreeBSD.org>2003-09-07 00:14:04 +0000
commita1327ebdc5f2dec724e9a2caac668552cb829574 (patch)
tree12097e6a812799cd594d09d6c0d69939049c16f5 /misc/detachtty/Makefile
parent061bee5cf88a54646e6abc3551a5432885038846 (diff)
Add detachtty 6, run interactive programs non-interactively.
PR: 50303 Submitted by: Johannes Groedem <johs@copyleft.no>
Notes
Notes: svn path=/head/; revision=88656
Diffstat (limited to 'misc/detachtty/Makefile')
-rw-r--r--misc/detachtty/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/misc/detachtty/Makefile b/misc/detachtty/Makefile
new file mode 100644
index 000000000000..c0416011f346
--- /dev/null
+++ b/misc/detachtty/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: detachtty
+# Date created: 25 March 2003
+# Whom: johs
+#
+# $FreeBSD$
+#
+
+PORTNAME= detachtty
+PORTVERSION= 6
+CATEGORIES= misc
+MASTER_SITES= ftp://ftp.linux.org.uk/pub/lisp/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= johs@copyleft.no
+COMMENT= Run interactive programs non-interactively
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_GMAKE= yes
+
+MAN1= detachtty.1
+MLINKS= detachtty.1 attachtty.1
+MANCOMPRESSED= no
+
+post-install:
+.if !defined(NO_INSTALL_MANPAGES)
+ ${INSTALL_MAN} ${WRKSRC}/detachtty.1 ${MANPREFIX}/man/man1
+.endif
+
+.include <bsd.port.mk>