aboutsummaryrefslogtreecommitdiff
path: root/misc/diction/files
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-12-19 08:17:41 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-12-19 08:17:41 +0000
commita4b7ce27a19eddd5ad7c856fef65fc8ded6185f5 (patch)
tree4726ce58f3c339bc4451521f36521e4dae19edd9 /misc/diction/files
parent6d4b5c5dada1b0360cfbd1141faa842cf7740a71 (diff)
downloadports-a4b7ce27a19eddd5ad7c856fef65fc8ded6185f5.tar.gz
ports-a4b7ce27a19eddd5ad7c856fef65fc8ded6185f5.zip
Notes
Diffstat (limited to 'misc/diction/files')
-rw-r--r--misc/diction/files/patch-aa53
-rw-r--r--misc/diction/files/patch-ab14
2 files changed, 50 insertions, 17 deletions
diff --git a/misc/diction/files/patch-aa b/misc/diction/files/patch-aa
index eaee92934c82..f3481e1c8052 100644
--- a/misc/diction/files/patch-aa
+++ b/misc/diction/files/patch-aa
@@ -1,20 +1,39 @@
---- Makefile.in.orig Tue Aug 4 12:55:19 1998
-+++ Makefile.in Tue Aug 4 12:55:52 1998
-@@ -29,14 +29,14 @@
- sed -e s+/usr/share+$(SHAREDIR)+ diction.1.in >$@
+--- Makefile.in.orig Tue May 16 03:10:04 2000
++++ Makefile.in Tue Dec 19 00:32:28 2000
+@@ -3,6 +3,10 @@
+ prefix= @prefix@
+ exec_prefix= @exec_prefix@
+
++INSTALL= @INSTALL@
++INSTALL_PROGRAM= @INSTALL_PROGRAM@
++INSTALL_DATA= @INSTALL_DATA@
++
+ CC= @CC@
+ CFLAGS= @CFLAGS@
+ CPPFLAGS= @CPPFLAGS@ -DSHAREDIR=\"@datadir@\"
+@@ -20,16 +24,16 @@
+ getopt.o getopt1.o $(LIBM) $(LIBS)
install: all
-- $(INSTALL) -m 755 -d $(BINDIR)
-+ $(MKDIR) $(BINDIR)
- $(INSTALL_PROGRAM) -s diction $(BINDIR)/diction
- $(INSTALL_PROGRAM) -s style $(BINDIR)/style
-- $(INSTALL) -m 755 -d $(SHAREDIR)/diction
-+ $(MKDIR) $(SHAREDIR)/diction
- $(INSTALL_DATA) de $(SHAREDIR)/diction/de
- $(INSTALL_DATA) en $(SHAREDIR)/diction/en
- (cd $(SHAREDIR)/diction; rm -f C; ln en C)
-- $(INSTALL) -m 755 -d $(MANDIR)/man1
-+ $(MKDIR) $(MANDIR)/man1
- $(INSTALL_DATA) diction.1 $(MANDIR)/man1/diction.1
- $(INSTALL_DATA) style.1 $(MANDIR)/man1/style.1
+- @INSTALL@ -m 755 -d @bindir@
+- @INSTALL@ diction @bindir@/diction
+- @INSTALL@ style @bindir@/style
+- @INSTALL@ -m 755 -d @datadir@/diction
+- @INSTALL@ -m 644 de @datadir@/diction/de
+- @INSTALL@ -m 644 en @datadir@/diction/en
++ -mkdir -p @bindir@
++ $(INSTALL_PROGRAM) diction @bindir@/diction
++ $(INSTALL_PROGRAM) style @bindir@/style
++ -mkdir -p @datadir@/diction
++ $(INSTALL_DATA) de @datadir@/diction/de
++ $(INSTALL_DATA) en @datadir@/diction/en
+ (cd @datadir@/diction; rm -f C; ln en C)
+- @INSTALL@ -m 755 -d @mandir@/man1
+- @INSTALL@ -m 644 diction.1 @mandir@/man1/diction.1
+- @INSTALL@ -m 644 style.1 @mandir@/man1/style.1
++ -mkdir -p @mandir@/man1
++ $(INSTALL_DATA) diction.1 @mandir@/man1/diction.1
++ $(INSTALL_DATA) style.1 @mandir@/man1/style.1
+ install.msg:
+ gencat -o @datadir@/locale/en_US/LC_MESSAGES/diction.cat diction-en.msg sent-en.msg
diff --git a/misc/diction/files/patch-ab b/misc/diction/files/patch-ab
new file mode 100644
index 000000000000..79f686fdbee5
--- /dev/null
+++ b/misc/diction/files/patch-ab
@@ -0,0 +1,14 @@
+--- configure.in.orig Tue May 16 03:08:09 2000
++++ configure.in Tue Dec 19 00:26:35 2000
+@@ -19,11 +19,6 @@
+ fi
+
+ AC_PROG_CC
+-if test "$GCC" = yes
+-then
+- CFLAGS="${CFLAGS} ${PIPE}-Wmissing-prototypes -Wstrict-prototypes -Wcast-qual -Wpointer-arith -Wcast-align -Wwrite-strings -Wmissing-declarations -Wnested-externs -pedantic -fno-common"
+- LDFLAGS='-g'
+-fi
+
+ AC_PROG_INSTALL
+ AC_CHECK_FUNCS(strerror)