aboutsummaryrefslogtreecommitdiff
path: root/misc/diction
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-12-19 08:17:41 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-12-19 08:17:41 +0000
commita4b7ce27a19eddd5ad7c856fef65fc8ded6185f5 (patch)
tree4726ce58f3c339bc4451521f36521e4dae19edd9 /misc/diction
parent6d4b5c5dada1b0360cfbd1141faa842cf7740a71 (diff)
downloadports-a4b7ce27a19eddd5ad7c856fef65fc8ded6185f5.tar.gz
ports-a4b7ce27a19eddd5ad7c856fef65fc8ded6185f5.zip
Notes
Diffstat (limited to 'misc/diction')
-rw-r--r--misc/diction/Makefile19
-rw-r--r--misc/diction/distinfo2
-rw-r--r--misc/diction/files/patch-aa53
-rw-r--r--misc/diction/files/patch-ab14
-rw-r--r--misc/diction/pkg-descr14
5 files changed, 66 insertions, 36 deletions
diff --git a/misc/diction/Makefile b/misc/diction/Makefile
index 3ae3dd9f9553..ca180242db51 100644
--- a/misc/diction/Makefile
+++ b/misc/diction/Makefile
@@ -1,22 +1,19 @@
-# New ports collection makefile for: diction
+# New ports collection makefile for: diction
# Date created: 2 August 1998
# Whom: J Han <hjh@best.com>
#
# $FreeBSD$
#
-PORTNAME= diction
-PORTVERSION= 0.8
-CATEGORIES= misc
-MASTER_SITES= ftp://cantor.informatik.rwth-aachen.de/pub/unix/
+PORTNAME= diction
+PORTVERSION= 0.9
+CATEGORIES= misc
+MASTER_SITES= http://www.moria.de/~michael/diction/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USE_AUTOCONF= yes
-MAKE_ENV= MKDIR="$(MKDIR)"
-
-MAN1= diction.1 style.1
+MAN1= diction.1 style.1
.include <bsd.port.mk>
diff --git a/misc/diction/distinfo b/misc/diction/distinfo
index 5632c6a5549b..0561b8995526 100644
--- a/misc/diction/distinfo
+++ b/misc/diction/distinfo
@@ -1 +1 @@
-MD5 (diction-0.8.tar.gz) = 0765745433bfa6bdc303db81acded9a1
+MD5 (diction-0.9.tar.gz) = 948e9c4b9001e8f06e6154231fbd06d7
diff --git a/misc/diction/files/patch-aa b/misc/diction/files/patch-aa
index eaee92934c82..f3481e1c8052 100644
--- a/misc/diction/files/patch-aa
+++ b/misc/diction/files/patch-aa
@@ -1,20 +1,39 @@
---- Makefile.in.orig Tue Aug 4 12:55:19 1998
-+++ Makefile.in Tue Aug 4 12:55:52 1998
-@@ -29,14 +29,14 @@
- sed -e s+/usr/share+$(SHAREDIR)+ diction.1.in >$@
+--- Makefile.in.orig Tue May 16 03:10:04 2000
++++ Makefile.in Tue Dec 19 00:32:28 2000
+@@ -3,6 +3,10 @@
+ prefix= @prefix@
+ exec_prefix= @exec_prefix@
+
++INSTALL= @INSTALL@
++INSTALL_PROGRAM= @INSTALL_PROGRAM@
++INSTALL_DATA= @INSTALL_DATA@
++
+ CC= @CC@
+ CFLAGS= @CFLAGS@
+ CPPFLAGS= @CPPFLAGS@ -DSHAREDIR=\"@datadir@\"
+@@ -20,16 +24,16 @@
+ getopt.o getopt1.o $(LIBM) $(LIBS)
install: all
-- $(INSTALL) -m 755 -d $(BINDIR)
-+ $(MKDIR) $(BINDIR)
- $(INSTALL_PROGRAM) -s diction $(BINDIR)/diction
- $(INSTALL_PROGRAM) -s style $(BINDIR)/style
-- $(INSTALL) -m 755 -d $(SHAREDIR)/diction
-+ $(MKDIR) $(SHAREDIR)/diction
- $(INSTALL_DATA) de $(SHAREDIR)/diction/de
- $(INSTALL_DATA) en $(SHAREDIR)/diction/en
- (cd $(SHAREDIR)/diction; rm -f C; ln en C)
-- $(INSTALL) -m 755 -d $(MANDIR)/man1
-+ $(MKDIR) $(MANDIR)/man1
- $(INSTALL_DATA) diction.1 $(MANDIR)/man1/diction.1
- $(INSTALL_DATA) style.1 $(MANDIR)/man1/style.1
+- @INSTALL@ -m 755 -d @bindir@
+- @INSTALL@ diction @bindir@/diction
+- @INSTALL@ style @bindir@/style
+- @INSTALL@ -m 755 -d @datadir@/diction
+- @INSTALL@ -m 644 de @datadir@/diction/de
+- @INSTALL@ -m 644 en @datadir@/diction/en
++ -mkdir -p @bindir@
++ $(INSTALL_PROGRAM) diction @bindir@/diction
++ $(INSTALL_PROGRAM) style @bindir@/style
++ -mkdir -p @datadir@/diction
++ $(INSTALL_DATA) de @datadir@/diction/de
++ $(INSTALL_DATA) en @datadir@/diction/en
+ (cd @datadir@/diction; rm -f C; ln en C)
+- @INSTALL@ -m 755 -d @mandir@/man1
+- @INSTALL@ -m 644 diction.1 @mandir@/man1/diction.1
+- @INSTALL@ -m 644 style.1 @mandir@/man1/style.1
++ -mkdir -p @mandir@/man1
++ $(INSTALL_DATA) diction.1 @mandir@/man1/diction.1
++ $(INSTALL_DATA) style.1 @mandir@/man1/style.1
+ install.msg:
+ gencat -o @datadir@/locale/en_US/LC_MESSAGES/diction.cat diction-en.msg sent-en.msg
diff --git a/misc/diction/files/patch-ab b/misc/diction/files/patch-ab
new file mode 100644
index 000000000000..79f686fdbee5
--- /dev/null
+++ b/misc/diction/files/patch-ab
@@ -0,0 +1,14 @@
+--- configure.in.orig Tue May 16 03:08:09 2000
++++ configure.in Tue Dec 19 00:26:35 2000
+@@ -19,11 +19,6 @@
+ fi
+
+ AC_PROG_CC
+-if test "$GCC" = yes
+-then
+- CFLAGS="${CFLAGS} ${PIPE}-Wmissing-prototypes -Wstrict-prototypes -Wcast-qual -Wpointer-arith -Wcast-align -Wwrite-strings -Wmissing-declarations -Wnested-externs -pedantic -fno-common"
+- LDFLAGS='-g'
+-fi
+
+ AC_PROG_INSTALL
+ AC_CHECK_FUNCS(strerror)
diff --git a/misc/diction/pkg-descr b/misc/diction/pkg-descr
index e3858ff69b12..0772b6f82609 100644
--- a/misc/diction/pkg-descr
+++ b/misc/diction/pkg-descr
@@ -1,17 +1,17 @@
-This is the snapshot release 0.6 beta of GNU diction and style, free
-implementations of old standard unix commands. For some reason,
-many modern systems lack them. Diction prints wordy and commonly
-misused phrases. Style analyses surface characteristics of a document,
-e.g. sentence length and various readability measures.
+This is the GNU diction and style, free implementations of old standard
+unix commands. For some reason, many modern systems lack them. Diction
+prints wordy and commonly misused phrases. Style analyses surface
+characteristics of a document, e.g. sentence length and various
+readability measures.
Both commands support English and German documents.
--
-WWW: http://www.fsf.org/software/diction/diction.html
+WWW: http://www.gnu.org/software/diction/diction.html
GNU style and diction are written by Michael Haardt
-http://cantor.informatik.rwth-aachen.de/~michael/
+http://www.moria.de/~michael/
--
J Han <hjh@best.com>