aboutsummaryrefslogtreecommitdiff
path: root/misc/display
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2005-10-20 13:10:28 +0000
committerPeter Pentchev <roam@FreeBSD.org>2005-10-20 13:10:28 +0000
commitfb1782653240a3eac709e8315e7f7789038897ec (patch)
treebd7d249f00493c640a071d76f70e808f39954c86 /misc/display
parent6a1b0bc65a628631d2ab0104c356f95ed216127f (diff)
downloadports-fb1782653240a3eac709e8315e7f7789038897ec.tar.gz
ports-fb1782653240a3eac709e8315e7f7789038897ec.zip
Notes
Diffstat (limited to 'misc/display')
-rw-r--r--misc/display/Makefile23
1 files changed, 17 insertions, 6 deletions
diff --git a/misc/display/Makefile b/misc/display/Makefile
index 8c33e0352364..5d9637711156 100644
--- a/misc/display/Makefile
+++ b/misc/display/Makefile
@@ -7,7 +7,7 @@
PORTNAME= display
PORTVERSION= 1.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc
MASTER_SITES= http://www.ipsmart.com/src/
EXTRACT_SUFX= .tgz
@@ -15,15 +15,26 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Runs command repeatedly; shows output
+GNU_CONFIGURE= yes
+
+DISPLAY_PROGRAM_PREFIX?=
+
+.if empty(DISPLAY_PROGRAM_PREFIX)
+pre-everything::
+ @${ECHO_MSG} "NOTE: You may set DISPLAY_PROGRAM_PREFIX to change the name of the 'display'"
+ @${ECHO_MSG} "utility so that it does not conflict with similarly named files from"
+ @${ECHO_MSG} "the ImageMagick and goblin ports."
+
CONFLICTS= ImageMagick-[0-9]* goblin-*
+.endif
-GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --program-prefix=${DISPLAY_PROGRAM_PREFIX}
-MAN1= display.1
-PLIST_FILES= bin/display
+MAN1= ${DISPLAY_PROGRAM_PREFIX}display.1
+PLIST_FILES= bin/${DISPLAY_PROGRAM_PREFIX}display
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/display ${PREFIX}/bin/display
- ${INSTALL_MAN} ${WRKSRC}/display.man ${MANPREFIX}/man/man1/display.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/display ${PREFIX}/bin/${DISPLAY_PROGRAM_PREFIX}display
+ ${INSTALL_MAN} ${WRKSRC}/display.man ${MANPREFIX}/man/man1/${DISPLAY_PROGRAM_PREFIX}display.1
.include <bsd.port.mk>