aboutsummaryrefslogtreecommitdiff
path: root/misc/dotfile/files
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-02-23 04:10:15 +0000
committerSteve Price <steve@FreeBSD.org>1998-02-23 04:10:15 +0000
commit79053065b7a723e8ec0f6c02e9c4db129c996a7a (patch)
tree44439c3d8e49f52b3380209783cbe60e8dbf46ea /misc/dotfile/files
parent85d9c74f37aad82707d5b80fc5631aa4e1ac63ed (diff)
downloadports-79053065b7a723e8ec0f6c02e9c4db129c996a7a.tar.gz
ports-79053065b7a723e8ec0f6c02e9c4db129c996a7a.zip
Notes
Diffstat (limited to 'misc/dotfile/files')
-rw-r--r--misc/dotfile/files/patch-aa85
-rw-r--r--misc/dotfile/files/patch-ab49
-rw-r--r--misc/dotfile/files/patch-ac19
-rw-r--r--misc/dotfile/files/patch-ad31
-rw-r--r--misc/dotfile/files/patch-ae14
5 files changed, 178 insertions, 20 deletions
diff --git a/misc/dotfile/files/patch-aa b/misc/dotfile/files/patch-aa
index 418b8761adf1..3fe5dab96909 100644
--- a/misc/dotfile/files/patch-aa
+++ b/misc/dotfile/files/patch-aa
@@ -1,20 +1,65 @@
---- configure.orig Fri Jan 31 08:09:10 1997
-+++ configure Sat Nov 22 15:25:48 1997
-@@ -399,7 +399,7 @@
-
-
-
--for ac_prog in wish4.2 wish4.1 wish4.0 wish
-+for ac_prog in wish8.0 wish4.2 wish4.1 wish4.0 wish
- do
- # Extract the first word of "$ac_prog", so it can be a program name with args.
- set dummy $ac_prog; ac_word=$2
-@@ -439,7 +439,7 @@
- { echo "configure: error: I couldn't find 'wish' please insert it into your path and try again" 1>&2; exit 1; }
- fi
-
--for ac_prog in tclsh7.6 tclsh7.5 tclsh7.4 tclsh
-+for ac_prog in tclsh8.0 tclsh7.6 tclsh7.5 tclsh7.4 tclsh
- do
- # Extract the first word of "$ac_prog", so it can be a program name with args.
- set dummy $ac_prog; ac_word=$2
+*** Makefile.in.orig Sun Dec 21 06:40:34 1997
+--- Makefile.in Sun Feb 22 11:07:08 1998
+***************
+*** 23,48 ****
+ SHELL = /bin/sh
+
+ ### Tell the user that there is nothing to be compiled.
+- .PHONY: nothing
+- nothing:
+- @echo ----------------------------------------------------------------------
+- @echo ----------------------------------------------------------------------
+- @echo "The Dotfile Generator does not contain any files which has to be compiled!"
+- @echo "On the other hand, during installation, all the modules need to be"
+- @echo "bytecompiled, so now it's time to type: make install"
+- @echo ----------------------------------------------------------------------
+- @echo ----------------------------------------------------------------------
+
+- #
+ # install all the files in the corect places.
+ #
+ .PHONY: install
+ install: copydirs bytecompile
+- @echo "**********************************************************************"
+- @echo In the directory Doc, three articles in HTML format, concerning
+- @echo The Dotfile Generator is located. If you want these to be installed
+- @echo on your system, please do it manually.
+- @echo "**********************************************************************"
+
+ .PHONY: copydirs
+ copydirs:
+--- 23,33 ----
+***************
+*** 58,64 ****
+ done
+ cp dotfile.1 $(mandir)
+ -@RM@ $(bindir)/dotfile
+! -@LN@ -s $(bindir)/dotfile-$(version) $(bindir)/dotfile
+ chmod 755 $(bindir)/dotfile
+ chmod 755 $(bindir)/dotfile-$(version)
+
+--- 43,49 ----
+ done
+ cp dotfile.1 $(mandir)
+ -@RM@ $(bindir)/dotfile
+! -@LN@ -s dotfile-$(version) $(bindir)/dotfile
+ chmod 755 $(bindir)/dotfile
+ chmod 755 $(bindir)/dotfile-$(version)
+
+***************
+*** 72,78 ****
+ fvwm1 fvwm2:
+ @echo "----------------------------------------------------------------------"
+ @echo " Byte compiling $@"
+! @if wish testwish; then \
+ @WISH@ $(libdir)/Generator/dotfile.tcl $(libdir)/Generator $(libdir)/$@ bytecompile; \
+ else \
+ echo "An error should be shown above!"; \
+--- 57,63 ----
+ fvwm1 fvwm2:
+ @echo "----------------------------------------------------------------------"
+ @echo " Byte compiling $@"
+! @if $(WISH) testwish; then \
+ @WISH@ $(libdir)/Generator/dotfile.tcl $(libdir)/Generator $(libdir)/$@ bytecompile; \
+ else \
+ echo "An error should be shown above!"; \
diff --git a/misc/dotfile/files/patch-ab b/misc/dotfile/files/patch-ab
new file mode 100644
index 000000000000..97ebeb2cbbf0
--- /dev/null
+++ b/misc/dotfile/files/patch-ab
@@ -0,0 +1,49 @@
+*** configure.in.orig Sun Dec 21 06:40:27 1997
+--- configure.in Sun Feb 22 09:55:53 1998
+***************
+*** 25,37 ****
+ dnl remove until the next comment line
+ dnl and rerun autoconf (or mail blackie@imada.ou.dk)
+
+- echo "######################################################################"
+- echo "######################################################################"
+- echo If the configure script does not work, then please report to
+- echo blackie@imada.ou.dk, and edit configure.in.
+- echo "######################################################################"
+- echo "######################################################################"
+-
+ AC_PATH_PROGS(WISHnew, wish8.0 wish4.2 wish4.1 wish4.0,no)
+ AC_PATH_PROGS(WISHnothing, wish, no)
+ if test "$WISHnew" != "no" -a "$WISHnothing" != "no"; then
+--- 25,30 ----
+***************
+*** 53,68 ****
+ AC_PATH_PROGS(WISH, wish8.0 wish4.2 wish4.1 wish4.0 wish, no)
+ if test "$WISH" = no; then
+ AC_MSG_ERROR(I couldn't find 'wish' please insert it into your path and try again)
+- else
+- echo "####################################################################"
+- echo "####################################################################"
+- echo " WARNING"
+- echo "You do not have a link from wish to \"$WISH\"."
+- echo "This means that the executable dotfile does not work, when you"
+- echo "upgrade wish! In this case edit \"dotfile\" !"
+- echo "####################################################################"
+- echo "####################################################################"
+- fi
+ fi
+ dnl ############################################################
+ dnl The dotfile generator require tclsh, if it can not be found
+--- 46,51 ----
+***************
+*** 134,142 ****
+ chmod 755 dotfile
+ chmod 755 Modules/fvwm2/fvwmrc_convert
+
+- echo ----------------------------------------------------------------------
+- echo ----------------------------------------------------------------------
+- echo please login to your mail host, go to the directory Modules/procmail
+- echo and run ./configure from there.
+- echo ----------------------------------------------------------------------
+- echo ----------------------------------------------------------------------
+--- 117,119 ----
diff --git a/misc/dotfile/files/patch-ac b/misc/dotfile/files/patch-ac
new file mode 100644
index 000000000000..f61e160deb84
--- /dev/null
+++ b/misc/dotfile/files/patch-ac
@@ -0,0 +1,19 @@
+*** Modules/procmail/configure.in.orig Sat Feb 21 15:20:04 1998
+--- Modules/procmail/configure.in Sat Feb 21 15:20:19 1998
+***************
+*** 13,19 ****
+ echo "----------------------------------------------------------------------"
+
+
+! AC_PATH_PROGS(TCLSH, tclsh7.6 tclsh7.5 tclsh7.4 tclsh, no)
+ if test "$TCLSH" = no; then
+ AC_MSG_ERROR(I couldn't find 'tclsh' please insert it into your pa
+ th and try again)
+--- 13,19 ----
+ echo "----------------------------------------------------------------------"
+
+
+! AC_PATH_PROGS(TCLSH, tclsh8.0 tclsh7.6 tclsh7.5 tclsh7.4 tclsh, no)
+ if test "$TCLSH" = no; then
+ AC_MSG_ERROR(I couldn't find 'tclsh' please insert it into your pa
+ th and try again)
diff --git a/misc/dotfile/files/patch-ad b/misc/dotfile/files/patch-ad
new file mode 100644
index 000000000000..eba86e8e2333
--- /dev/null
+++ b/misc/dotfile/files/patch-ad
@@ -0,0 +1,31 @@
+*** Modules/procmail/configure.orig Sun Dec 21 06:40:33 1997
+--- Modules/procmail/configure Sun Feb 22 18:11:20 1998
+***************
+*** 519,537 ****
+
+
+
+! echo "----------------------------------------------------------------------"
+! echo "----------------------------------------------------------------------"
+! echo "Please note that the configure script for procmail has to be run on"
+! echo "your mailhost! This is important, since the mailhost may have separate"
+! echo "file systems, and thus have other programs, than your current host!"
+! echo "If this is not your mail host, please rlogin to it and run"
+! echo "Modules/procmail/configure on it, or edit Modules/procmail/system.tcl"
+! echo "accordingly!"
+! echo "----------------------------------------------------------------------"
+! echo "----------------------------------------------------------------------"
+!
+!
+! for ac_prog in tclsh7.6 tclsh7.5 tclsh7.4 tclsh
+ do
+ # Extract the first word of "$ac_prog", so it can be a program name with args.
+ set dummy $ac_prog; ac_word=$2
+--- 519,525 ----
+
+
+
+! for ac_prog in tclsh8.0 tclsh7.6 tclsh7.5 tclsh7.4 tclsh
+ do
+ # Extract the first word of "$ac_prog", so it can be a program name with args.
+ set dummy $ac_prog; ac_word=$2
diff --git a/misc/dotfile/files/patch-ae b/misc/dotfile/files/patch-ae
new file mode 100644
index 000000000000..23c3700f67d8
--- /dev/null
+++ b/misc/dotfile/files/patch-ae
@@ -0,0 +1,14 @@
+*** configure.orig Sun Feb 22 10:05:56 1998
+--- configure Sun Feb 22 10:06:13 1998
+***************
+*** 1427,1435 ****
+ chmod 755 dotfile
+ chmod 755 Modules/fvwm2/fvwmrc_convert
+
+- echo ----------------------------------------------------------------------
+- echo ----------------------------------------------------------------------
+- echo please login to your mail host, go to the directory Modules/procmail
+- echo and run ./configure from there.
+- echo ----------------------------------------------------------------------
+- echo ----------------------------------------------------------------------
+--- 1427,1429 ----