aboutsummaryrefslogtreecommitdiff
path: root/misc/e2fsprogs-libuuid/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-07-16 21:41:38 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-07-16 21:41:38 +0000
commit194fc80cd2300ec6947eeb80a9d27935a791108f (patch)
tree44abc6d60661b0688c415a2b33bcc5aed8266a4f /misc/e2fsprogs-libuuid/Makefile
parentb906ced0b0141e504419fc9a0f38588539777637 (diff)
downloadports-194fc80cd2300ec6947eeb80a9d27935a791108f.tar.gz
ports-194fc80cd2300ec6947eeb80a9d27935a791108f.zip
Notes
Diffstat (limited to 'misc/e2fsprogs-libuuid/Makefile')
-rw-r--r--misc/e2fsprogs-libuuid/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/misc/e2fsprogs-libuuid/Makefile b/misc/e2fsprogs-libuuid/Makefile
index 2b1179ea698b..d99af0db816f 100644
--- a/misc/e2fsprogs-libuuid/Makefile
+++ b/misc/e2fsprogs-libuuid/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
#
-PORTREVISION= 1
+PORTREVISION= 0
CATEGORIES= misc devel
PKGNAMESUFFIX= -libuuid
@@ -18,6 +18,7 @@ CONFIGURE_ARGS= --enable-elf-shlibs
WITHOUT_NLS= yes
MASTERDIR= ${.CURDIR}/../../sysutils/e2fsprogs
MAKE_ARGS= LIB_SUBDIRS=lib/uuid
+USE_GMAKE= yes
USE_LDCONFIG= yes
ALL_TARGET= libs
INSTALL_TARGET= install install-shlibs
@@ -47,8 +48,8 @@ pre-build:
# failure to launch uuidd is fine (one might be running, or we may lack
# privileges); if it works, it'll quit after 50 seconds
post-build:
- cd ${WRKSRC}/misc && ${MAKE} uuidgen uuidgen.1 uuidd uuidd.8
- ( ulimit -t 5 ; cd ${INSTALL_WRKSRC} && { ../../misc/uuidd -T50 || true ; ${MAKE} check ; } )
+ cd ${WRKSRC}/misc && ${GMAKE} uuidgen uuidgen.1 uuidd uuidd.8
+ cd ${INSTALL_WRKSRC} && ( ulimit -t 5 && ${GMAKE} check )
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/misc/uuidgen ${PREFIX}/bin/