aboutsummaryrefslogtreecommitdiff
path: root/misc/earthview
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /misc/earthview
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
Notes
Diffstat (limited to 'misc/earthview')
-rw-r--r--misc/earthview/Makefile4
-rw-r--r--misc/earthview/files/patch-Makefile2
2 files changed, 3 insertions, 3 deletions
diff --git a/misc/earthview/Makefile b/misc/earthview/Makefile
index ee86d801b330..a85e0824609e 100644
--- a/misc/earthview/Makefile
+++ b/misc/earthview/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Produces a view output of an arbitrary region of the Earth
USE_XORG= xpm
-CFLAGS+= -I${X11BASE}/include
+CFLAGS+= -I${LOCALBASE}/include
ALL_TARGET= earthview
PLIST_FILES= bin/earthview share/earthview/topography/topography.cps \
@@ -29,7 +29,7 @@ PLIST_DIRS= share/earthview/topography share/earthview/population \
post-patch:
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" -e "s|%%CC%%|${CC}|g" \
- -e "s|%%CFLAGS%%|${CFLAGS}|g" -e "s|%%X11BASE%%|${X11BASE}|g" \
+ -e "s|%%CFLAGS%%|${CFLAGS}|g" -e "s|%%LOCALBASE%%|${LOCALBASE}|g" \
${WRKSRC}/Makefile
pre-build:
diff --git a/misc/earthview/files/patch-Makefile b/misc/earthview/files/patch-Makefile
index 8f1780581e3e..cfecbaacbf8f 100644
--- a/misc/earthview/files/patch-Makefile
+++ b/misc/earthview/files/patch-Makefile
@@ -11,7 +11,7 @@
earthview: earthview.c
- gcc -Wall -DDATADIR=\"$(DATADIR)\" earthview.c -o earthview -L/usr/X11R6/lib -lX11 -lm -lz -lbz2
-+ %%CC%% %%CFLAGS%% -DDATADIR=\"$(DATADIR)\" earthview.c -o earthview -L%%X11BASE%%/lib -lX11 -lm -lz -lbz2
++ %%CC%% %%CFLAGS%% -DDATADIR=\"$(DATADIR)\" earthview.c -o earthview -L%%LOCALBASE%%/lib -lX11 -lm -lz -lbz2
install:
install -c -s earthview $(BINDIR)