aboutsummaryrefslogtreecommitdiff
path: root/misc/esniper
diff options
context:
space:
mode:
authorThomas Abthorpe <tabthorpe@FreeBSD.org>2007-11-05 19:59:18 +0000
committerThomas Abthorpe <tabthorpe@FreeBSD.org>2007-11-05 19:59:18 +0000
commit1c9e17d05d9ee734bd169311013f85dc45b4ca01 (patch)
tree219f4fc165eb4b355babb08a4be0d11b7c145cef /misc/esniper
parent8deb6a4aca3f9315411473bba80c8cfdc0518d29 (diff)
downloadports-1c9e17d05d9ee734bd169311013f85dc45b4ca01.tar.gz
ports-1c9e17d05d9ee734bd169311013f85dc45b4ca01.zip
Notes
Diffstat (limited to 'misc/esniper')
-rw-r--r--misc/esniper/Makefile3
-rw-r--r--misc/esniper/files/patch-http.c20
2 files changed, 21 insertions, 2 deletions
diff --git a/misc/esniper/Makefile b/misc/esniper/Makefile
index 13e9b11d8de8..db64fd6c3870 100644
--- a/misc/esniper/Makefile
+++ b/misc/esniper/Makefile
@@ -7,8 +7,7 @@
PORTNAME= esniper
DISTVERSION= 2-17-1
CATEGORIES= misc net
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
EXTRACT_SUFX= .tgz
MAINTAINER= lewiz@compsoc.man.ac.uk
diff --git a/misc/esniper/files/patch-http.c b/misc/esniper/files/patch-http.c
new file mode 100644
index 000000000000..ee3e020377c5
--- /dev/null
+++ b/misc/esniper/files/patch-http.c
@@ -0,0 +1,20 @@
+--- http.c.orig Wed Oct 31 15:13:04 2007
++++ http.c Wed Oct 31 15:13:39 2007
+@@ -51,7 +51,7 @@
+ static int initCurlStuffFailed(void);
+
+ #ifdef NEED_CURL_EASY_STRERROR
+-static const char *curl_easy_strerror(CURLcode error);
++const char *curl_easy_strerror(CURLcode error);
+ #endif
+
+ /* Set auction error with full libcurl details */
+@@ -409,7 +409,7 @@
+ "Requested FTP SSL level failed", /* CURLE_FTP_SSL_FAILED */
+ };
+
+-static const char *
++const char *
+ curl_easy_strerror(CURLcode error)
+ {
+ if (error < 0 || error >= CURL_LAST ||