aboutsummaryrefslogtreecommitdiff
path: root/misc/exercism/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-05-11 18:34:57 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-05-11 18:34:57 +0000
commit88bfe4bd43787219ab4de75bd68c490c98776dfc (patch)
tree634e1ef4990207301493f26b46d80abe56b9f2b3 /misc/exercism/Makefile
parent9e8bfe9c71187ea60ac9f3a55c0c7bde80d76033 (diff)
Cleanup DIST* variables.
When appropriate: - Try to use DISTVERSION{SUF,PRE}FIX - Replace PORTNAME-PORTVERSION by DISTNAME - Convert MASTER_SITES to use macros - Other light cleanup With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=386097
Diffstat (limited to 'misc/exercism/Makefile')
-rw-r--r--misc/exercism/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/misc/exercism/Makefile b/misc/exercism/Makefile
index 0da4d5dced7d..77abc62f4f36 100644
--- a/misc/exercism/Makefile
+++ b/misc/exercism/Makefile
@@ -3,10 +3,11 @@
PORTNAME= exercism
PORTVERSION= 1.7.1
+DISTVERSIONPREFIX= v
CATEGORIES= misc
-MASTER_SITES= https://github.com/${PORTNAME}/cli/archive/v${PORTVERSION}.tar.gz?dummy=/:group1 \
+MASTER_SITES= \
https://codeload.github.com/codegangsta/cli/legacy.tar.gz/f7ebb76?dummy=/:group2
-DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:group1 \
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
codegansta-cli-f7ebb76${EXTRACT_SUFX}:group2
MAINTAINER= swills@FreeBSD.org
@@ -15,6 +16,8 @@ COMMENT= CLI client for exercism.io
BUILD_DEPENDS= ${LOCALBASE}/bin/go:${PORTSDIR}/lang/go
WRKSRC= ${WRKDIR}/cli-${PORTVERSION}
+USE_GITHUB= yes
+GH_PROJECT= cli
PLIST_FILES= bin/exercism