aboutsummaryrefslogtreecommitdiff
path: root/misc/explosions/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-08-08 17:56:08 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-08-08 17:56:08 +0000
commitd79868927d24c8557666cbb8cc2d4781981ef98d (patch)
treef244db904b1d3d7b9c5ab18d89b79595e1130f08 /misc/explosions/Makefile
parent39bd08f6a6157b09775a2a70230575ca594f68ad (diff)
Notes
Diffstat (limited to 'misc/explosions/Makefile')
-rw-r--r--misc/explosions/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/misc/explosions/Makefile b/misc/explosions/Makefile
new file mode 100644
index 000000000000..835811836c42
--- /dev/null
+++ b/misc/explosions/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: explosions
+# Date created: 8 August 2001
+# Whom: Pete Fritchman <petef@databits.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= explosions
+PORTVERSION= 0.2001.08.05
+CATEGORIES= misc
+MASTER_SITES= ftp://ftp.sonic.net/pub/users/nbs/unix/x/explosions/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/^0.//}
+
+MAINTAINER= petef@databits.net
+
+LIB_DEPENDS= SDL-1.1.3:${PORTSDIR}/devel/sdl12 \
+ SDL_image.10:${PORTSDIR}/graphics/sdl_image
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+
+SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
+
+post-patch:
+ @${PERL} -pi -e 's!CFLAGS=-Wall -O2!CFLAGS+=-Wall!; \
+ s!sdl-config!${SDL_CONFIG}!' \
+ ${WRKSRC}/Makefile
+ @${PERL} -pi -e 's!spark%d.png!${DATADIR}/spark%d.png!' \
+ ${WRKSRC}/explosions.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/explosions ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/spark?.png ${DATADIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in BUGS.txt CHANGES.txt README.txt
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>