aboutsummaryrefslogtreecommitdiff
path: root/misc/findutils
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2011-05-20 12:20:53 +0000
committerFrederic Culot <culot@FreeBSD.org>2011-05-20 12:20:53 +0000
commitbfd35bbb51486ceb466a84800db629aeb451d37f (patch)
tree01270c16a834ea62eaf09e33198ade1d901b8667 /misc/findutils
parent7dab3d2942dd42bc87fe29850fd626beccc1530e (diff)
downloadports-bfd35bbb51486ceb466a84800db629aeb451d37f.tar.gz
ports-bfd35bbb51486ceb466a84800db629aeb451d37f.zip
Notes
Diffstat (limited to 'misc/findutils')
-rw-r--r--misc/findutils/Makefile1
-rw-r--r--misc/findutils/files/patch-locate__updatedb.sh38
2 files changed, 39 insertions, 0 deletions
diff --git a/misc/findutils/Makefile b/misc/findutils/Makefile
index 1d868b4aa24f..295051cf989e 100644
--- a/misc/findutils/Makefile
+++ b/misc/findutils/Makefile
@@ -7,6 +7,7 @@
PORTNAME= findutils
PORTVERSION= 4.5.10
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_GNU_ALPHA}
MASTER_SITE_SUBDIR= findutils
diff --git a/misc/findutils/files/patch-locate__updatedb.sh b/misc/findutils/files/patch-locate__updatedb.sh
new file mode 100644
index 000000000000..4795680cbf4e
--- /dev/null
+++ b/misc/findutils/files/patch-locate__updatedb.sh
@@ -0,0 +1,38 @@
+--- locate/updatedb.sh.orig 2011-04-03 23:53:12.000000000 +0100
++++ locate/updatedb.sh 2011-05-17 18:20:29.000000000 +0100
+@@ -250,7 +250,7 @@
+ if test -n "$SEARCHPATHS"; then
+ if [ "$LOCALUSER" != "" ]; then
+ # : A1
+- su $LOCALUSER `select_shell $LOCALUSER` -c \
++ su -m $LOCALUSER -c \
+ "$find $SEARCHPATHS $FINDOPTIONS \
+ \\( $prunefs_exp \
+ -type d -regex '$PRUNEREGEX' \\) -prune -o $print_option"
+@@ -266,7 +266,7 @@
+ myuid=`getuid`
+ if [ "$myuid" = 0 ]; then
+ # : A3
+- su $NETUSER `select_shell $NETUSER` -c \
++ su -m $NETUSER -c \
+ "$find $NETPATHS $FINDOPTIONS \\( -type d -regex '$PRUNEREGEX' -prune \\) -o $print_option" ||
+ exit $?
+ else
+@@ -319,7 +319,7 @@
+ if test -n "$SEARCHPATHS"; then
+ if [ "$LOCALUSER" != "" ]; then
+ # : A5
+- su $LOCALUSER `select_shell $LOCALUSER` -c \
++ su -m $LOCALUSER -c \
+ "$find $SEARCHPATHS $FINDOPTIONS \
+ \( $prunefs_exp \
+ -type d -regex '$PRUNEREGEX' \) -prune -o $print_option" || exit $?
+@@ -335,7 +335,7 @@
+ myuid=`getuid`
+ if [ "$myuid" = 0 ]; then
+ # : A7
+- su $NETUSER `select_shell $NETUSER` -c \
++ su -m $NETUSER -c \
+ "$find $NETPATHS $FINDOPTIONS \\( -type d -regex '$PRUNEREGEX' -prune \\) -o $print_option" ||
+ exit $?
+ else