aboutsummaryrefslogtreecommitdiff
path: root/misc/firestring
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2002-11-09 00:37:57 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2002-11-09 00:37:57 +0000
commit7368c19fe14d50c44d079c12d5bab5e98d3695d5 (patch)
tree550276124c8f6a6567af44d92af263cb1cb79230 /misc/firestring
parent6e9b0f64df7cab61987201fae5c87ddcae213c28 (diff)
downloadports-7368c19fe14d50c44d079c12d5bab5e98d3695d5.tar.gz
ports-7368c19fe14d50c44d079c12d5bab5e98d3695d5.zip
Maintainer updates for misc/firestring and net/firedns (depending
on each other) PR: ports/44771,ports/44773 Submitted by: Dean Hollister <dean@odyssey.apana.org.au>
Notes
Notes: svn path=/head/; revision=69766
Diffstat (limited to 'misc/firestring')
-rw-r--r--misc/firestring/Makefile21
-rw-r--r--misc/firestring/distinfo2
-rw-r--r--misc/firestring/files/patch-configure11
-rw-r--r--misc/firestring/pkg-comment2
4 files changed, 23 insertions, 13 deletions
diff --git a/misc/firestring/Makefile b/misc/firestring/Makefile
index 8f4fe5820509..388a62c4bc64 100644
--- a/misc/firestring/Makefile
+++ b/misc/firestring/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= firestring
-PORTVERSION= 0.1.21
-CATEGORIES= misc net
+PORTVERSION= 0.1.22
+CATEGORIES= misc net devel
MASTER_SITES= http://ares.penguinhosting.net/~ian/projects/ \
http://www.wa.apana.org.au/~dean/sources/ \
ftp://ftp.wa.apana.org.au/pub/pc/unix/packages/
@@ -27,14 +27,15 @@ MAN3= firestring_chomp.3 firestring_chug.3 firestring_concat.3 \
firestring_estr_base64_encode.3 firestring_estr_ends.3 \
firestring_estr_estrcasecmp.3 firestring_estr_estrcat.3 \
firestring_estr_estrcmp.3 firestring_estr_estrcpy.3 \
- firestring_estr_estristr.3 firestring_estr_estrncasecmp.3 \
- firestring_estr_estrstr.3 firestring_estr_expand.3 \
- firestring_estr_free.3 firestring_estr_read.3 \
- firestring_estr_sprintf.3 firestring_estr_starts.3 \
- firestring_estr_strcasecmp.3 firestring_estr_strcat.3 \
- firestring_estr_strchr.3 firestring_estr_strcmp.3 \
- firestring_estr_strcpy.3 firestring_estr_stristr.3 \
- firestring_estr_strstr.3 firestring_estr_xml_decode.3 \
+ firestring_estr_estristr.3 \
+ firestring_estr_estrncasecmp.3 firestring_estr_estrstr.3 \
+ firestring_estr_expand.3 firestring_estr_free.3 \
+ firestring_estr_read.3 firestring_estr_sprintf.3 \
+ firestring_estr_starts.3 firestring_estr_strcasecmp.3 \
+ firestring_estr_strcat.3 firestring_estr_strchr.3 \
+ firestring_estr_strcmp.3 firestring_estr_strcpy.3 \
+ firestring_estr_stristr.3 firestring_estr_strstr.3 \
+ firestring_estr_xml_decode.3 \
firestring_estr_xml_encode.3 firestring_hextoi.3 \
firestring_malloc.3 firestring_realloc.3 \
firestring_snprintf.3 firestring_strcasecmp.3 \
diff --git a/misc/firestring/distinfo b/misc/firestring/distinfo
index d1ddc3585867..e7c8298c116d 100644
--- a/misc/firestring/distinfo
+++ b/misc/firestring/distinfo
@@ -1 +1 @@
-MD5 (firestring-0.1.21.tar.gz) = 24373e9973406af7dae65414534e4bed
+MD5 (firestring-0.1.22.tar.gz) = c9e65fa76d1fffcd01d8052ba4231616
diff --git a/misc/firestring/files/patch-configure b/misc/firestring/files/patch-configure
index 45cd38f77814..c5905d7a7b1a 100644
--- a/misc/firestring/files/patch-configure
+++ b/misc/firestring/files/patch-configure
@@ -1,5 +1,5 @@
--- configure.orig Sun Sep 22 06:37:40 2002
-+++ configure Tue Oct 15 17:22:58 2002
++++ configure Thu Oct 31 12:44:24 2002
@@ -322,7 +322,7 @@
$ECHO "INCLUDEDIR ?= \$(PREFIX)/include" >> Makefile
$ECHO "MANDIR ?= \$(PREFIX)/man" >> Makefile
@@ -36,6 +36,15 @@
$ECHO "done"
done;
$ECHO >> Makefile
+@@ -556,7 +556,7 @@
+ $ECHO "install-headers: $HEADERS" >> Makefile
+ for HEADER in $HEADERS; do
+ $ECHO -n " adding rule to install header $HEADER..."
+- $ECHO " ./install.sh $HEADER \$(INCLUDEDIR) \$(INSTALL_USER) \$(INSTALL_GROUP) 0644" >> Makefile
++ $ECHO " ./install.sh $HEADER \$(PREFIX)/include \$(INSTALL_USER) \$(INSTALL_GROUP) 0644" >> Makefile
+ $ECHO "done"
+ done;
+ $ECHO >> Makefile
@@ -569,7 +569,7 @@
if test "$LS" != ""; then
$ECHO $LS >> Makefile
diff --git a/misc/firestring/pkg-comment b/misc/firestring/pkg-comment
index 1ea9624a3db5..7446573a9866 100644
--- a/misc/firestring/pkg-comment
+++ b/misc/firestring/pkg-comment
@@ -1 +1 @@
-A library that provides maximum length aware string handling functions
+A library to make string handling easier in C