aboutsummaryrefslogtreecommitdiff
path: root/misc/flashlight/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-03-15 10:17:16 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-03-15 10:18:40 +0000
commitc15247cb4f6446b22b6c122dffba9f598c8f1b90 (patch)
tree2bed470ca2c9dba279dc08be9d1fa7cfff3ef0cf /misc/flashlight/Makefile
parent3f9d30d7279954888d1c470968347a6de3eed69e (diff)
downloadports-c15247cb4f6446b22b6c122dffba9f598c8f1b90.tar.gz
ports-c15247cb4f6446b22b6c122dffba9f598c8f1b90.zip
Diffstat (limited to 'misc/flashlight/Makefile')
-rw-r--r--misc/flashlight/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/misc/flashlight/Makefile b/misc/flashlight/Makefile
new file mode 100644
index 000000000000..307c867c7b0e
--- /dev/null
+++ b/misc/flashlight/Makefile
@@ -0,0 +1,31 @@
+PORTNAME= flashlight
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.4.0-16
+DISTVERSIONSUFFIX= -gafcd364e
+CATEGORIES= misc # machine-learning
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Standalone C++ library for machine learning
+WWW= https://github.com/flashlight/flashlight
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= cereal>0:devel/cereal
+LIB_DEPENDS= libdnnl.so:math/onednn252
+
+USES= cmake:testing compiler:c++17-lang localbase pkgconfig
+USE_GITHUB= yes
+USE_LDCONFIG= yes
+
+CMAKE_OFF= FL_USE_ARRAYFIRE \
+ FL_BUILD_TESTS FL_BUILD_EXAMPLES
+CMAKE_OFF+= FL_BUILD_DISTRIBUTED # need to add MPI options
+CMAKE_ON= BUILD_SHARED_LIBS \
+ FL_USE_CPU
+CMAKE_ON+= FL_USE_ONEDNN # needs to have oneDNN enabled because it needs a working tensor backend
+
+post-patch: # workaround for https://github.com/flashlight/flashlight/issues/1086
+ @${RM} ${WRKSRC}/cmake/Findcereal.cmake
+
+.include <bsd.port.mk>