aboutsummaryrefslogtreecommitdiff
path: root/misc/fortuneit/Makefile
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2006-11-04 08:12:32 +0000
committerAlex Dupre <ale@FreeBSD.org>2006-11-04 08:12:32 +0000
commitd34ce65633b49bf5bf2e2827f95e5bf3e2451406 (patch)
treea2f0c337cd50b344162ad2727ce6f7c6a93ce591 /misc/fortuneit/Makefile
parent136facb65afa7275866b6a41521a043cd64d7dd3 (diff)
Notes
Diffstat (limited to 'misc/fortuneit/Makefile')
-rw-r--r--misc/fortuneit/Makefile62
1 files changed, 23 insertions, 39 deletions
diff --git a/misc/fortuneit/Makefile b/misc/fortuneit/Makefile
index 703608c1ebd0..5ec624d17f1b 100644
--- a/misc/fortuneit/Makefile
+++ b/misc/fortuneit/Makefile
@@ -6,61 +6,45 @@
#
PORTNAME= fortuneit
-PORTVERSION= 1.51
-PORTREVISION= 1
+PORTVERSION= 1.99
CATEGORIES= misc
-MASTER_SITES= http://www.giovannelli.it/~gmarco/files/
-DISTNAME= fortune.it-${PORTVERSION}
+MASTER_SITES= http://utenti.gufi.org/~gmarco/files/distfiles/
+DISTNAME= fortune-it-${PORTVERSION}
-MAINTAINER= gmarco@giovannelli.it
+MAINTAINER= gmarco@gufi.org
COMMENT= A very funny fortune file in Italian
-NO_BUILD= yes
-
STRCMD= /usr/games/strfile
-.if defined(INSTALL_OFFENSIVE)
-PLIST= ${PKGDIR}/pkg-plist.off
-.endif
+FORTUNEFILES= adams banner computer definizioni formiche italia itatrek \
+ jackfr leggi luke luttazzi norm paolotedeschi zuse \
+ computer-o definizioni-o film-o italia-o jackfr-o leggi-o \
+ luttazzi-o obsc-o zuse-o
-pre-fetch:
-.if !defined(INSTALL_OFFENSIVE)
- @${ECHO_MSG} ""
- @${ECHO_MSG} "If you want to install potentially offensive italian"
- @${ECHO_MSG} "fortunes \"make INSTALL_OFFENSIVE=yes\""
- @${ECHO_MSG} ""
-.else
- @${ECHO_MSG} ""
- @${ECHO_MSG} "Potentially offensive fortunes will be installed"
- @${ECHO_MSG} ""
+pre-build:
+.if !exists(${STRCMD})
+ @${ECHO_MSG} "Please install the games distribution"
+ @exit 1
.endif
+do-build:
+.for f in ${FORTUNEFILES}
+ ${STRCMD} ${WRKSRC}/testi/${f}
+.endfor
+
do-install:
@${MKDIR} ${PREFIX}/share/games
@${MKDIR} ${PREFIX}/share/games/fortune
- @${INSTALL_DATA} ${WRKSRC}/italia ${PREFIX}/share/games/fortune
-.if defined(INSTALL_OFFENSIVE)
- @${INSTALL_DATA} ${WRKSRC}/zozzital ${PREFIX}/share/games/fortune
-.endif
-
-pre-install:
-.if !exists(${STRCMD})
- @ ${ECHO_MSG} "Please install the games distribution"
- @ exit 1
-.endif
+.for f in ${FORTUNEFILES}
+ @${INSTALL_DATA} ${WRKSRC}/testi/${f}* ${PREFIX}/share/games/fortune
+.endfor
post-install:
- @${STRCMD} ${PREFIX}/share/games/fortune/italia
-.if defined(INSTALL_OFFENSIVE)
- @${STRCMD} ${PREFIX}/share/games/fortune/zozzital
-.endif
@${ECHO_MSG} ""
@${ECHO_MSG} "Usage:"
- @${ECHO_MSG} "/usr/games/fortune ${PREFIX}/share/games/fortune/italia"
-.if defined(INSTALL_OFFENSIVE)
- @${ECHO_MSG} "or"
- @${ECHO_MSG} "/usr/games/fortune ${PREFIX}/share/games/fortune/zozzital"
-.endif
+ @${ECHO_MSG} "/usr/games/fortune [-aDefilosw] ${PREFIX}/share/games/fortune/"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Please check fortune manual pages for more informations"
@${ECHO_MSG} ""
.include <bsd.port.mk>