aboutsummaryrefslogtreecommitdiff
path: root/misc/freebsd-doc-en
diff options
context:
space:
mode:
authorMarc Fonvieille <blackend@FreeBSD.org>2013-11-19 18:52:13 +0000
committerMarc Fonvieille <blackend@FreeBSD.org>2013-11-19 18:52:13 +0000
commitbdd46fabc66e3190e14034370f7514239d874704 (patch)
treee9b610cb3f7fa7c2de7b2b5a93de83162d13d204 /misc/freebsd-doc-en
parentb9a7f3ab064aff0c9b48e9f4d14cf3d45f3fdc7f (diff)
downloadports-bdd46fabc66e3190e14034370f7514239d874704.tar.gz
ports-bdd46fabc66e3190e14034370f7514239d874704.zip
Notes
Diffstat (limited to 'misc/freebsd-doc-en')
-rw-r--r--misc/freebsd-doc-en/Makefile76
-rw-r--r--misc/freebsd-doc-en/distinfo4
-rw-r--r--misc/freebsd-doc-en/pkg-plist.html-split13
3 files changed, 37 insertions, 56 deletions
diff --git a/misc/freebsd-doc-en/Makefile b/misc/freebsd-doc-en/Makefile
index 54f1400243bc..215e8592a400 100644
--- a/misc/freebsd-doc-en/Makefile
+++ b/misc/freebsd-doc-en/Makefile
@@ -1,32 +1,8 @@
# Created by: Marc Fonvieille <blackend@FreeBSD.org>
# $FreeBSD$
-# Several knobs can be used to select the documentation formats.
-#
-# WITH_HTML_SPLIT allows the build of the "html-split" format:
-# This is the default format, it is the same format used on
-# www.FreeBSD.org. It is a collection of small, linked HTML files
-# (index.html, plus images and secondary files).
-#
-# WITH_HTML allows the build of the "html" format:
-# a single HTML file per document (article.html or book.html, as
-# appropriate, plus images).
-#
-# WITH_PDF allows the build of the "pdf" format:
-# Adobe Portable Document Format, for use with Adobe
-# Acrobat Reader or Ghostscript (article.pdf or book.pdf, as
-# appropriate).
-#
-# WITH_PS allows the build of the "ps" format:
-# Postscript (article.ps or book.ps, as appropriate).
-#
-# WITH_TXT allows the build of the "txt" format:
-# Plain text (article.txt or book.txt, as appropriate).
-#
-
PORTNAME= freebsd-doc
-PORTVERSION= 43088
-PORTREVISION= 1
+PORTVERSION= 43207
PORTEPOCH= 1
CATEGORIES= misc docs
MASTER_SITES= LOCAL/blackend
@@ -35,6 +11,15 @@ PKGNAMEPREFIX?= en-
MAINTAINER= doceng@FreeBSD.org
COMMENT?= Documentation from the FreeBSD Documentation Project
+BUILD_DEPENDS= docproj>=2.0_1:${PORTSDIR}/textproc/docproj \
+ fop:${PORTSDIR}/textproc/fop \
+ ${LOCALBASE}/lib/X11/fonts/GentiumPlus/GentiumPlus-R.ttf:${PORTSDIR}/x11-fonts/gentium-plus \
+ ${LOCALBASE}/lib/X11/fonts/Droid/DroidSans.ttf:${PORTSDIR}/x11-fonts/droid-fonts-ttf \
+ ${LOCALBASE}/lib/X11/fonts/Lohit/Lohit-Bengali.ttf:${PORTSDIR}/x11-fonts/lohit \
+ ${LOCALBASE}/lib/X11/fonts/dejavu/DejaVuSansMono.ttf:${PORTSDIR}/x11-fonts/dejavu \
+ ${LOCALBASE}/share/fonts/TrueType/gkai00mp.ttf:${PORTSDIR}/chinese/arphicttf \
+ ${LOCALBASE}/share/fonts/OTF/ipam.otf:${PORTSDIR}/japanese/font-ipa
+
WRKSRC= ${WRKDIR}/doc
PLIST_SUB= DOCSDIR=${DOCBASE} \
DOCLANG=${DOCLANG} \
@@ -45,14 +30,17 @@ MAKE_ARGS= FORMATS="${DOCFORMAT}" \
DOCDIR=${PREFIX}/${DOCBASE} \
DOCOWN=${SHAREOWN} \
DOCGRP=${SHAREGRP}
+MAKE_JOBS_UNSAFE= yes
+PLIST= ${WRKDIR}/pkg-plist
+NO_STAGE= yes
DOCLANG?= en_US.ISO8859-1
DOCLANG_PREFIX?= ${DOCLANG:C/_.*$//}
DOCBASE?= share/doc/freebsd
-PLIST= ${WRKDIR}/pkg-plist
+AVAILABLEFORMATS= HTML HTML_SPLIT PDF PS TXT
-OPTIONS_DEFINE= HTML HTML_SPLIT PDF PS TXT
+OPTIONS_DEFINE= ${AVAILABLEFORMATS}
OPTIONS_DEFAULT= HTML_SPLIT PDF
HTML_DESC= Single HTML file per document
HTML_SPLIT_DESC= The default HTML format used on www.FreeBSD.org
@@ -60,38 +48,18 @@ PDF_DESC= PDF format
PS_DESC= PostScript format
TXT_DESC= Plain text
-NO_STAGE= yes
-
-.include <bsd.port.pre.mk>
-
-AVAILABLEFORMATS= HTML HTML_SPLIT PDF PS TXT
-
# if PACKAGE_BUILDING=yes, enable all of $AVAILABLEFORMATS.
.if defined(PACKAGE_BUILDING)
-.for F in ${AVAILABLEFORMATS}
-WITH_${F}= yes
-.endfor
+OPTIONS_SET+= ${AVAILABLEFORMATS}
.endif
-# translate "WITH_FOO=yes" into "DOCFORMAT+=FOO".
-.for F in ${AVAILABLEFORMATS}
-.if ${PORT_OPTIONS:M${F}}
-DOCFORMAT+= ${F:L:S,_,-,}
-.endif
-.endfor
+.include <bsd.port.options.mk>
-# set a default value when DOCFORMAT is empty
-.if empty(DOCFORMAT)
-DOCFORMAT= html-split
-WITH_HTML_SPLIT= yes
+.for O in ${AVAILABLEFORMATS}
+.if ${PORT_OPTIONS:M${O}}
+DOCFORMAT+= ${O:L:S,_,-,}
+PLIST_FORMATS+= ${O:L:S,_,-,}
.endif
-
-BUILD_DEPENDS= docproj>=1.17:${PORTSDIR}/textproc/docproj
-
-MAKE_JOBS_UNSAFE= yes
-
-.for F in ${DOCFORMAT:L}
-PLIST_FORMATS+= ${F:L}
.endfor
# when html or html-split is defined as the format, add HTML_COMMON.
@@ -106,4 +74,4 @@ PLIST_FORMATS+= extras common
pre-build:
${CAT} ${PLIST_FORMATS:S,^,${.CURDIR}/pkg-plist.,} > ${PLIST}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/misc/freebsd-doc-en/distinfo b/misc/freebsd-doc-en/distinfo
index 80d30c450be5..e2ed29390fee 100644
--- a/misc/freebsd-doc-en/distinfo
+++ b/misc/freebsd-doc-en/distinfo
@@ -1,2 +1,2 @@
-SHA256 (freebsd-doc-43088.tar.gz) = a14e836ab77af926ceb191a489743e659a14d633a4fb4326e8d1f0dede30b23e
-SIZE (freebsd-doc-43088.tar.gz) = 32625230
+SHA256 (freebsd-doc-43207.tar.gz) = e23f3c868aa9b43c5d4303549932a0d3412359a9a212dd81bb87776bb3ac8db0
+SIZE (freebsd-doc-43207.tar.gz) = 32790777
diff --git a/misc/freebsd-doc-en/pkg-plist.html-split b/misc/freebsd-doc-en/pkg-plist.html-split
index 37cfaf30d2f5..eda57f1288b2 100644
--- a/misc/freebsd-doc-en/pkg-plist.html-split
+++ b/misc/freebsd-doc-en/pkg-plist.html-split
@@ -25,6 +25,7 @@
%%DOCSDIR%%/%%DOCLANG%%/articles/casestudy-argentina.com/results.html
%%DOCSDIR%%/%%DOCLANG%%/articles/casestudy-argentina.com/trademarks.html
%%DOCSDIR%%/%%DOCLANG%%/articles/committers-guide/archs.html
+%%DOCSDIR%%/%%DOCLANG%%/articles/committers-guide/commit-log-message.html
%%DOCSDIR%%/%%DOCLANG%%/articles/committers-guide/committer.types.html
%%DOCSDIR%%/%%DOCLANG%%/articles/committers-guide/conventions.html
%%DOCSDIR%%/%%DOCLANG%%/articles/committers-guide/coverity.html
@@ -53,6 +54,7 @@
%%DOCSDIR%%/%%DOCLANG%%/articles/console-server/conserver-versions.html
%%DOCSDIR%%/%%DOCLANG%%/articles/console-server/freebsd.html
%%DOCSDIR%%/%%DOCLANG%%/articles/console-server/index.html
+%%DOCSDIR%%/%%DOCLANG%%/articles/console-server/ix01.html
%%DOCSDIR%%/%%DOCLANG%%/articles/console-server/links.html
%%DOCSDIR%%/%%DOCLANG%%/articles/console-server/manpages.html
%%DOCSDIR%%/%%DOCLANG%%/articles/console-server/our-solution.html
@@ -65,6 +67,7 @@
%%DOCSDIR%%/%%DOCLANG%%/articles/contributing-ports/create-port.html
%%DOCSDIR%%/%%DOCLANG%%/articles/contributing-ports/fix-broken.html
%%DOCSDIR%%/%%DOCLANG%%/articles/contributing-ports/index.html
+%%DOCSDIR%%/%%DOCLANG%%/articles/contributing-ports/ix01.html
%%DOCSDIR%%/%%DOCLANG%%/articles/contributing-ports/maintain-port.html
%%DOCSDIR%%/%%DOCLANG%%/articles/contributing-ports/mortal-coil.html
%%DOCSDIR%%/%%DOCLANG%%/articles/contributing-ports/resources.html
@@ -72,6 +75,7 @@
%%DOCSDIR%%/%%DOCLANG%%/articles/contributing-ports/what-contribute.html
%%DOCSDIR%%/%%DOCLANG%%/articles/contributing/contrib-how.html
%%DOCSDIR%%/%%DOCLANG%%/articles/contributing/index.html
+%%DOCSDIR%%/%%DOCLANG%%/articles/contributing/ix01.html
%%DOCSDIR%%/%%DOCLANG%%/articles/contributing/trademarks.html
%%DOCSDIR%%/%%DOCLANG%%/articles/contributors/contrib-386bsd.html
%%DOCSDIR%%/%%DOCLANG%%/articles/contributors/contrib-additional.html
@@ -81,9 +85,11 @@
%%DOCSDIR%%/%%DOCLANG%%/articles/contributors/contrib-develinmemoriam.html
%%DOCSDIR%%/%%DOCLANG%%/articles/contributors/contrib-portmgralumni.html
%%DOCSDIR%%/%%DOCLANG%%/articles/contributors/index.html
+%%DOCSDIR%%/%%DOCLANG%%/articles/contributors/ix01.html
%%DOCSDIR%%/%%DOCLANG%%/articles/contributors/staff-committers.html
%%DOCSDIR%%/%%DOCLANG%%/articles/contributors/trademarks.html
%%DOCSDIR%%/%%DOCLANG%%/articles/cups/index.html
+%%DOCSDIR%%/%%DOCLANG%%/articles/cups/ix01.html
%%DOCSDIR%%/%%DOCLANG%%/articles/cups/printing-cups-clients.html
%%DOCSDIR%%/%%DOCLANG%%/articles/cups/printing-cups-configuring-printers.html
%%DOCSDIR%%/%%DOCLANG%%/articles/cups/printing-cups-configuring-server.html
@@ -229,6 +235,7 @@
%%DOCSDIR%%/%%DOCLANG%%/articles/mh/trademarks.html
%%DOCSDIR%%/%%DOCLANG%%/articles/nanobsd/howto.html
%%DOCSDIR%%/%%DOCLANG%%/articles/nanobsd/index.html
+%%DOCSDIR%%/%%DOCLANG%%/articles/nanobsd/ix01.html
%%DOCSDIR%%/%%DOCLANG%%/articles/nanobsd/trademarks.html
%%DOCSDIR%%/%%DOCLANG%%/articles/new-users/adding-a-user.html
%%DOCSDIR%%/%%DOCLANG%%/articles/new-users/comments-welcome.html
@@ -300,6 +307,7 @@
%%DOCSDIR%%/%%DOCLANG%%/articles/pr-guidelines/references.html
%%DOCSDIR%%/%%DOCLANG%%/articles/pr-guidelines/trademarks.html
%%DOCSDIR%%/%%DOCLANG%%/articles/problem-reports/index.html
+%%DOCSDIR%%/%%DOCLANG%%/articles/problem-reports/ix01.html
%%DOCSDIR%%/%%DOCLANG%%/articles/problem-reports/pr-followup.html
%%DOCSDIR%%/%%DOCLANG%%/articles/problem-reports/pr-further.html
%%DOCSDIR%%/%%DOCLANG%%/articles/problem-reports/pr-prep.html
@@ -392,6 +400,7 @@
%%DOCSDIR%%/%%DOCLANG%%/books/arch-handbook/isa-driver-resources.html
%%DOCSDIR%%/%%DOCLANG%%/books/arch-handbook/isa-driver-shutdown.html
%%DOCSDIR%%/%%DOCLANG%%/books/arch-handbook/isa-driver.html
+%%DOCSDIR%%/%%DOCLANG%%/books/arch-handbook/ix01.html
%%DOCSDIR%%/%%DOCLANG%%/books/arch-handbook/jail-restrictions.html
%%DOCSDIR%%/%%DOCLANG%%/books/arch-handbook/jail.html
%%DOCSDIR%%/%%DOCLANG%%/books/arch-handbook/kernel-objects-operation.html
@@ -510,6 +519,7 @@
%%DOCSDIR%%/%%DOCLANG%%/books/developers-handbook/introduction.html
%%DOCSDIR%%/%%DOCLANG%%/books/developers-handbook/ipc.html
%%DOCSDIR%%/%%DOCLANG%%/books/developers-handbook/ipv6.html
+%%DOCSDIR%%/%%DOCLANG%%/books/developers-handbook/ix01.html
%%DOCSDIR%%/%%DOCLANG%%/books/developers-handbook/kernel.html
%%DOCSDIR%%/%%DOCLANG%%/books/developers-handbook/kernelbuild-new.html
%%DOCSDIR%%/%%DOCLANG%%/books/developers-handbook/kernelbuild.html
@@ -611,6 +621,7 @@
%%DOCSDIR%%/%%DOCLANG%%/books/fdp-primer/examples-formatted.html
%%DOCSDIR%%/%%DOCLANG%%/books/fdp-primer/examples.html
%%DOCSDIR%%/%%DOCLANG%%/books/fdp-primer/index.html
+%%DOCSDIR%%/%%DOCLANG%%/books/fdp-primer/ix01.html
%%DOCSDIR%%/%%DOCLANG%%/books/fdp-primer/legalnotice.html
%%DOCSDIR%%/%%DOCLANG%%/books/fdp-primer/make-includes.html
%%DOCSDIR%%/%%DOCLANG%%/books/fdp-primer/overview-quick-start.html
@@ -795,6 +806,7 @@
%%DOCSDIR%%/%%DOCLANG%%/books/handbook/install.html
%%DOCSDIR%%/%%DOCLANG%%/books/handbook/introduction.html
%%DOCSDIR%%/%%DOCLANG%%/books/handbook/ipsec.html
+%%DOCSDIR%%/%%DOCLANG%%/books/handbook/ix01.html
%%DOCSDIR%%/%%DOCLANG%%/books/handbook/jails-application.html
%%DOCSDIR%%/%%DOCLANG%%/books/handbook/jails-build.html
%%DOCSDIR%%/%%DOCLANG%%/books/handbook/jails-intro.html
@@ -827,6 +839,7 @@
%%DOCSDIR%%/%%DOCLANG%%/books/handbook/mac-modules.html
%%DOCSDIR%%/%%DOCLANG%%/books/handbook/mac-partition.html
%%DOCSDIR%%/%%DOCLANG%%/books/handbook/mac-planning.html
+%%DOCSDIR%%/%%DOCLANG%%/books/handbook/mac-policies.html
%%DOCSDIR%%/%%DOCLANG%%/books/handbook/mac-portacl.html
%%DOCSDIR%%/%%DOCLANG%%/books/handbook/mac-seeotheruids.html
%%DOCSDIR%%/%%DOCLANG%%/books/handbook/mac-troubleshoot.html